Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Upgrade to 1.4 issue with Mage_Core_Modules
 
soundtraxx
Jr. Member
 
Avatar
Total Posts:  20
Joined:  2010-02-08
Red Wing, MN USA
 

I un-installed my 1.3.2.4 version and installed a clean version of 1.4. In Magento connect I looked for upgrades to my installs and found a few. One of them “ Mage_Core_Modules “ would not upgrade and remained at version 1.3.2.4.?

It gave me the error message below?

magento-core/interface_frontend_default_modern requires package “magento-core/Mage_Core_Modules” (version >= 1.3.2.2, version <= 1.3.3, excluded versions: 1.3.3), downloaded version is 1.4.0.0
magento-core/Mage_Core_Modules cannot be installed, conflicts with installed packages
Install Errors
No valid packages found
PEAR ERROR: upgrade failed

 
Magento Community Magento Community
Magento Community
Magento Community
 
andcorp
Jr. Member
 
Total Posts:  18
Joined:  2009-07-19
 

I am having the same problem with everything..

magento-core/interface_frontend_default_default_blue requires package “magento-core/Interface_Frontend_Default” (version >= 1.3.1, version <= 1.4.0, excluded versions: 1.4.0), downloaded version is 1.4.0.0
magento-core/Interface_Frontend_Default cannot be installed, conflicts with installed packages
magento-core/Mage_All_Latest requires package “magento-core/Interface_Frontend_Default” (version >= 1.4.0.0, version <= 1.4.0.0), installed version is 1.3.2.2
magento-core/interface_frontend_default requires package “magento-core/Mage_Core_Modules” (version >= 1.3.2.2, version <= 1.3.3, excluded versions: 1.3.3), downloaded version is 1.4.0.0
magento-core/mage_all_latest requires package “magento-core/Mage_Core_Modules” (version >= 1.3.2.4, version <= 1.3.2.4), downloaded version is 1.4.0.0
magento-core/Mage_Core_Modules cannot be installed, conflicts with installed packages
magento-core/mage_all_latest requires package “magento-core/Mage_Core_Adminhtml” (version >= 1.3.2.4, version <= 1.3.2.4), downloaded version is 1.4.0.0
magento-core/Mage_Core_Adminhtml cannot be installed, conflicts with installed packages
magento-core/mage_all_latest requires package “magento-core/Interface_Adminhtml_Default” (version >= 1.3.2.2, version <= 1.3.2.2), downloaded version is 1.4.0.0
magento-core/Interface_Adminhtml_Default cannot be installed, conflicts with installed packages
magento-core/mage_all_latest requires package “magento-core/Interface_Install_Default” (version >= 1.3.2, version <= 1.3.2), downloaded version is 1.4.0.0
magento-core/Interface_Install_Default cannot be installed, conflicts with installed packages
magento-core/mage_all_latest requires package “magento-core/Mage_Downloader” (version >= 1.3.2.1, version <= 1.3.2.1), downloaded version is 1.4.0.0
magento-core/Mage_Downloader cannot be installed, conflicts with installed packages
magento-core/Mage_Centinel requires package “magento-core/Mage_Core_Modules” (version >= 1.4.0.0, version <= 1.4.1, excluded versions: 1.4.1), installed version is 1.3.2.4
magento-core/Interface_Frontend_Base_Default requires package “magento-core/Mage_Core_Modules” (version >= 1.4.0.0, version <= 1.4.1, excluded versions: 1.4.1), installed version is 1.3.2.4
magento-core/mage_core_modules requires package “magento-core/Lib_Varien” (version >= 1.3.2.2, version <= 1.3.3, excluded versions: 1.3.3), downloaded version is 1.4.0.0
magento-core/Lib_Varien cannot be installed, conflicts with installed packages
magento-core/mage_core_modules requires package “magento-core/Lib_Google_Checkout” (version >= 1.2.0, version <= 1.3.3, excluded versions: 1.3.3), downloaded version is 1.4.0.0
magento-core/Lib_Google_Checkout cannot be installed, conflicts with installed packages
magento-core/mage_core_adminhtml requires package “magento-core/Lib_Js_Calendar” (version >= 1.3.2, version <= 1.3.2), downloaded version is 1.51.0
magento-core/mage_core_modules requires package “magento-core/Lib_Js_Calendar” (version >= 1.3.2, version <= 1.3.3, excluded versions: 1.3.3), downloaded version is 1.51.0
magento-core/Lib_Js_Calendar cannot be installed, conflicts with installed packages
magento-core/mage_core_modules requires package “magento-core/Lib_Js_Mage” (version >= 1.3.2.3, version <= 1.3.3, excluded versions: 1.3.3), downloaded version is 1.4.0.0
magento-core/Lib_Js_Mage cannot be installed, conflicts with installed packages
magento-core/mage_downloader requires package “magento-core/Lib_Js_Prototype” (version >= 1.3.1, version <= 1.4.0, excluded versions: 1.4.0), downloaded version is 1.6.0.3.0
magento-core/lib_js_mage requires package “magento-core/Lib_Js_Prototype” (version >= 1.3.2, version <= 1.3.3, excluded versions: 1.3.3), downloaded version is 1.6.0.3.0
magento-core/mage_core_modules requires package “magento-core/Lib_Js_Prototype” (version >= 1.3.2, version <= 1.3.3, excluded versions: 1.3.3), downloaded version is 1.6.0.3.0
magento-core/Lib_Js_Prototype cannot be installed, conflicts with installed packages
magento-core/mage_core_modules requires package “magento-core/Lib_PEAR” (version >= 1.3.1, version <= 1.3.3, excluded versions: 1.3.3), downloaded version is 1.4.0.0
magento-core/Lib_PEAR cannot be installed, conflicts with installed packages
magento-core/mage_core_adminhtml requires package “magento-core/Lib_Js_Ext” (version >= 1.0.18800, version <= 1.0.18800), downloaded version is 1.4.0.0
magento-core/interface_adminhtml_default requires package “magento-core/Lib_Js_Ext” (version >= 1.0.18800, version <= 1.0.18800), downloaded version is 1.4.0.0
magento-core/Lib_Js_Ext cannot be installed, conflicts with installed packages
magento-core/mage_core_adminhtml requires package “magento-core/Lib_LinLibertineFont” (version >= 1.1.1, version <= 1.1.1), downloaded version is 2.8.14.0
magento-core/Lib_LinLibertineFont cannot be installed, conflicts with installed packages
magento-core/lib_varien requires package “magento-core/Lib_ZF” (version >= 1.7.2.4, version <= 1.7.3, excluded versions: 1.7.3), downloaded version is 1.9.6.0
magento-core/Lib_ZF cannot be installed, conflicts with installed packages
magento-core/lib_zf requires package “magento-core/Lib_ZF_Locale” (version >= 1.7.2.2, version <= 1.7.3, excluded versions: 1.7.3), downloaded version is 1.9.6.0
magento-core/Lib_ZF_Locale cannot be installed, conflicts with installed packages
Install Errors
No valid packages found
PEAR ERROR: install failed

 
Magento Community Magento Community
Magento Community
Magento Community
 
Joel of MMCC
Jr. Member
 
Total Posts:  13
Joined:  2009-04-10
 

The only upgrade that worked for me was the TinyMCE (“Lib_Js_TinyMCE v. 3.2.5.0 (stable)”), which of course does nothing without the rest of it.
Given some of the other threads over the past three days, though, I think I should count my blessings!  hmmm

Hey, Varien, about your use of the word “stable” — well, this guy says it best!

 
Magento Community Magento Community
Magento Community
Magento Community
 
hidonet
Member
 
Avatar
Total Posts:  52
Joined:  2008-03-25
Istanbul
 

Same error occured in my update process… All modules updated but Mage_Core_Modules not.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Gummi
Jr. Member
 
Total Posts:  25
Joined:  2008-02-12
 

I’m having troubles with everything like andcorp. Has anyone found a solution to this problem?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Baskettcase
Member
 
Total Posts:  48
Joined:  2008-05-08
 

I also would like to know if anyone has figured a way around this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Baskettcase
Member
 
Total Posts:  48
Joined:  2008-05-08
 

Ok I figured this one out. You need to uninstall the templates that say that they require the core modules. So for example the first person, soundtraxx, would need to uninstall magento-core/interface_frontend_default_modern and “andcorp” would need to uninstall magento-core/interface_frontend_default_default_blue

Once I did that everything worked out well for the upgrade.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Gummi
Jr. Member
 
Total Posts:  25
Joined:  2008-02-12
 

I’ve managed to get through the errors with this

./pear install -f magento-core/Mage_All_Latest
./pear install -f magento-core/Mage_Core_Modules
./pear upgrade-all
 
Magento Community Magento Community
Magento Community
Magento Community
 
lichal
Jr. Member
 
Total Posts:  12
Joined:  2010-02-16
 
Flicker - 10 March 2010 03:22 PM

I’ve managed to get through the errors with this

./pear install -f magento-core/Mage_All_Latest
./pear install -f magento-core/Mage_Core_Modules
./pear upgrade-all

That worked for me. Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
blst
Jr. Member
 
Total Posts:  8
Joined:  2009-06-05
 

hi, hope someone see this, but i tried to follow the last two commenters’ (./pear ...) instructions, but that didn’t work.

i then attempted to follow the above suggestion for uninstalling the theme, but that didn’t work either, now the site (it is a dev site) is pretty much dead.

i am unable to do any upgrades nor can i reinstall the blank theme.

here is what i am getting when i try to reinstall the theme:
magento-core/Interface_Frontend_Default_Blank requires package “magento-core/Mage_Core_Modules” (version >= 1.3.3, version <= 1.3.4, excluded versions: 1.3.4), installed version is 1.3.2.3
Install Errors
No valid packages found
PEAR ERROR: install failed

and when i try to reinstall core modules i get:
magento-core/Mage_Core_Modules is not compatible with downloaded package “magento-core/Lib_Varien” version 1.3.3
magento-core/Mage_Core_Modules is not compatible with downloaded package “magento-core/Lib_Js_Mage” version 1.3.3
magento-core/mage_core_modules is not compatible with downloaded package “magento-core/Lib_Varien” version 1.3.3
magento-core/Lib_Varien cannot be installed, conflicts with installed packages
magento-core/mage_core_modules is not compatible with downloaded package “magento-core/Lib_Js_Mage” version 1.3.3
magento-core/Lib_Js_Mage cannot be installed, conflicts with installed packages
Install Errors
No valid packages found
PEAR ERROR: upgrade failed

finally, when i try to update varien:
magento-core/mage_core_modules is not compatible with downloaded package “magento-core/Lib_Varien” version 1.3.3
magento-core/Lib_Varien cannot be installed, conflicts with installed packages
Install Errors
No valid packages found
PEAR ERROR: upgrade failed

any help is much appreciated…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Thejosh13
Sr. Member
 
Total Posts:  252
Joined:  2008-06-23
 
Flicker - 10 March 2010 03:22 PM

I’ve managed to get through the errors with this

./pear install -f magento-core/Mage_All_Latest
./pear install -f magento-core/Mage_Core_Modules
./pear upgrade-all

Deleted cache and this worked

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top