Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Path “…” must be writable
 
jimmypalmer
Sr. Member
 
Total Posts:  79
Joined:  2008-05-04
 

I’m using media temple’s dedicated virtual and I am getting the following error during the config/installation process. 

Path “/var/www/vhosts/XXX/httpdocs/magento/var/session/sess_n5e1nfuh1hbjdhk5jolg5ckik6” must be writable

I set the permissions as guided by here:  http://www.magentocommerce.com/wiki/mediatemple_installation_guide_-_dedicated-virtual_server

and I have been playing around with the permissions with just that file, but have had not luck.

Any suggestions?

 
Magento Community Magento Community
Magento Community
Magento Community
 
elementdesign
Jr. Member
 
Total Posts:  4
Joined:  2007-09-06
 

Same issue.  Running on the Media Temple DV 3.5 which has PHP 5.2.5 installed (verified by phpinfo).  All permissions are set to 777 and continues to error (same as above minus the session name).

 
Magento Community Magento Community
Magento Community
Magento Community
 
elementdesign
Jr. Member
 
Total Posts:  4
Joined:  2007-09-06
 

The problem was with the PHP Safe Mode being set to “on”.  In Plesk, allow the domain administrator to change the PHP Safe Mode variable in their control panel.  Log in as that client and uncheck the safe mode “on” check box.  Worked just fine after that change.

 
Magento Community Magento Community
Magento Community
Magento Community
 
majaluk
Jr. Member
 
Total Posts:  5
Joined:  2008-04-04
 

thanks i was having the same problem. good fix. grin

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top