Magento Forum

   
Magento 1.4.0.0 Admin Panel Issue
 
Shoey-N
Jr. Member
 
Total Posts:  4
Joined:  2010-02-11
 

Just upgraded from 1.3.2.4 with everything working to 1.4.0.0.
All the links in the Admin Navigation bar are gone now, all I can see is Dashboard and System.
Does anybody know why this is and how I could fix it ?
Any help would be appreciated

 
Magento Community Magento Community
Magento Community
Magento Community
 
SimStim
Jr. Member
 
Total Posts:  3
Joined:  2010-02-13
 

Exactly the same for me. Additionally, though, I don’t see any products in the front-end ("There are no products matching the selection.") I’m assuming something has changed in the database that makes the data unavailable?

I’d very much appreciate any help, thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
gadgetsdirect
Jr. Member
 
Total Posts:  21
Joined:  2008-09-06
 

Same here, the menu links are showing but they won’t drop down.

Even tried deleting everything keeping the database and media directory, only same on fresh install, so maybe a wrong coding error hitting the database.

 
Magento Community Magento Community
Magento Community
Magento Community
 
SimStim
Jr. Member
 
Total Posts:  3
Joined:  2010-02-13
 

I fixed my problem by doing a fresh install, and then copying all files except configs and designs over the old shop. Then the usual routine indexing and clearing caches. Now I have all the menus in admin and all products back in the catalog. Still looking for inconsistencies (I noticed my watermark is gone), but I don’t expect major issues. Yay!

 
Magento Community Magento Community
Magento Community
Magento Community
 
LukasMagento
Jr. Member
 
Total Posts:  9
Joined:  2010-02-14
 

A fey issues that i’ve encountered with the MAGENTO 1.4.0.0 Stable version.

*1. On localhost using XAMMP having throubles loging into the Backend.
Commenting the lines under // session cookie params in Varien.php
brought nothing just an Error like: There has been an error processing
your request #147657007
. I have to mention that I’ve succesfully resolved
this login issue on the MAGENTO 1.3.2.4 Stable Version with the method above.

*2. Magento Connect doesn’t work on 1.4.0.0 . Again I tested it on my localhost using XAMMP
(after fresh installing the 1.4.0.0 one, was able just once to login into the
backend after that never able again, and saw that the Magento Connect makes
conflict between PEAR.php from magento directory and xammp directory).

One single issue on 1.3.2.4 stable version

*3. Installing the JqZoom extension that allows costummers to see the product images
by draging the mouse over them, on a zommed window was also succseful after refreshing
the cookies and a relog. But wen I try to import some products the product images
doesn’t shows up. Here I must mention that the imported .csv file was before opened
and renamed the image path by putting a slash ‘/’ before the image name.Everithing else
was cleaned up. The Image directory for the imported products must be in catalog/media/import.
I thing the problem is that Jqzoom doesn’t find the path for the imported images just for
those products that have been created in the admin and not imported.
This kind of issue has also MagicZoomPlus.

Has anyone an answer to those three main problems? Thank You!

 
Magento Community Magento Community
Magento Community
Magento Community
 
synkaten
Jr. Member
 
Total Posts:  17
Joined:  2009-10-01
 

Same issue here!

I upgraded from 1.3.2.4 to 1.4.0.0 CE stable today (2/18) by using MagentoConnect Manager, however on Admin Panel only 2 menus left - Dashboard and System.

It seems that many people encountered the same issue as well, see this thread -
http://www.magentocommerce.com/boards/viewthread/76538/

Is there any solutions? I really appreciate!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Tomakun
Sr. Member
 
Total Posts:  77
Joined:  2008-10-21
 

I just did the update through the Magento Connect Manager.

At first I couldn’t log in but manage to enter the admin after deleting app/code/core/Zend/Cache folder as advise by Magento staff.

Problem is, I have all menu but no content! Please check the screenshot. I really need help on this as without the admin, I cannot rebuild the index as needed with this new version.

Image Attachments
magentoadmin.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
cranberry
Jr. Member
 
Total Posts:  16
Joined:  2009-01-21
 

I had the “admin with only DASHBOARD and SYSTEM in the menu” issue after upgrading by magento connect to the 1.4 version, but i fixed it by upgrading manually the following extensions as it indicates de wiki (http://www.magentocommerce.com/wiki/upgrading_magento):

* magento-core/Interface_Adminhtml_Default
* magento-core/Interface_Frontend_Default
* magento-core/Interface_Install_Default
* magento-core/Mage_Core_Adminhtml
* magento-core/Mage_Core_Modules

The last two were already installed, but the others were not. Maybe it fix the index management and the others ones.

 
Magento Community Magento Community
Magento Community
Magento Community
 
DaeronAlagos
Jr. Member
 
Total Posts:  3
Joined:  2008-08-30
 
cranberry - 19 February 2010 10:24 AM

I had the “admin with only DASHBOARD and SYSTEM in the menu” issue after upgrading by magento connect to the 1.4 version, but i fixed it by upgrading manually the following extensions as it indicates de wiki (http://www.magentocommerce.com/wiki/upgrading_magento):

* magento-core/Interface_Adminhtml_Default
* magento-core/Interface_Frontend_Default
* magento-core/Interface_Install_Default
* magento-core/Mage_Core_Adminhtml
* magento-core/Mage_Core_Modules

The last two were already installed, but the others were not. Maybe it fix the index management and the others ones.

Thanks, worked for me.

J.

 
Magento Community Magento Community
Magento Community
Magento Community
 
6sMeTz
Jr. Member
 
Total Posts:  5
Joined:  2009-09-17
 

thanks a lot cranberry, had the same issue and missed that pointer at the wiki.

problem solved

 
Magento Community Magento Community
Magento Community
Magento Community
 
mmm7L
Jr. Member
 
Total Posts:  1
Joined:  2009-11-24
 

For anyone still having the problem after upgrading to 1.4.0.x where you only see the Dashboard and System Menus in the admin area (and also your products are not showing), this is what fixed it for me.

1) Make sure your magento directory has full privileges for the user that the installer is running under
2) SSH to your magento directory
3) Run the following commands:
a) ./pear mage-setup .
b) ./pear install magento-core/Mage_All_Latest
c) ./pear upgrade-all

*Note that in command a, the period is not a mistake, you must include that

4) Delete the contents of the Cache and Sessions folders
*Note that if you delete the entire Cache directory, you have to make sure you re-allow write permissions to the folder after the system recreates it, otherwise you will get an error when you go to the web page

5) Log in to the admin area. If your navigation is back, you’re in good shape.
6) There should be a warning message telling you to re-index your catalog, go to Index Management and re-index everything

That should do it hopefully. Good luck.

 
Magento Community Magento Community
Magento Community
Magento Community
 
egrueda
Jr. Member
 
Total Posts:  4
Joined:  2009-09-28
 
-

I had the “admin with only DASHBOARD and SYSTEM in the menu” issue after upgrading by magento connect to the 1.4 version, but i fixed it by upgrading manually the following extensions as it indicates de wiki (http://www.magentocommerce.com/wiki/upgrading_magento):

* magento-core/Interface_Adminhtml_Default
* magento-core/Interface_Frontend_Default
* magento-core/Interface_Install_Default
* magento-core/Mage_Core_Adminhtml
* magento-core/Mage_Core_Modules

The last two were already installed, but the others were not. Maybe it fix the index management and the others ones.

Sorry, but how did you manually updated those packages?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top