Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Probleme mit Multi Store Views bei 1und1
 
Cosmonoid
Jr. Member
 
Total Posts:  8
Joined:  2008-04-02
 

Hallo Community,

ich bin sehr begeistert von Magento und dieser Community. Die Features und die klare, strukturierte Programmierung gefällt mir sehr gut.

Aber nun zu meinem Problem. Evtl. hat jemand die gleiche Problematik und kann mir weiterhelfen. Mein Domain wird bei 1und1 gehostet. Nach einigem Problemen habe ich Magento als php5-cgi Variante zum laufen bekommen. Parallel habe ich es auch auf 2 Ubuntu-VMs laufen wo bisher keine Probleme auftraten.
Das größte Problem habe ich mit dem Multi Store View. Ich habe gemäß Anleitung einen zweiten Store View erstellt. Wenn ich jetzt aber im Frontend den View umstelle bekomme ich auf dem 1und1 System kurz eine weiße Seite mit 3 Fehlermeldungen (siehe Attachment). Dann erscheint eine Magento-Seite mit der Fehlermeldung :

Cannot send headersheaders already sent in /homepages/30/d38984979/htdocs/shop/app/code/core/Mage/Core/functions.phpline 191.
Das dies nur ein resultierender Fehler ist, ist mir klar. Das Hauptproblem scheint in der Meldung ‘Undefinded index’ (Siehe Attachment) zu liegen.
Auf meinen VM´s habe ich die gleiche Prozedur wiederholt und konnte nach dem Anlegen eines 2. Store Views direkt im Frontend umschalten.

Eine weitere kleinere Problematik habe ich mit Sprachpaketen die ich über Magento Connect installieren möchte. Er fängt nach Eingabe des Codes an die Pakete herunterzuladen, bleibt danach aber stehen. Er lädt also runter und entpackt, installiert aber nichts. Will ich die Seite verlassen, erscheint ein Hinweis das er noch installieren will; habe dann nach einer halben Stunde abgebrochen. Das ist übrigens nur bei den Sprachpaketen so, andere Erweiterungen konnt ich über Magento Connect installieren. Auf meinen VMs hatte ich auch mit Sprackpaketen kein Problem. Letzendlich habe ich einfach die locale Ordner von einer VM auf den 1und1 Server kopiert. Evtl. hängt diese Problematik mit der ersten zusammen, daher wollte ich es mal erwähnen.

So, ne ganze Menge Text für mein erstes Posting.
Freue mich auf Euer Feedback.

Edit : Das Problem konnte ich lösen. Zum einen habe ich auf das php5 binary von magento zurückgegriffen was gar nicht nötig ist. 1und1 hat auf allen Servern auch auch php5 bin liegen. Damit konnte ich das Problem der Store Views lösen. Für das 2. Problem mit dem Magento Connect habe ich hier im Forum eine Lösung gefunden. Den Pfad des bin (bei 1und1 : usr/local/bin/php5 ) hart in die Datei pear eintragen - dann klappts auch mit dem Updaten.

Sonnige Grüße aus Düsseldorf,
cosmo

Image Attachments
error.gif
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top