Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

can’t activate catalog price rule after update
 
caos989
Sr. Member
 
Total Posts:  96
Joined:  2008-07-25
Linz, Austria
 

Hi

I was running a working system with magento 1.4.1.1 with good working cron jobs and no errors. My catalog price rules was also working fine till yesterday.

I updatet magento to 1.8.0.0 and today to 1.8.1.0 after the first update my catalog price rules stoped work and I can’t switch it on.

There is no price rule in my database at catalogrule_product.

I tried to run this script, but I just get some errors:
<?php

require_once 'app/Mage.php';
// if your are not root folder then write the proper path like public_html/magento/app/Mage.php

Mage::app('default');

$catalogRule = Mage::getModel('catalogrule/rule');
$catalogRule->applyAll();

Mage::app()->removeCache('catalog_rules_dirty');

?>

I also tried to delate all price rules and make new one.

I was reindexing the whole shop a couple of times with the cronjob and I also delated the var/cache dir very often.

The databse repair tools says:
• Module “find_feed_setup” is not installed in corrupted DB
• Module “googlebase_setup” has wrong version 0.1.2 in corrupted DB (reference DB contains “googlebase_setup” ver. 1.6.0.0)
• Module “googleoptimizer_setup” has wrong version 0.1.2 in corrupted DB (reference DB contains “googleoptimizer_setup” ver. 1.6.0.0)
• Module “reports_setup” has wrong version 1.6.0.0 in corrupted DB (reference DB contains “reports_setup” ver. 1.6.0.0.1)

Has someone any idea what I can do next?

 
Magento Community Magento Community
Magento Community
Magento Community
 
dastoke
Jr. Member
 
Total Posts:  21
Joined:  2012-03-14
 

I have exactly the same problem after upgrade from 1.7.02 to 1.8.1.0
I have created a new catalog rule > save & apply > flushed cache = No Change to the category?

 
Magento Community Magento Community
Magento Community
Magento Community
 
dgiouzelis
Jr. Member
 
Total Posts:  10
Joined:  2008-08-04
 

did you solve the issue?
in my case, rules disappear at 11oclock and not coming back, what ever i tryied!
only after some hours aply.
i got a 1.8.0 t installation upgraded to 1.8.1

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top