Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

new attribute for customer not showing in admin
 
nonu
Member
 
Total Posts:  60
Joined:  2008-03-26
 

I added a new attributes in registration Page.So i insert that attribute in eav_attribute table and corresponding changes in phtml file and controller where function is storing data in customer array.

I created new attribute as

INSERT INTO `eav_attribute` (`entity_type_id`, `attribute_code`, `attribute_model`, `backend_model`, `backend_type`, `backend_table`, `frontend_model`, `frontend_input`, `frontend_label`, `frontend_class`, `source_model`, `is_global`, `is_visible`, `is_required`, `is_user_defined`, `default_value`, `is_searchable`, `is_filterable`, `is_comparable`, `is_visible_on_front`, `is_unique`, `apply_to`, `use_in_super_product`, `is_visible_in_advanced_search`) VALUES
(2, ‘officeadd’, NULL, ‘’, ‘varchar’, NULL, NULL, ‘text’, ‘Office Add’, NULL, NULL, 1, 1, 1, 1, NULL, 1, 0, 0, 0, 0, 0, 1, 0)

.It is working in frontend but it is not showing in admin

What changes should i do so that it can be changed through admin also.Plesae reply soon.

 
Magento Community Magento Community
Magento Community
Magento Community
 
nonu
Member
 
Total Posts:  60
Joined:  2008-03-26
 

Not getting any reply on magento forum since long time.

Will i never got any reply on this forum. long face

 
Magento Community Magento Community
Magento Community
Magento Community
 
Bojan Hrnkas
Member
 
Total Posts:  51
Joined:  2008-04-15
 

To solve your problem, use backend class to create new attribute as explained in this wiki post:

http://www.magentocommerce.com/wiki/adding_a_new_attribute

But I have an other problem with this. I added the attribute and changed .../customer/form/edit.phtml so a customer can change the new attribute. Problem is, the value that customer enters is not saved. How did you do that?

Thanks!

Bojan Hrnkas

 
Magento Community Magento Community
Magento Community
Magento Community
 
bloggleme
Sr. Member
 
Avatar
Total Posts:  101
Joined:  2008-05-06
 

im interested in this as well

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top