Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Magento Connect Manager - blank page issue
 
iaineach
Jr. Member
 
Total Posts:  5
Joined:  2009-08-10
 

Hi,

Having problems with Connect Manager - basically I get the Magento Connect header graphic and then blank content underneath. The outputted page doesn’t appear to be pulling in the relevant data:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"
>
<
html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<
head>
    <
title>Magento Downloader</title>
    <
meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
    <
link type="image/x-icon" href="/tea/downloader/favicon.ico" rel="icon"/>
    <
link type="image/x-icon" href="/tea/downloader/favicon.ico" rel="shortcut icon"/>
    <
script type="text/javascript" src="js/prototype.js"></script>
    
<link type="text/css" rel="stylesheet" href="skin/boxes.css"></link>

    <!--
[if IE]>
    <
link type="text/css" rel="stylesheet" href="skin/ieboxes.css" media="all"></link>
    <!
[endif]-->
    <!--
[if gt IE 6]>
    <
link type="text/css" rel="stylesheet" href="skin/ie7boxes.css" media="all"></link>
    <!
[endif]-->
</
head>
<
body>
    <
div class="container">

        <
div class="header-top">
            <
h1 id="logo">Magento Downloader</h1>
        </
div>
        <
div class="main">

                    <
div class="content">

It’s just pulling in the top of the page template files and nothing else. I’ve set all folder permissions in /downloader to 755 and all files to 644 so I can’t see where the problem lies. Any ideas?

p.s. I’ve searched the boards and google but haven’t been able to come up with an answer.

 
Magento Community Magento Community
Magento Community
Magento Community
 
comodo
Jr. Member
 
Total Posts:  25
Joined:  2007-12-13
 

Have you fixed it? I have also this error, i got this after I’ve installed a new extension.

 
Magento Community Magento Community
Magento Community
Magento Community
 
iaineach
Jr. Member
 
Total Posts:  5
Joined:  2009-08-10
 

no, no joy as yet.

 
Magento Community Magento Community
Magento Community
Magento Community
 
comodo
Jr. Member
 
Total Posts:  25
Joined:  2007-12-13
 

Try to acces your Magento Connect with Google Chrome, it has worked by me but I can’t still access it with Firefox or Internet Explorer.

 
Magento Community Magento Community
Magento Community
Magento Community
 
comodo
Jr. Member
 
Total Posts:  25
Joined:  2007-12-13
 

I’ve found out now that it isn’t a browser bug, it’s something else, very weird, just put directly site.com/downloader without http://www and you will fix the problem in any browser.

 
Magento Community Magento Community
Magento Community
Magento Community
 
iaineach
Jr. Member
 
Total Posts:  5
Joined:  2009-08-10
 

neither of these options work for me…

 
Magento Community Magento Community
Magento Community
Magento Community
 
MisterDevil
Jr. Member
 
Total Posts:  1
Joined:  2010-07-02
 

Same for me , nothing works, using 1.4.10 version of magento :((

 
Magento Community Magento Community
Magento Community
Magento Community
 
joshq3i
Jr. Member
 
Total Posts:  16
Joined:  2008-12-09
 

Having the same problem here, any success finding a workaround?

 
Magento Community Magento Community
Magento Community
Magento Community
 
samstha
Jr. Member
 
Total Posts:  12
Joined:  2011-07-06
 

Hi all,
I have a similar issue.  When I click on Magento connect manager from the backend I get a blank white screen/page.
My URL is like this:
http://www.mysite.com/downloader/?return=http&#x3A;&#x2F;&#x2F;www.mysite.com&#x2F;index.php&#x2F;admin&#x2F;

Any idea where I should start?

Thanks,
Sam

 
Magento Community Magento Community
Magento Community
Magento Community
 
Hilly
Jr. Member
 
Total Posts:  14
Joined:  2010-08-22
 

I am having the same issue as Samstha. Any Ideas ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
samstha
Jr. Member
 
Total Posts:  12
Joined:  2011-07-06
 

I was able to resolve the issue,

I added the following code in .../downloader/index.php

Mage_Autoload_Simple::register();
ini_set(\"memory_limit\”,\"1028M\");
umask(0);

signed out and signed back in. It worked!

let me know if it works for you. (P.S. I used 1028M on the php.ini file as well)

 
Magento Community Magento Community
Magento Community
Magento Community
 
samstha
Jr. Member
 
Total Posts:  12
Joined:  2011-07-06
 

I was able to resolve the issue,

I added the following code in .../downloader/index.php

Mage_Autoload_Simple::register();
ini_set(\\\"memory_limit\\\”,\\\"1028M\\\");
umask(0);

signed out and signed back in. It worked!

let me know if it works for you. (P.S. I used 1028M on the php.ini file as well)

 
Magento Community Magento Community
Magento Community
Magento Community
 
Chun-Yian Liew
Jr. Member
 
Total Posts:  6
Joined:  2008-06-09
Rotterdam, The Netherlands
 

I experienced the same issue yesterday when trying to setup a test shop using the latest Mage Community Edition 1.5.1.0 release.
The test server was setup with CentOS 6.0 (32bit) + nginx 1.05 + php-fpm (php 5.3.6) + apc 3.1.9
The Mage Connect blank page issue I ran into seemed not be related to a shortage of memory assigned to php, in my case being 128M.

It took me some debugging but I managed to isolate the issue in the following file:

<magento_base_dir>/downloader/lib/Mage/Connect/Singleconfig.php

In my case the problem was caused in the save function of that file.
The following (problematic) method is used: gzcomress, this method seems just to halt the complete php execution without any errors being thrown.

I’ve created a small test php file (gzcompress_test.php) which showed the same behavior, the last echo statement is not displayed.
It just looks like the rest of the php execution is halted.

<?php                                                                                               
        $datatocompress 
"Testing123";                                                                 
        echo 
"Data to be compressed: " $datatocompress;                                                         
        
$compresseddata = @gzcompress($datatocompress);                                                           
        echo 
"Compressed data: " $compresseddata;                                                                
?>

To skip the usage of the gzcompress method in <magento_base_dir>/downloader/lib/Mage/Connect/Singleconfig.php
you can change the following line

protected $_debug false;
into
protected $_debug true;

This is at least what I have done as a temporary workaround until I have figured out why gzcompress is behaving the way it does in my test environment.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Chun-Yian Liew
Jr. Member
 
Total Posts:  6
Joined:  2008-06-09
Rotterdam, The Netherlands
 

Ok, I figured out what was wrong with my setup.

Because of the error control operator (@ character) before the gzcompress method call, any error messages that might be generated by that method call will be ignored.

So I removed the @ character in my gzcompress_test.php file and guess what? The error was finally displayed:

Fatal error: Call to undefined function gzcompress() in <location of gzcompress_test.php>

So I was missing zlib support in my php configuration.

By the way, I strongly agree with the last sentence in the following this bug description:

@ should not be used when function can generate fatal err

 
Magento Community Magento Community
Magento Community
Magento Community
 
kelvingani
Jr. Member
 
Total Posts:  2
Joined:  2011-10-04
 
samstha - 09 July 2011 08:37 PM

I was able to resolve the issue,

I added the following code in .../downloader/index.php

Mage_Autoload_Simple::register();
ini_set(\\\"memory_limit\\\”,\\\"1028M\\\");
umask(0);

signed out and signed back in. It worked!

let me know if it works for you. (P.S. I used 1028M on the php.ini file as well)

This works for me. Thanks

Kelvin

 
Magento Community Magento Community
Magento Community
Magento Community
 
eniteo
Jr. Member
 
Total Posts:  7
Joined:  2010-04-28
 

Hi,

I have found an other conflict that I have resolved. I share this it can be useful.

Sometimes there are conflict with php 5.3 an the memory set in magento.  (exact php version 5.3.8)
Basically it is not possible under my configuration to change the variable memory_limit either in the .htaccess file or any other files

Check if the set of memory_limit cause the error or if you previously had this error in your environment.

Under this circumstances you have to comment the following line:

Comment the line commented as above

For Magento ver. 1.6.1.0 file:  downloader/Maged/Connect.php
For Magento ver. 1.4.2 file:  downloader/Maged/Pear.php

public function run($command$options=array(), $params=array())
    
{
        
@set_time_limit(0);
//        @ini_set('memory_limit', '256M');

Excuse my english I’m french with some gramitical english rules to learn wink

Hopes it helps

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2