Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

WYSIWYG doesn’t work
 
atlantide
Sr. Member
 
Avatar
Total Posts:  187
Joined:  2008-02-16
France
 

In try to set a WYSIWYG TinyMCE editor, but it doesn’t seems to work.

I followed the Wiki about WYSIWYG.

First problem, it says “For products, add the code around line 54 of app/design/adminhtml/defaut/default/template/catalog/product/edit.phtml”, but I can’t find the exact place where to insert…

Second problem :

When I insert at : lib/Varien/Data/Form/Element/Editor.php, inside the $html variable and after the the <textarea> tag, I get the following screen instead of my regular magento page.

<script language="javascript\" type="text/javascript\" src="path/to/magento/js/tiny_mce/tiny_mce.js"></script>
<script language="javascript\" type="text/javascript\">
tinyMCE.init({
mode : “exact”,
theme : “advanced”,
elements : “element1,element2,element3,etc.”,
theme_advanced_toolbar_location : “top”,
theme_advanced_toolbar_align : “left”,
theme_advanced_path_location : “bottom”,
extended_valid_elements : “a[name|href|target|title|onclick],img[class|src|border=0|alt|title|hspace|vspace|width|height|align|onmouseover|onmouseout|name],hr[class|width|size|noshade],font[face|size|color|style],span[class|align|style]”,
theme_advanced_resize_horizontal : “true”,
theme_advanced_resizing : “true”,
apply_source_formatting : “true”,
convert_urls : “false”,
force_br_newlines : “true”,
doctype : ‘<!DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.0 Strict//EN” “http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">’,
});
</script>

instead of

<script language="javascript\" type="text/javascript\">
/* tinyMCE.init({
mode : “exact”,
theme : “‘.$this->getTheme().’”,
elements : ”’ . $element . ‘“,
theme_advanced_toolbar_location : “top”,
theme_advanced_toolbar_align : “left”,
theme_advanced_path_location : “bottom”,
extended_valid_elements : “a[name|href|target|title|onclick],img[class|src|border=0|alt|title|hspace|vspace|width|height|align|onmouseover|onmouseout|name],hr[class|width|size|noshade],font[face|size|color|style],span[class|align|style]”,
theme_advanced_resize_horizontal : “false”,
theme_advanced_resizing : “false”,
apply_source_formatting : “true”,
convert_urls : “false”,
force_br_newlines : “true”,
doctype : \’<!DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.0 Strict//EN” “http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">\’
});*/
</script>

I use Magento 1.0.19700

Thanks a lot

Image Attachments
02.05.2008 à 12h 46m 39s 765'.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
GodRJa
Jr. Member
 
Total Posts:  22
Joined:  2008-04-28
 

For the firs problem: I did insert it in lice 51 after the </form> element and befor <script ...> element. It did show an editor. But the editor has been disabled and I didn’t find a way to enable it.

 
Magento Community Magento Community
Magento Community
Magento Community
 
atlantide
Sr. Member
 
Avatar
Total Posts:  187
Joined:  2008-02-16
France
 

thank you for your anser GodRJa

does anyone have an idea ???

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top