Magento Forum

Conflit entre Magento et eAccelerator
 
Peusly
Jr. Member
 
Total Posts:  2
Joined:  2009-02-26
 

Bonjour,

J’ai actuellement un serveur Kimsufi 750G avec debian Lenny qui met sert à faire de l’hébergement web. J’ai tenté de migrer un magento dessus, mais eAccelerator pose un problème.

J’ai deux erreurs aléatoires, soit dans mes logs d’erreurs d’apache j’ai l’erreur ci dessous accompagnée d’une page blanche :
[Tue Jan 12 17:41:01 2010] [notice] child pid 6341 exit signal Segmentation fault (11)

Ou j’obtiens une erreur fatale :
Fatal error: Cannot access protected property Varien_Autoload::$_instance in /home/www/ldb/magento/lib/Varien/Autoload.php on line 62

Lorsque je désactive eAccelerator, magento tourne sans problème. Bien sur les autres sites hébergés fonctionnent très bien avec eAccelerator.

Version de PHP : 5.2.6-1+lenny4
Version de eAccelerator : 0.9.5.3-0+lenny3 installé via le package php5-eaccelerator

Quelqu’un a déjà rencontrer un problème similaire avec Magento et eAccelerator?
Sinon est il possible de restreindre eAccelerator qu’à certains sites?

Merci d’avance pour vos réponses.

 
Magento Community Magento Community
Magento Community
Magento Community
 
coolshop
Sr. Member
 
Total Posts:  121
Joined:  2009-08-28
 

Peusly

Augmente la mémoire php dans ton php.ini. Cela devrait résoudre le problème.

 
Magento Community Magento Community
Magento Community
Magento Community
 
GratHost
Jr. Member
 
Avatar
Total Posts:  25
Joined:  2010-01-01
World Wide [ APE: 6202A ]
 

Magento ( http://3x8.fr/ar ) tourne sans problème sur nos serveurs avec eAccelerator enabled ( http://td3.fr/w6Ts487bf )… wink

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top