Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Erro na minha loja após inserção do “Brazilian Email Templates”. 
 
Alex C. Silva
Jr. Member
 
Total Posts:  25
Joined:  2008-08-19
 

Bom dia após hoje colocar este app em minha loja, apareceu este erro…
a minha versão é uma 1.3.x
Como poderia solucionar este pequeno problema?

Error in file"/home/editoralore/public_html/vendejo3/app/code/community/Bragento/EmailTemplate/sql/emailtemplate_setup/mysql4-install-0.1.0.sql" SQLSTATE[42S22]Column not found1054 Unknown column 'template_styles' in 'field list'
Trace:
#0 /home/editoralore/public_html/vendejo3/app/code/core/Mage/Core/Model/Resource/Setup.php(292): Mage::exception('Mage_Core', 'Error in file: ...')
#1 /home/editoralore/public_html/vendejo3/app/code/core/Mage/Core/Model/Resource/Setup.php(167): Mage_Core_Model_Resource_Setup->_modifyResourceDb('install', '', '0.1.0')
#2 /home/editoralore/public_html/vendejo3/app/code/core/Mage/Core/Model/Resource/Setup.php(155): Mage_Core_Model_Resource_Setup->_installResourceDb('0.1.0')
#3 /home/editoralore/public_html/vendejo3/app/code/core/Mage/Core/Model/Resource/Setup.php(121): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /home/editoralore/public_html/vendejo3/app/code/core/Mage/Core/Model/Config.php(263): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /home/editoralore/public_html/vendejo3/app/code/core/Mage/Core/Model/App.php(263): Mage_Core_Model_Config->init(Array)
#6 /home/editoralore/public_html/vendejo3/app/Mage.php(434): Mage_Core_Model_App->init('', 'store', Array)
#7 /home/editoralore/public_html/vendejo3/app/Mage.php(455): Mage::app('', 'store', Array)
#8 /home/editoralore/public_html/vendejo3/index.php(65): Mage::run()
#9 {main}

Abraços, Alex

 
Magento Community Magento Community
Magento Community
Magento Community
 
Eric Cavalcanti
Guru
 
Avatar
Total Posts:  710
Joined:  2008-09-28
San Antonio
 

Adriano, la ta dizendo que é para 1.3+
O.o
O que ele é, apenas os templates para email?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Alex C. Silva
Jr. Member
 
Total Posts:  25
Joined:  2008-08-19
 
CajuCLC - 12 January 2010 04:52 AM

Adriano, la ta dizendo que é para 1.3+
O.o
O que ele é, apenas os templates para email?

Valeu Adriano, para mim o post está resolvido… pelo logs vi que são tradução do templates de email, certo?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Eric Cavalcanti
Guru
 
Avatar
Total Posts:  710
Joined:  2008-09-28
San Antonio
 

Hum, nao poderia colocar eles aqui em zip?
Queria baixar para ver como estão.
:D

 
Magento Community Magento Community
Magento Community
Magento Community
 
eschamann
Member
 
Total Posts:  33
Joined:  2009-11-17
São Paulo - Brazil
 

Adriano, estou com a ver 1.3.2.4 e instalei os templates 1.0 (para ver 1.3 de Magento), porém agora aparecem as seguintes mensagens quando tento fazer algo relacionado aos e-mails:
Cannot send headers; headers already sent in /home/qualityfor/public_html/loja/app/code/core/Mage/Core/Model/Resource/Setup.php, line 291
Trace:
#0 /home/qualityfor/public_html/loja/lib/Zend/Controller/Response/Abstract.php(147): Zend_Controller_Response_Abstract->canSendHeaders(true)
#1 /home/qualityfor/public_html/loja/app/code/core/Mage/Adminhtml/Controller/Action.php(340): Zend_Controller_Response_Abstract->setRedirect(’http://www.qual...’)
#2 /home/qualityfor/public_html/loja/app/code/core/Mage/Adminhtml/controllers/System/ConfigController.php(164): Mage_Adminhtml_Controller_Action->_redirect(’*/*/edit’, Array)
#3 /home/qualityfor/public_html/loja/app/code/core/Mage/Core/Controller/Varien/Action.php(376): Mage_Adminhtml_System_ConfigController->saveAction()
#4 /home/qualityfor/public_html/loja/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(248): Mage_Core_Controller_Varien_Action->dispatch(’save’)
#5 /home/qualityfor/public_html/loja/app/code/core/Mage/Core/Controller/Varien/Front.php(158): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#6 /home/qualityfor/public_html/loja/app/Mage.php(459): Mage_Core_Controller_Varien_Front->dispatch()
#7 /home/qualityfor/public_html/loja/index.php(65): Mage::run()
#8 {main}

Quando retorno à página onde estava, fica a mensagem:
Erro no arquivo: “/home/qualityfor/public_html/loja/app/code/community/Bragento/EmailTemplate/sql/emailtemplate_setup/mysql4-upgrade-0.1.0-0.1.2.sql” - SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘template_styles’ in ‘field list’
Erro no arquivo: “/home/qualityfor/public_html/loja/app/code/community/Bragento/EmailTemplate/sql/emailtemplate_setup/mysql4-upgrade-0.1.0-0.1.2.sql” - SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘template_styles’ in ‘field list’

Tentei reinstalar a extension, mas também apresenta erro nesse processo.

Alguma idéia?

Obrigado,
Quique

 
Magento Community Magento Community
Magento Community
Magento Community
 
eschamann
Member
 
Total Posts:  33
Joined:  2009-11-17
São Paulo - Brazil
 

Agora que percebi que mesmo tendo colocado a extension correta para a ver 0.1.0 (cujo final é 0.1.0) instalou o a ver 0.1.2

@Adriano, teria como dar uma olhada nisso, por favor?

Obrigado,
Quique

 
Magento Community Magento Community
Magento Community
Magento Community
 
eschamann
Member
 
Total Posts:  33
Joined:  2009-11-17
São Paulo - Brazil
 

Acabei desinstalando a extension e resolveu, mas o link instalava mesmoa 0.1.2, embora tenha selecionado a ver 0.1.0.

Abraço

 
Magento Community Magento Community
Magento Community
Magento Community
 
Tiago souza
Jr. Member
 
Total Posts:  2
Joined:  2010-01-05
 

Sou novo por aqui.. mas em questão do erro do “eschamann” seria um pequeno e confuso erro na tabela do banco de dados. Se usou o prefixo “_” para as tabelas na hora da instalação, consequentemente o magento gera um erro por não poder passar por cima das tabelas.. Resolvi os erros entrando no sistema do Bragente e acrescentando “_” , ja que eu instalei com prefixo _local para indentificar no banco. Espero que tenha ajudado.

Abraços
Tiago Souza

 
Magento Community Magento Community
Magento Community
Magento Community
 
Tiago souza
Jr. Member
 
Total Posts:  2
Joined:  2010-01-05
 

Sou novo por aqui.. mas em questão do erro do “eschamann” seria um pequeno e confuso erro na tabela do banco de dados. Se usou o prefixo “_” para as tabelas na hora da instalação, consequentemente o magento gera um erro por não poder passar por cima das tabelas.. Resolvi os erros entrando no sistema do Bragento e acrescentando “_” , ja que eu instalei com prefixo _local para indentificar no banco. Espero que tenha ajudado.

Abraços
Tiago Souza

 
Magento Community Magento Community
Magento Community
Magento Community
 
eschamann
Member
 
Total Posts:  33
Joined:  2009-11-17
São Paulo - Brazil
 

Tiago, a instalação foi feita automaticamente pelo Magento Connect. De qualquer maneira, quando removi a Extension, os html dos e-mails ficaram no servidor, e as usei normalmente.
Obrigado, Quique

 
Magento Community Magento Community
Magento Community
Magento Community
 
deniscass
Jr. Member
 
Total Posts:  5
Joined:  2009-01-19
 

Pessoal,

Também estou tendo problemas, alguém sabe me dizer onde encontro um pacote zip com essa extensão? Instalei a versão 0.1 pelo Magento connect mas não resolveu. Ele instala corretamente, mas não cria os arquivos na pasta pt_BR. Estou precisando disso com urgência.

Obrigado!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Angelo Lima
Jr. Member
 
Total Posts:  1
Joined:  2010-07-26
 

Bom, essa madrugada foi longa apos instalar pelo Magento Connect a traducao de e-mail para pt-BR pelo nosso amigo Adriano Aguiar.
Mas enfim, vamos la:

Quem tiver o mesmo problema, verifique se existe algum prefixo na tabela do banco de dados. No meu caso eu tinha colocado “mgt_”.
a alteracao e simples, va em app > code > community > Bragento > EmailTemplate > sql > emailtemplate_setup > mysql4-upgrade-0.1.0-0.1.2.sql

Abra o arquivo, altere todos os nomes da tabela do INSERT para “seu_prefixo_"core_email_template.
No meu caso alterei para mgt_core_email_template.

Salve o arquivo. E Pronto!

Espero ter ajudado.

ATENCAO: SE VC TIVER ACHADO ESSE ARQUIVO E EXECUTADO ELE DIRETAMENTE NA QUERY NO MYSQL, RECRIE A TABELA.
ELE DA ERRO DE DUPLICACAO SE VC TIVER INSERIDO PELO PROPRIO BANCO.

Segue abaixo o Dump para recriar a tabela.

/*
SQLyog Ultimate v8.61 
MySQL - 5.1.41-percona-log : Database - nome_da_sua_base_de_dados
*********************************************************************
*/


/*!40101 SET NAMES utf8 */;

/*!40101 SET SQL_MODE=''*/;

/*!40014 SET @OLD_UNIQUE_CHECKS=@@UNIQUE_CHECKS, UNIQUE_CHECKS=0 */;
/*!40014 SET @OLD_FOREIGN_KEY_CHECKS=@@FOREIGN_KEY_CHECKS, FOREIGN_KEY_CHECKS=0 */;
/*!40101 SET @OLD_SQL_MODE=@@SQL_MODE, SQL_MODE='NO_AUTO_VALUE_ON_ZERO' */;
/*!40111 SET @OLD_SQL_NOTES=@@SQL_NOTES, SQL_NOTES=0 */;
CREATE DATABASE /*!32312 IF NOT EXISTS*/`nome_da_sua_base_de_dados/*!40100 DEFAULT CHARACTER SET latin1 COLLATE latin1_general_ci */;

USE `
nome_da_sua_base_de_dados`;

/*Table structure for table `mgt_core_email_template` */

DROP TABLE IF EXISTS `mgt_core_email_template`;

CREATE TABLE `mgt_core_email_template` (
  `
template_idINT(7UNSIGNED NOT NULL AUTO_INCREMENT,
  `
template_codeVARCHAR(150) DEFAULT NULL,
  `
template_textTEXT,
  `
template_stylesTEXT,
  `
template_typeINT(3UNSIGNED DEFAULT NULL,
  `
template_subjectVARCHAR(200) DEFAULT NULL,
  `
template_sender_nameVARCHAR(200) DEFAULT NULL,
  `
template_sender_emailVARCHAR(200CHARACTER SET latin1 COLLATE latin1_general_ci DEFAULT NULL,
  `
added_atDATETIME DEFAULT NULL,
  `
modified_atDATETIME DEFAULT NULL,
  `
orig_template_codeVARCHAR(200) DEFAULT NULL,
  `
orig_template_variablesTEXT NOT NULL,
  
PRIMARY KEY (`template_id`),
  
UNIQUE KEY `template_code` (`template_code`),
  
KEY `added_at` (`added_at`),
  
KEY `modified_at` (`modified_at`)
ENGINE=INNODB AUTO_INCREMENT=41 DEFAULT CHARSET=utf8 COMMENT='Email templates';

/*!40101 SET SQL_MODE=@OLD_SQL_MODE */;
/*!40014 SET FOREIGN_KEY_CHECKS=@OLD_FOREIGN_KEY_CHECKS */;
/*!40014 SET UNIQUE_CHECKS=@OLD_UNIQUE_CHECKS */;
/*!40111 SET SQL_NOTES=@OLD_SQL_NOTES */;

Estou postando o arquivo do Dump tb.

File Attachments
core_email_template.sql  (File Size: 2KB - Downloads: 97)
 
Magento Community Magento Community
Magento Community
Magento Community
 
earcondicionado
Jr. Member
 
Total Posts:  1
Joined:  2011-01-23
 

opa ! é isso ai ! usei o procedimento e deu certinho ! obrigado ! estou com alguns outros probleminhas mas pouco a pouco estou resolvendo abraço a todo, meus trabalhos:
ar condicionado | lingerie | peças

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top