Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 3
404 errors in front and backend
 
patriveri
Jr. Member
 
Total Posts:  30
Joined:  2008-02-23
 

I unpacked the new tarball, removed the /var/cache and /var/session directiories, changed all permissions to 777, increased the memory size in .htaccess but cannot access the site; all the pages end up in a 404 error.

This is an upgrade, so apache, curl, etc are all properly configured.

Has anyone been able to get around this? Any troubleshooting tips?

-patricio

 
Magento Community Magento Community
Magento Community
Magento Community
 
patriveri
Jr. Member
 
Total Posts:  30
Joined:  2008-02-23
 

A fresh install works fine (unpacking the tarball and using a new db). However, when I point local.xml to the previous db I get the 404 redirects again.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Roly
Sr. Member
 
Total Posts:  276
Joined:  2008-04-30
 

Hi,

Try chmod 777 local.xml

If doesn’t work,

try chmod 755 local.xml

 
Magento Community Magento Community
Magento Community
Magento Community
 
chooky
Jr. Member
 
Total Posts:  3
Joined:  2008-04-14
Perth, Western Australia
 

Hi All,

Don’t know if this will help others or was only a problem for me. I installed Magento-1.0.19700 which installed fine however couldn’t view front or back end.

What fixed my problem.

In my Apache configuration file I changed the following:
AllowOverride None
to
AllowOverride All

Because I noticed the .htaccess file in the magento folder has quite a lot of settings and without that setting the .htaccess file wasn’t working. Now it’s working 100%.

Regards,

Matthew

 
Magento Community Magento Community
Magento Community
Magento Community
 
patriveri
Jr. Member
 
Total Posts:  30
Joined:  2008-02-23
 

The permissions were already 777 on local.xml, and the httpd.conf had ‘AllowOverride All’ set. This was a working install (I still cannot get it working, so I’ve rolled back to 1.0). Thanks for the responses, though.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ttread
Jr. Member
 
Total Posts:  1
Joined:  2008-04-05
Santa Rosa, California
 

Installed Magento 1.0.19700 and the patch, which went fine.  After installation it worked fine, until I went to Create Website.  Now everything is inaccessible.  I am getting 404 on both front and backend.  Any ideas would be appreciated.

Note, AllowOverride is set to All, and app/etc/local.xml has permissions set to 777.

 
Magento Community Magento Community
Magento Community
Magento Community
 
sgoodman
Jr. Member
 
Total Posts:  4
Joined:  2008-01-29
 

I’m having the same issue as patriveri - I attempted to upgrade a 1.0 installation via Magento Connect, which only succeeded in corrupting Magento connect itself (due to downloader/Maged/Controller.php run() using $this) and making it impossible to login to my admin panel. I backed up my custom theme and local code, deleted my 1.0 install, and performed a fresh install of 1.0.19700 against my 1.0 database. This resulted in the 404 errors. Re-installing against a brand new database worked perfectly though, which implies that there is an incompatibility between the 1.0 and 1.0.19700 database schemas.

Magento team, is there is a simple way to disable the new 404 redirects in code, so I can learn what is throwing the 404? I have too much time invested in my database to start from scratch.

 
Magento Community Magento Community
Magento Community
Magento Community
 
PandaWebStudio
Member
 
Avatar
Total Posts:  40
Joined:  2008-04-19
Amsterdam, Netherlands
 
ttread - 04 May 2008 07:53 PM

Installed Magento 1.0.19700 and the patch, which went fine.  After installation it worked fine, until I went to Create Website.  Now everything is inaccessible.  I am getting 404 on both front and backend.  Any ideas would be appreciated.

Note, AllowOverride is set to All, and app/etc/local.xml has permissions set to 777.

I don’t know if this helps:

I downloaded and installed Magento 1.0.19700 today and I had the same problem:
Cause:
Htaccess file was missing from website root (I don’t know why). So my suggestion is to check if you have the .htaccess file in your website root.

 
Magento Community Magento Community
Magento Community
Magento Community
 
gthing
Jr. Member
 
Total Posts:  13
Joined:  2008-05-08
 
ttread - 04 May 2008 07:53 PM

Installed Magento 1.0.19700 and the patch, which went fine.  After installation it worked fine, until I went to Create Website.  Now everything is inaccessible.  I am getting 404 on both front and backend.  Any ideas would be appreciated.

Note, AllowOverride is set to All, and app/etc/local.xml has permissions set to 777.

This is what triggered my problem as well.  Has anyone found a solution yet?

 
Magento Community Magento Community
Magento Community
Magento Community
 
gthing
Jr. Member
 
Total Posts:  13
Joined:  2008-05-08
 

Has anyone figured this out?

It seems to be that the software got upgraded without the database getting upgraded.  So there are two possible -easy- solutions: wipe the database and start over with a new install, or downgrade to whatever previous version you were using.

I have a new store and haven’t even finished setting it up yet, so I don’t mind reinstalling.  But it would be a lot nicer if there was an elegant solution so that when this happens down the road I’m not stuck with a non-functioning store for days at a time while I wait for someone to respond in a forum.

When you upgrade wordpress, the first thing the admin panel does is have you upgrade the database (simple point and click - it’s practically automatic).  It would be really nice if Magento could do something similar rather than just breaking.

Or perhaps it does, and i just missed the boat on how to do it.

 
Magento Community Magento Community
Magento Community
Magento Community
 
craig c
Jr. Member
 
Total Posts:  2
Joined:  2008-05-12
 

I can vouch for this same error/issue. painful it is. hope it’s solved soon.

 
Magento Community Magento Community
Magento Community
Magento Community
 
craig c
Jr. Member
 
Total Posts:  2
Joined:  2008-05-12
 

@ gthing.

if i use your “wipe the database and start over with a new install” technique, how do I get the magenta installation wizard to run again..?

do i need to modify/remove the htaccess files or anything..? my 404 pages have gone, but now i have blackpages both front and backend and no wizard in sight.

 
Magento Community Magento Community
Magento Community
Magento Community
 
gthing
Jr. Member
 
Total Posts:  13
Joined:  2008-05-08
 

I tried just deleting the local.xml file (I actually renamed it to local.xml.bak).  It is located in the app/etc folder.

This gave me the wizard again.  I created a new database from scratch, installed magento, and went in to create a new store.  BAM - 404s again. 

I’m going to try a totally clean install now.

 
Magento Community Magento Community
Magento Community
Magento Community
 
gthing
Jr. Member
 
Total Posts:  13
Joined:  2008-05-08
 

-Erased everything from my server including all files, databases, and db users
-Download the latest magento package from this site
-Uploaded the package to my server and set all permissions as per instructions (being careful to transfer hidden files also)
-Created a new database and db user
-Ran through the wizard
-Installation successful
-Tried creating a new website via the admin interface

BAM! 404s EVERYWHERE!

It simply doesn’t work.  I will concede that it is possible that my server is not configured properly, but I followed all instructions, checked permissions, and double checked server requirements.  Even if it is a problem with my server, the system should recover from the error gracefully ("Can’t do this because you don’t have this...") or at least take me to a meaningful error message.

I just don’t think Magento is ready for prime time.  I’ve been trying to set it up for nearly a week now and have yet to even get to the point where I can start adding products.  There is always some error or another that wipes the whole thing out.  What if this was a production website?  Support in the forums is sparse, and the information in the wiki and other support areas isn’t specific enough to address my problem. 

I’m beginning to understand Magento’s business model.  Release alpha stage software and hope people pay for support to get it working.  The decimal point in the current version number really should be moved one digit to the left.

I know I can’t expect a whole lot from *free* software, but let’s be serious - I’ve installed probably hundreds of Wordpress packages, and done a fair bit with Drupal and numerous other CMS’s and shopping carts, and never run into so many problems and so little support. 

For now, I’m off to install uber cart so I can stop dicking around and start making money.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Fadde
Jr. Member
 
Total Posts:  3
Joined:  2008-05-13
 

I had exactly the same problem when i was installing the version 1.0.19870. I solved it by putting ‘default’ in the Mage::run(); line in index.php.

Mage::run();

...should be…

Mage::run('default');

I hope it helps.

 
Magento Community Magento Community
Magento Community
Magento Community
 
skycapps
Jr. Member
 
Total Posts:  1
Joined:  2008-05-09
 

^^

That last one solved the problem for me on 1.0.19870

thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 3