Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Error when try to use Magento Connect
 
Shepstar
Sr. Member
 
Total Posts:  142
Joined:  2008-07-14
 

Hi there,

Magento Connect never really used to work with me, everytime I tried to upgrade via Magento Connect - the whole Magento crashed and had to be reinstalled.
So up until now I always upgraded using the FTP method, which is rather annoying.

Now I upgraded to 1.3.2.4 and wanted to install the german language pack via Magento Connect and I always get this error message:

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/www/web57/html/magento/downloader/pearlib/php/System.php:459) in /home/www/web57/html/magento/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php on line 99
Trace:
#0 /home/www/web57/html/magento/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php(99): mageCoreErrorHandler(2, ‘session_start()...’, ‘/home/www/web57...’, 99, Array)
#1 /home/www/web57/html/magento/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php(154): Mage_Core_Model_Session_Abstract_Varien->start()
#2 /home/www/web57/html/magento/app/code/core/Mage/Core/Model/Session/Abstract.php(83): Mage_Core_Model_Session_Abstract_Varien->init(’adminhtml’)
#3 /home/www/web57/html/magento/app/code/core/Mage/Core/Model/Session.php(39): Mage_Core_Model_Session_Abstract->init(’core’, ‘adminhtml’)
#4 /home/www/web57/html/magento/app/code/core/Mage/Core/Model/Config.php(1086): Mage_Core_Model_Session->__construct(’core’, ‘adminhtml’)
#5 /home/www/web57/html/magento/app/Mage.php(319): Mage_Core_Model_Config->getModelInstance(Array)
#6 /home/www/web57/html/magento/app/Mage.php(333): Mage::getModel(’core/session’, Array)
#7 /home/www/web57/html/magento/app/code/core/Mage/Core/Controller/Varien/Action.php(440): Mage::getSingleton(’core/session’, Array)
#8 /home/www/web57/html/magento/app/code/core/Mage/Adminhtml/Controller/Action.php(130): Mage_Core_Controller_Varien_Action->preDispatch(’core/session’, Array)
#9 /home/www/web57/html/magento/app/code/core/Mage/Core/Controller/Varien/Action.php(365): Mage_Adminhtml_Controller_Action->preDispatch()
#10 /home/www/web57/html/magento/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(248): Mage_Core_Controller_Varien_Action->dispatch()
#11 /home/www/web57/html/magento/app/code/core/Mage/Core/Controller/Varien/Front.php(158): Mage_Core_Controller_Varien_Router_Standard->match(’index’)
#12 /home/www/web57/html/magento/app/Mage.php(459): Mage_Core_Controller_Varien_Front->dispatch(Object(Mage_Core_Controller_Request_Http))
#13 /home/www/web57/html/magento/index.php(65): Mage::run()
#14 {main}

Is there a special way how I have to install Magento or Magento Connect, so the Connect part works without any problems, or does my Hosting Provider have to change something.
Would love to get the Magento Connect working.

Thank you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 

Sounds like PHP is running as an Apache module. Try deleting your var/cache/ and var/session/ directory and make sure they have the correct permissions:

chomd o+var/

Or 777 for the var directory and all directories under it.

 
Magento Community Magento Community
Magento Community
Magento Community
 
relentless1
Member
 
Total Posts:  67
Joined:  2009-04-02
 

the solution here

http://www.magentocommerce.com/boards/viewthread/179097/

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top