Magento Forum

   
Page 1 of 3
Language changes to default store view! 
 
Tesla
Jr. Member
 
Total Posts:  19
Joined:  2008-04-28
 

Is this a bug or a misconfiguration from my side?
I have 2 languages, 1 store view default = enlish
and second swedish.
Each time I select swedish it works fine, but as soon I enter links etc language changes back to english.
How do I make the language “stick” throughout the user session?

Cheers

 
Magento Community Magento Community
Magento Community
Magento Community
 
Savage
Jr. Member
 
Total Posts:  4
Joined:  2008-05-07
 

Did you ever solve this? I’ve got two languages also, English and Norwegian. It keeps going back to English whenever I navigate on the site.

Anyone?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Loic_LC
Sr. Member
 
Avatar
Total Posts:  194
Joined:  2007-12-19
Paris, France
 

I’m exactly in the same situation. Ok I know this doesn’t help you, but I’ll look into it too.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Yoke Lee
Sr. Member
 
Avatar
Total Posts:  80
Joined:  2008-05-08
China - Singapore
 

I heard it will always does that in Windows.
But it’s safe in Linux.

maybe we should report this a bug ?  smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
doctorlogos
Sr. Member
 
Avatar
Total Posts:  178
Joined:  2008-05-06
 

I have the same issue.

Can anybody help us?

 
Magento Community Magento Community
Magento Community
Magento Community
 
amitsamtani
Jr. Member
 
Total Posts:  7
Joined:  2007-10-03
 

I’m having the same issue. It doesn’t seem like its a Windows only problem though. I’m using OSX/Firefox and it happens there as well.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Loic_LC
Sr. Member
 
Avatar
Total Posts:  194
Joined:  2007-12-19
Paris, France
 

anybody making progress on this ?
Is this a bug or a miss configuration ?
Any help / answer from the team would be appreciated.
Thanks…

 
Magento Community Magento Community
Magento Community
Magento Community
 
doctorlogos
Sr. Member
 
Avatar
Total Posts:  178
Joined:  2008-05-06
 

No progress oh oh

 
Magento Community Magento Community
Magento Community
Magento Community
 
Loic_LC
Sr. Member
 
Avatar
Total Posts:  194
Joined:  2007-12-19
Paris, France
 

I’ve submitted to bug tracking, with the ID #5011
I’ll let you know…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

Did you try to refresh the cache (System -> Cache Management) ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Loic_LC
Sr. Member
 
Avatar
Total Posts:  194
Joined:  2007-12-19
Paris, France
 

yes I did, but no changes :(

thanks for the hint anyway.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 
Loïc - 28 May 2008 12:58 AM

yes I did, but no changes :(

How did you install the translation ?

Can you please PM me the link to your store ?

Thank you,
Michael.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Loic_LC
Sr. Member
 
Avatar
Total Posts:  194
Joined:  2007-12-19
Paris, France
 

Thanks for your concerns Michael.

Unfortunatly as I told you by PM I don’t have an online site yet, it’s local.

Here are the steps I followed to install languages (english + French) :

1/ download language files and place into the right folders (app > local)
2/ Log into admin panel System > Manage stores
3/ create new store view
4/ Log into admin panel System > Configuration > general
then select store view “english” locale options > locale > English (United states)
select store view “Francais” locale options > locales > French (France)
Save config

When I’m in front end, I can see both langues, and switch between them, it just doesn’t stay in French, and goes back to English (which is the default language in my case)

thanks for your help…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

Are you able to log in as a customer ? It seems that cookies don’t work for you.

If your local Magento is installed like http://localhost/ or http://localhost/magento you can use something like http://localhost.com/ or http://localhost.com/magento correspondingly. That is a known issue for most browsers - they don’t save cookies if domain name doesn’t contain point (period).

Please let me know if it helps.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Loic_LC
Sr. Member
 
Avatar
Total Posts:  194
Joined:  2007-12-19
Paris, France
 

Great !
It’s solved (so you can set “resolved” to tracking bug #5011)

for me http://localhost.com/ didn’t work, but http://127.0.0.1/ did

thank you so much for your help.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Andrea, Argentina
Sr. Member
 
Total Posts:  164
Joined:  2007-12-05
Buenos Aires, Argentina
 

I have the same problem. I tried with 127.0.0.1 instead of localhost but when I click any category the URL changes to localhost AND returns to my default store view :(

Any idea?
Thank you

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top
Page 1 of 3