Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Can’t add products with custom options to cart!!!  SAYS - Please specify the product required option(s) 1.3.2.4
 
mastro97
Jr. Member
 
Total Posts:  5
Joined:  2009-12-25
 

Can’t add to cart any item with custom options, even with a new product i just made with custom options for size!!!  SAYS - Please specify the product required option(s) .  I checked the forums here and nothing worked for 1.3.2.4.  A line in the changelog for one of the previous updates said it addressed this issue.  It is STILL happening.

This is on products with options.  Products without options add to the cart just fine.  I have tried to make a new simple product with custom options for size, and the same thing happens, Please specify the product required option(s).

Upgraded to 1.3.2.4 but it did not fix it.

Please anyone, please.  I was about to go live, just got the payment setup and this came out of nowhere!

Thanks so much.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mastro97
Jr. Member
 
Total Posts:  5
Joined:  2009-12-25
 

there are a few other posts about people with the same prob and it not working.  ask yourself..  do I have ssl. 

That is where my problem lies.  The underwriter for the payment gateway required the whole site to be ssl.  SO i added the required lines to my htaccess..  fine. whole site https and working fine.  I setup the secure urls and set the frontend and admin to use ssl.  fine..  the problem is, you need to change the UNSECURE base url to be https instead of http.  this works now, and my whole site is ssl , and the stupid problem with adding custom option items to the cart is fixed.  I had no idea that this problem was related to ssl until hours of trying to redo products, etc.

JM

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sunjerseys
Jr. Member
 
Avatar
Total Posts:  1
Joined:  2011-04-15
 

I know this is an old post, but thank you for posting about the ssl.  I couldn\’t add to cart in 1.6.2.0 getting Please specify the product required option(s).  I had changed the base url in the core_config table and it seemed to break some things.  Changing the protocol from https and then back to http with the new base url name fixed the problem and I can now add to cart.

 
Magento Community Magento Community
Magento Community
Magento Community
 
darinf
Jr. Member
 
Total Posts:  4
Joined:  2013-04-03
 

This is an old thread, but still relevant.

Thank you for the solution. I was having the same problem.

My site was also setup to have everything https:

So when I entered http: as my base URL, I was getting the error on custom options.

But once I changed the unsecure base URL to https:, everything started working.

Makes sense, but hard to figure out!

Thanks,
-Darin

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top