Magento Forum

   
Can’t View/Add Orders in Admin Mode, White Screen. 
 
nickfran
Jr. Member
 
Total Posts:  14
Joined:  2009-12-23
 

Basically, my problem is: I installed magento through BlueHost / SimpleScripts. It installed and worked perfectly. Placed a test order in Magento (PayPal Website Payments Standard) worked great, and I can view the order as I login to customer mode. When I login to Admin Mode I see the order but when I click it to view, I get a white screen no text. I tried multiple browsers. The same thing occurs if I click “Create New Order” from the admin section.

I found this http://www.dssquared.com/2008/10/can’t-view-orders-from-salesorders-in-magento/ and that is all I could find relating to the issue. I went into blue host switched to php.inc and generated a new file and clicked generate. The php.inc file generated in my Public_HTML folder and I changed from 32M to 64M as the blog post suggests but that didn’t solve my problem. I even uninstalled and reinstalled Magento.

Please Help if you can! I really appreciate it! Please guide me through as step-by-step as possible I think it would be best to under estimate my knowledge of PHP and MySQL and assume I know nothing so that I can follow step by step and hopefully get this fixed! Thanks everyone! This would be an awesome christmas present to get my Magento store working!


My current Magento version 1.3.2.4

 
Magento Community Magento Community
Magento Community
Magento Community
 
nickfran
Jr. Member
 
Total Posts:  14
Joined:  2009-12-23
 

Fixed it by trying to increase memory limit again to 64M, don’t know what went wrong the first time i tried.

 
Magento Community Magento Community
Magento Community
Magento Community
 
MOLÔN LABE!
Jr. Member
 
Total Posts:  4
Joined:  2009-08-30
 

Hi!

I have the exact problem - can you help?

What exactly did you change and in which file?

Thanks!

Daniel

 
Magento Community Magento Community
Magento Community
Magento Community
 
nickfran
Jr. Member
 
Total Posts:  14
Joined:  2009-12-23
 

Hi Daniel,
I guess it depends on your hosting provider. I have bluehost but I think this would work for any hosting provider. The problem was that the memory was too low, Magento couldn’t process everything it needed to with the default 32M of memory. You have to increase it to 64M or sometimes even higher 128M (64M worked for me).

If you have CPanel:
1. Login to CPanel
2. If available click on the PHP Config link/icon (For me it was under software and services)
3. Select the second option PHP5 (Single.ini) and click “Save Changes”.
4. Click “Install PHP.INI master file” after you click Save changes.
--------
Exit Cpanel:
1. Open FTP Client (Dreamweaver is my choice, but you can use any I.E. FileZilla)
2. Login to FTP Server
3. Open public_html folder
4. Drag over/open the php.ini file
5. Rename the local copy php.ini.txt if you cannot get it to open with notepad or dreamweaver or some other editor.
6. Open the local copy.
7. Find this section of the file

;;;;;;;;;;;;;;;;;;;

Resource Limits ;

;;;;;;;;;;;;;;;;;;;

max_execution_time 30     Maximum execution time of each scriptin seconds

max_input_time 
60    Maximum amount of time each script may spend parsing request data

memory_limit 
32M      Maximum amount of memory a script may consume (32MB)

Change

memory_limit 32M
to
memory_limit 64M
or higher if this doesn’t fix the problem.

Then save the file removing the .txt extension if you added it so the file name is “php.ini” then publish it into your public_html folder.

ONLY DO THIS IF YOU CANNOT GENERATE IT FROM CPANEL
If you cannot generate the php.ini file from your hosting provider, a sample one should be available in the root folder of your magento installation. Use the one from your hosting provider first before using the one provided in the magento folder. Then just make the same changes rename it to php.ini and publish it to the public_html folder.

Hope this helps! Happy Holidays!
- Nick

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top