Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Can’t upload product images…. 
 
cosmicbandito
Jr. Member
 
Total Posts:  16
Joined:  2008-06-04
 

Hi,

I just came to the same problem, that’s not able to upload pictures. Well, I’ll try the php.ini configuration next.

But just for info, it seems to be a server issue for me. The upload doesn’t work on the webserver, which is a apache server on a linux system. But I tried it on a local XAMPP configuration (Apache and WinXP) too and there the upload worked fine. In each case I used the same browser which was FF.

I’ll let you know if the php.ini thing fixed it…

 
Magento Community Magento Community
Magento Community
Magento Community
 
alexallied
Jr. Member
 
Total Posts:  7
Joined:  2008-06-12
 

The php.ini does it for me. Had been cracking my head over this issue for over a month now!!

Make a php.ini file and add the following lines. Save, and upload into your magento folder.

register_globals=On
allow_url_fopen=On
magic_quotes_gpc = off
short_open_tag = on
extension=pdo.so
extension=pdo_mysql.so

Hope that helps.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mtulett
Jr. Member
 
Total Posts:  4
Joined:  2008-06-04
 

OK, I could not fix the issue where I uploaded an image and it logged me out. So I got onto the Varian guys and paid them to set the thing up for me in case I had done anything stoopid installing it. They got the same problem and went away and found it is indeed down to a server setting.

So to fix it what you need to do is create yourself a php.ini file in your magento folder with the following

suhosin.session.cryptua = Off

then set the permissions for it to 644 and away you go......I did this and it all worked beautifully (although it initially confused my server into thinking I didn’t have pdo_sql installed, but that was only temporary)

Hope that works for anyone else with the same issue…

Cheers

 
Magento Community Magento Community
Magento Community
Magento Community
 
catchgraphics
Jr. Member
 
Total Posts:  11
Joined:  2008-03-23
 

I have the same problem – not able to upload images onto server. It doesn’t require SSL as it works fine on my local server and have got it working in a previous version of Magento without an SSL certificate. I think it is a permissions problem as I have had problem after problem with my new install of Magento and each problem has been resolved by changing the permissions to 755 or 644. I don’t want to go to every single file and change the permissions as that would take forever. Perhaps it is an incompatibility with my Aspiration webhosting company (but others have posted the same problem). The same version installs perfectly on my local server without a problem so I am guessing that Magento’s default permissions don’t match Aspiration (my webhosting company’s permissions).
If someone could please respond from Magento on these issues that would be great as a lot of people are having these issues.
Many thanks

Michael

 
Magento Community Magento Community
Magento Community
Magento Community
 
fitabo.com
Jr. Member
 
Total Posts:  5
Joined:  2008-07-08
 

Is there another workaround? I tried all fixes mentioned here in this thread and nothing works for me, the image upload works normal and it says “Complete” but nothing happens, no image in the list, no image in the media folder!

System: Mac 10.5.4
Browser: latest Safari, latest Flash
latest Xampp Install

 
Magento Community Magento Community
Magento Community
Magento Community
 
finderbee
Jr. Member
 
Total Posts:  8
Joined:  2008-04-14
 

Just a thought about this image upload failure problem.

It appears to me that some of you are having problems caused by the restriction imposed by PHP safe mode. Note that the current system requirements for Magento include “php_safe_mode = off”.

The PHP safe mode is an attempt to solve the shared-server security problem by imposing several limitations that might cause some scripts to go wild, well not quite wink .  Basically, when it is switched on (as in many shared hosts), PHP does a UID compare check to see if the owner of the current script matches the owner of the file to be operated on. Now if you run php as an apache module, the temporary img-upload file or the directory created by the script would be owned by the apache user (could be apache, www-data, etc). Now, if the script is owned by user somebody-else, the compare check failed and the “safe mode restriction” would be in effect, thus image upload failed.

More info about php_safe_mode:  http://www.php.net/features.safe-mode
To check if it is switched on:  simply use php_info().
Possible solution (not-tested): if you could, set php_safe_mode = off ; otherwise try some work-around out there, such as relaxing the UID check with safe_mode_gid = true; or running php as cgi; or deploying su_php; etc. etc.

Hope this helps. Cheers.

 
Magento Community Magento Community
Magento Community
Magento Community
 
cosmicbandito
Jr. Member
 
Total Posts:  16
Joined:  2008-06-04
 

Thanks mtulett,

the suhosin.session.cryptua = Off in php.ini worked for me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Etasker
Member
 
Total Posts:  54
Joined:  2008-07-17
Denmark
 
mtulett - 05 July 2008 09:02 AM

OK, I could not fix the issue where I uploaded an image and it logged me out. So I got onto the Varian guys and paid them to set the thing up for me in case I had done anything stoopid installing it. They got the same problem and went away and found it is indeed down to a server setting.

So to fix it what you need to do is create yourself a php.ini file in your magento folder with the following

suhosin.session.cryptua = Off

then set the permissions for it to 644 and away you go......I did this and it all worked beautifully (although it initially confused my server into thinking I didn’t have pdo_sql installed, but that was only temporary)

Hope that works for anyone else with the same issue…

Cheers

Beautiful!!! it works!

Just remember to save it in coding “ANSI” I tried “UTF-8” dosen’t work wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

Hi guys,

We have settled this problem of ours by adding a new php.ini file with the followings in Magento root folder:-

magic_quotes_gpc = off
short_open_tag = on
extension=pdo.so
extension=pdo_mysql.so

Regards,
James

 
Magento Community Magento Community
Magento Community
Magento Community
 
Gregersen
Member
 
Total Posts:  57
Joined:  2008-06-15
 

Hi…

I have the same problem about uploading pictures.. It just won’t work…
I tried with the php.ini in Magentos root folder, but with no luck.
Now I have tried to get my host to change apaches php.ini with following values:

suhosin.session.cryptua = off
magic_quotes_gpc = off
short_open_tag = on
extension = pdo.so
extension = pdo_mysql.so

But it still not working…
What can I now try to do?

Kind regards,
Mr. Gregersen

 
Magento Community Magento Community
Magento Community
Magento Community
 
skitpt
Jr. Member
 
Total Posts:  17
Joined:  2008-05-09
 

Not working either. app/etc its 777 also is /var and /media and php.ini is there with all those mods. Nothing did it!
Damn ... Maybe because my host has suExec ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

@ skitpt: If your host has suExec enabled, you will need to change all permissions of 777 to 755. wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
skitpt
Jr. Member
 
Total Posts:  17
Joined:  2008-05-09
 

Done that and its still the same, i’m already talking with some people from tech support and they say the permissions are ok.

Added the php.ini but nothing done. Ok the php.ini is not even being read since they have protection against that.

What else can i do ? I have it running outside an domain and on something like this 100.100.100.100/~store/ can this be the problem ?

I have already added https to the secure form but that didnt work either.

Setting the permissions to 755 /var /media and /app/etc makes magento fail.

The sysadmin has already tried it even with the safe-mode off.

Someone help me out please.

 
Magento Community Magento Community
Magento Community
Magento Community
 
speedyss
Jr. Member
 
Total Posts:  24
Joined:  2008-07-02
 

I am facing the same problem with EUKHOST.com, the file ‘uploads’ fine but then does not show up in the preview area. This problem has only surfaced in the last 3-4 days. I haven’t changed any code which leads me to believe it is something to do with their hosting...I will be requesting a log of what changes they have made to their config in the last 3-4 days..

EDIT: I have resolved this problem, my host changed the ownership of the files and directories from Nobody to <cpanel username> and images are now uploaded every time…

EDIT2: It is broken again, no idea what to do now....I have tried a clean install which leads to the same thing…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Anna Perena
Member
 
Total Posts:  41
Joined:  2008-06-07
 

I’m having this same problem - upload complete, no image appears and I get logged out, with a fresh installation of 1.1.2

Could we get an official response and support on this issue please.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top