Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Can’t upload product images…. 
 
SGLoughlin
Jr. Member
 
Total Posts:  2
Joined:  2008-05-07
 

Hi Everyone,

Your discussion has helped me tremendously in understanding my own photo uploading problem. I’ve been having a similar problem, except that I do not get logged off. I can “Browse Files” and “Upload Files” but after it says the file uploading is complete, the files do not move into the image manager section where you control whether it’s a “Base” “Small” or “Thumb” photo. It also does not save the images after uploading.

I attached a screenshot to show you what I’m trying to describe.

Is this a related bug to the one you’ve been discussing?

Thank you,
Susan

Image Attachments
Picture 1.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
castus
Member
 
Total Posts:  64
Joined:  2008-06-04
 

I also get the same as you Susan.

All files and folders are set CHMOD 777. Although, surely it’s a little risky and unnecessary to have everything 777!

 
Magento Community Magento Community
Magento Community
Magento Community
 
FlappySocks
Member
 
Total Posts:  31
Joined:  2008-02-05
 

OMG!  I have spent a whole week getting my shop ready for launch, leaving this image issue as the last thing to fix, and now I have found this thread, and it is two months old!  Why hasn’t this problem been fixed?! :-O

 
Magento Community Magento Community
Magento Community
Magento Community
 
bowers2000
Member
 
Total Posts:  31
Joined:  2008-05-21
 

My suggestion is to try and upload the images from a different computer and/or different internet connection.  I can’t upload images at work, but it works just fine at my house.  I think it’s a firewall issue, or the way session info is passed because at work it always makes me re authenticate...then doesn’t work.

 
Magento Community Magento Community
Magento Community
Magento Community
 
FlappySocks
Member
 
Total Posts:  31
Joined:  2008-02-05
 

Believe me I have done all of that.  Studied all the threads on this topic, three times over.  Tried everything suggested.  IE, Firefox, Konqueror, Linux, Win2K, Win XP.  File permissions, commending out PHP, changing config files, SSL, Not SSL, rebooting, clearing cashes, cookies, etc etc.  I dont really have a choice right now… Monday i have to switch platform, and start again.  i only wish I had found this thread earlier, because had I known this issue was two months old, I could have saved myself a weeks worth of effort.

 
Magento Community Magento Community
Magento Community
Magento Community
 
FlappySocks
Member
 
Total Posts:  31
Joined:  2008-02-05
 

Fixed my problem.  Image sizes were too big.  I resized everything to 1024x768, and they upload.  Pheeew, was getting seriously worried there.

 
Magento Community Magento Community
Magento Community
Magento Community
 
castus
Member
 
Total Posts:  64
Joined:  2008-06-04
 

My images weren’t being uploaded - I was getting a complete message but the images were not showing in the backend. When I sorted this problem they weren’t showing in the frontend either.

To fix the upload problem it was my permissions for the /media/tmp folders. I thought I had set everything to 777, but had missed this off. Make sure every folder is set 777!

Then I found that images sometimes weren’t being shown in the fronted etc. This was because all sorts of folders in the /media/catalog/product/ folder had already been put there by the example data. So I deleted all of these folders. Then all folders and sub folders are made successfully by Magento and everything seems to work fine.

 
Magento Community Magento Community
Magento Community
Magento Community
 
slawsonb
Jr. Member
 
Total Posts:  2
Joined:  2008-03-08
 

Thanks for the advise.  My permissions and everything looks fine.  It says the image is uploaded but isn’t.  This is a really annoying bug that needs some attention.  I would love to get off osCommerce but this isn’t ready for production yet.  Maybe next year.

Bruce

 
Magento Community Magento Community
Magento Community
Magento Community
 
castus
Member
 
Total Posts:  64
Joined:  2008-06-04
 

try deleting all of the folders and sub folders in /media/catalog/product/ and /media/tmp/

 
Magento Community Magento Community
Magento Community
Magento Community
 
davinder
Member
 
Total Posts:  56
Joined:  2008-06-26
 

Alright guys, I found the solution and it works like a charm!! Add new php.ini file if you dont have or add this code into your existing php.ini file:

magic_quotes_gpc = off
short_open_tag = on
extension=pdo.so
extension=pdo_mysql.so

 
Magento Community Magento Community
Magento Community
Magento Community
 
easymobiles
Jr. Member
 
Avatar
Total Posts:  25
Joined:  2008-03-10
 

Hi Everyone,
I have a pretty serious problem affecting our website at the moment http://www.mobicity.com.au.  I’ve posted this elsewhere but haven’t foudn anyone that can help so I’m hoping people in this thread might have some clues.

I have had a running version of 1.0 installed on the site for quite some time but decided to update to 1.0.19870.4 today to keep up with the latest releases and security.  I followed the upgrade process to do a PEAR installation using Magento Connect by typing in magento-core/Mage_All_Latest.  The update went straight through with no issues but now that it is installed all of our images are showing up as placeholders only.  The images still happily exist in the media directory but it looks like they are not being found by the PHP.

Other details:
PHP: http://www.mobicity.com.au/phpinfo.php
Error message: None given, placeholders are displayed
Magento package type: Full I guess, not sure
cPanel Version: 11.23.3-STABLE
cPanel Build: 25971
Theme: x3
Apache version: 1.3.37 (Unix)
PHP version: 4.4.7 (ignore this it is reported correctly in phpinfo)
MySQL version: 4.1.22-standard
Architecture: i686
Operating system: Linux

I have performed the following .htaccess change at my hosting providers request (enables PHP 5):

AddHandler application/x-httpd-php5 .php .php4 .php3 .phtml

The only other extension I have installed at the moment (and I’ve tried it with it uninstalled as well) is Fontis_Australia.

I’d appreciate any help that can be given as we are desperate to get our site back to normal.

The other puzzling thing is that if we enable an RSS feed of hot mobiles (hot products) it will show the product images correctly.

I have also tried deleting the images off a product, re-uploading them through Magento Admin and setting them to be thumbnails, etc and it still doesn’t show up on the front end.  The images are visible and successfully loaded up on the back end.

Cache has been enabled and disabled and flushed.  Session and Cache folders have been deleted multiple times from the Var directory.

What else should I try!?

Happy to provide cpanel, FTP or Magento login details on request by PM.

Cheers.

 
Magento Community Magento Community
Magento Community
Magento Community
 
easymobiles
Jr. Member
 
Avatar
Total Posts:  25
Joined:  2008-03-10
 
easymobiles - 30 June 2008 02:55 PM

Hi Everyone,
I have a pretty serious problem affecting our website at the moment http://www.mobicity.com.au.  I’ve posted this elsewhere but haven’t foudn anyone that can help so I’m hoping people in this thread might have some clues.

I managed to fix this issue by following the instruction laid out here.  Hope this helps others as it has been a very frustrating time for me.  I can only guess that my host has mem test disabled.

http://www.magentocommerce.com/boards/viewthread/7486/#t31484

 
Magento Community Magento Community
Magento Community
Magento Community
 
neillh
Jr. Member
 
Avatar
Total Posts:  1
Joined:  2008-06-30
Sydney, Australia
 

I have fixed my problem.
I could select an image. upload it, but then when i went to save it nothing happeed

I went into:
System --> Configuration --> Web

Set my Unsecure Base Url to “http://www.domain.com.au/magentofolder/” (Added www to it and made sure it was http not https)
Set my Secure Base URL to “https://www.domain.com.au/magentofolder/” (Added www to it and left it as https)

Now i can upload images and set them as thumb main etc etc

 
Magento Community Magento Community
Magento Community
Magento Community
 
mtulett
Jr. Member
 
Total Posts:  4
Joined:  2008-06-04
 

Hi all,

Anything new to report on this? I’m getting the same problem that was mentioned earlier - I try to upload images but it says ‘completed’ then I hit save and it logs me out and nothing is saved.

I have checked all the permissions, non of my images are larger than about 150k and I have tried all the other things mentioned in this thread apart from the php.ini modifications as I don’t really want to turn off magic quotes (but if anyone else has done this and it has worked then please let me know!)

If not then has anything else come to light that might get this working?

Many thanks, Matt

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jeff S
Jr. Member
 
Total Posts:  8
Joined:  2008-02-21
 

I had the same problem some people were having where the upload hits 100% and then nothing happens (not getting logged out like some of you). As mentioned on an earlier post I tried resizing the images first, they were huge pics sent from the client, and as soon as I tried the resized pic it worked fine.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top