Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Hilfe, ich kann mich nicht mehr im Admin-Bereich einloggen
 
unexplored
Jr. Member
 
Total Posts:  10
Joined:  2008-02-28
 

Hallo Magento-Freunde,

ich hab folgendes Problem:
Hab gestern meinen ersten Shop installiert und fleißig Kategorien und Produkte erstellt.
Wollte mich heute morgen im Admin-Bereich anmelden, doch das klappte nicht mehr.
Passwort war das richtige, ich erhielt keine Fehlermeldung. Nach dem Buttonklick passiert einfach nix.

Wenn ich ein falsches Paßwort angebe, kommt die Meldung ‘Zugriff verweigert’.
Hab den Passwort-Reminder getestet, doch die Mail mit dem neuen Passwort kommt nicht an.
Obwohl Magento den Mailversandt bestätigt hat.

Hab in der Datenbank nachgeschaut, die Mailadresse ist korrekt eingerichtet.

Hat jemand ne Idee? Jetzt wurde meine Passwort von Magento geändert, die Mail mit dem Passwort kommt nicht an.

Was kann ich tun?

Gruß,
Björn

 
Magento Community Magento Community
Magento Community
Magento Community
 
unexplored
Jr. Member
 
Total Posts:  10
Joined:  2008-02-28
 

Keiner eine Idee?

Hab schon versucht über phpMyAdmin einen neuen User ohne Passwort anzulegen.
Leider verlangt das Anmeldeformular ein Passwort, leeres Feld ist nicht erlaubt.
Und da die Passwörter in der DB verschlüsselt sind, hab ich ein Problem.

Ich bin heiß auf Magento! Mensch, schon 5 Stunden verschenkt :(
Kann doch nicht sein das ich Magento neu installieren muß ...

 
Magento Community Magento Community
Magento Community
Magento Community
 
jan212
Guru
 
Avatar
Total Posts:  407
Joined:  2008-01-03
 

Teste mal bitte:

UPDATE `admin_userSET `password`=MD5('mypassword'WHERE `username`='admin';

Oder per phpmyadmin in TABLE admin_user, FIELD password reinkopieren, vorher als MD5 Hash verschlüsseln
http://files.kniebes.net/php/md5/

 
Magento Community Magento Community
Magento Community
Magento Community
 
unexplored
Jr. Member
 
Total Posts:  10
Joined:  2008-02-28
 

Hi jan212,

danke für den Tip. Ich hab Magento mittlerweile neu installiert.
Nächstes Mal probier ich es aus wink

Ciao
Björn

 
Magento Community Magento Community
Magento Community
Magento Community
 
jan212
Guru
 
Avatar
Total Posts:  407
Joined:  2008-01-03
 

Bitte bitte, allet klar smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
QuadraVis
Sr. Member
 
Avatar
Total Posts:  82
Joined:  2008-05-30
D - Erbach
 
jan212 - 27 April 2008 02:37 PM

Teste mal bitte:

UPDATE `admin_userSET `password`=MD5('mypassword'WHERE `username`='admin';

Danke, hat geholfen.

 
Magento Community Magento Community
Magento Community
Magento Community
 
artlos
Jr. Member
 
Total Posts:  3
Joined:  2007-11-26
 

Schade, bei mir klappt das leider nicht :-(

Vorgeschichte: Ich habe Magento gerade das erste Mal testweise installiert und so weit lief auch alles recht problemlos. Nach einigem Hin- und Herklicken im Admin-Bereich habe ich die deutsche Sprachdatei installiert. Und ab diesem Moment konnte ich mich nicht mehr einloggen. Die neue Passwortanforderung funktioniert, sprich: mir wird eine Mail zugesendet. Aber auch das automatisch generierte Passwort wird nicht akzeptiert. Und die oben genannte SQL-Direkteingabe bringt leider auch noch immer den selben Fehler: “Zugriff verweigert”.

Hat jemand eine Idee, woran es hakt?

 
Magento Community Magento Community
Magento Community
Magento Community
 
artlos
Jr. Member
 
Total Posts:  3
Joined:  2007-11-26
 

Vielen Dank für die schnelle Antwort!
Mittlerweile bin ich zwei Schritte weiter: Die Installation läuft, sie läuft auf deutsch, und ich kann mich auch nach dem aus- wieder einloggen wink
Ob der Fehler an den cookies lag, kann ich nicht definitiv beantworten, weil ich diese nämlich nirgends gefunden habe.
ABER: Es wäre durchaus plausibel, weil ich laut Anleitung
> 3. Unter System -> Cache management den Haken bei “Translations” rausnehmen und bei “All Cache” den Punkt “Refresh” wählen
> 4. “Save cache settings” klicken und danach unten links als Sprache German (Germany) wählen
> 5. Magento in deutsch genießen
gestern nämlich den Punkt 3 gar nicht mehr angewählt hatte, weil mich das System unmittelbar nach Installation des Sprachpakets auf deutsch “ansprang”, und folglich auch Punkt 4 nicht mehr befolgte.
Wie auch immer: Da ich noch keinerlei Artikel eingegeben hatte, habe ich alles schlicht nochmal installiert…

Ein kleines “neues” Problem taucht aber auf, welches gestern bei der ersten Installation auch schon auftrat:
Nach dem Login erscheint ein kleines Flash-Fenster, dass die Version 1.1.8 erschienen sei. Und in der Kopfzeile ist ein Hinweis als kritisch ausgewiesen.
NUR: Ich habe ja die 1.1.8 installiert, was mir auch unten in der Fußzeile angezeigt wird. Woher wird also dieser Hinweis geholt? (übrigens sowohl auf der deutschen als auch auf der englischen Oberfläche)

 
Magento Community Magento Community
Magento Community
Magento Community
 
bewi
Jr. Member
 
Total Posts:  9
Joined:  2009-02-11
 

Bei lokaler Installation kein Zugriff via http://localhost/magento/ sonder nur via http://127.0.0.1/magento/. Bei mir Bestand das Login-Problem bei lokaler Installation über Easyphp

Siehe auch unter http://www.magentocommerce.com/boards/viewthread/4337

 
Magento Community Magento Community
Magento Community
Magento Community
 
Esteffano
Jr. Member
 
Total Posts:  4
Joined:  2008-04-24
 
Rico Neitzel - 15 December 2008 09:42 PM

Also am Lang-Pack sollte es nicht scheitern. Mein Tip: lösch mal die session/path/domaincookies. Vllt hat dein browser hartnäckig ein cookie mit falschen zugangsdaten gespeichert…
LG rico

Hallo.
Das ist ein wirklich brauchbarer Tipp.
Ich habe die Installation 2x gemacht, bis ich nach einer Lösung gesucht habe grin

Jetzt werde ich mich im Backoffice umschauen.
Sieht auf den ersten Blick sehr aufgeräumt aus.

Gruß,
Christian

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top