Magento Forum

   
Reuploaded old 1.7.02 version after 1.8.0 was a bust - Now I Get Table Not Found 1146 Error
 
suitesop
Jr. Member
 
Total Posts:  4
Joined:  2013-11-02
 

I was on Magento version 1.7.0.2 with several extensions and a rockmage template theme which all worked fine. Until a few days ago I updated to 1.8.0 then went to test my cart and was stuck in a loop that would not proceed past the shipping section of the Onepage checkout. So, I freaked out!  I looked for fixes and couldn’t seem to find anything so I ended up removing everything (hosting files and the db) Then I installed version 1.8.0 fresh in hopes that I could import my 1.7.02 database. However that was extremely frustrating. So I ended up removing all of that. Creating a new EMPTY database with full privileges, imported a saved version of my full 1.7.02 store database into the empty database. and uploaded my original store hosting files on my server again. I was able to configure the app/etc/local.xml to the new db settings yet when I cleared the var folder and refreshed the web browser, I am getting the following error:

SQLSTATE[42S02]Base table or view not found1146 Table '*myUser*_table.mg_sales_flat_quote_address' doesn't exist

I’ve tried running the Create sales_flat_quote table from the linked page below but no go: 

http://www.magento60s.com/magento/database-upgrade-question-30543.html

The trace statement for the SQLSTATE[42S02] Base Table or view not found is attached as a PDF (I could not fit it here)

(SEE ATTACHED PDF)

Your efficient insight is appreciated.

File Attachments
magento-exception.pdf  (File Size: 6KB - Downloads: 7)
 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1157
Joined:  2008-04-24
 

If you browse the database with a tool like phpMyAdmin, do you see the actual table ‘mg_sales_flat_quote_address’ ? It may sound like your database backup was incomplete, though.

 
Magento Community Magento Community
Magento Community
Magento Community
 
suitesop
Jr. Member
 
Total Posts:  4
Joined:  2013-11-02
 

OK, I was able to make a little head way. I have removed the self created 1.7.02 db and performed a restore in my Cpanel with the last archived db I took.  It seems to have gone through, but now I am getting the following error:

SQLSTATE[28000] [1045] Access denied for user ‘[myDataBaseName]’@’localhost’ (using password: YES)

with the following trace:  (I’m wondering if this is a directory permissions issue?) but not sure.

Trace:
#0 /home/[myAccountName]/public_html/lib/Zend/Db/Adapter/Pdo/Mysql.php(96): Zend_Db_Adapter_Pdo_Abstract->_connect()
#1 /home/[myAccountName]/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php(320): Zend_Db_Adapter_Pdo_Mysql->_connect()
#2 /home/[myAccountName]/public_html/lib/Zend/Db/Adapter/Abstract.php(459): Varien_Db_Adapter_Pdo_Mysql->_connect()
#3 /home/[myAccountName]/public_html/lib/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query(’SET NAMES utf8’, Array)
#4 /home/[myAccountName]/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php(428): Zend_Db_Adapter_Pdo_Abstract->query(’SET NAMES utf8’, Array)
#5 /home/[myAccountName]/public_html/app/code/core/Mage/Core/Model/Resource.php(169): Varien_Db_Adapter_Pdo_Mysql->query(’SET NAMES utf8’)
#6 /home/[myAccountName]/public_html/app/code/core/Mage/Core/Model/Resource.php(110): Mage_Core_Model_Resource->_newConnection(’pdo_mysql’, Object(Mage_Core_Model_Config_Element))
#7 /home/[myAccountName]/public_html/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(320): Mage_Core_Model_Resource->getConnection(’core_write’)
#8 /home/[myAccountName]/public_html/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(350): Mage_Core_Model_Resource_Db_Abstract->_getConnection(’write’)
#9 /home/[myAccountName]/public_html/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(335): Mage_Core_Model_Resource_Db_Abstract->_getWriteAdapter()
#10 /home/[myAccountName]/public_html/app/code/core/Mage/Core/Model/Resource/Cache.php(53): Mage_Core_Model_Resource_Db_Abstract->_getReadAdapter()
#11 /home/[myAccountName]/public_html/app/code/core/Mage/Core/Model/Cache.php(478): Mage_Core_Model_Resource_Cache->getAllOptions()
#12 /home/[myAccountName]/public_html/app/code/core/Mage/Core/Model/Cache.php(520): Mage_Core_Model_Cache->_initOptions()
#13 /home/[myAccountName]/public_html/app/code/core/Mage/Core/Model/App.php(1183): Mage_Core_Model_Cache->canUse(’config’)
#14 /home/[myAccountName]/public_html/app/code/core/Mage/Core/Model/Config.php(414): Mage_Core_Model_App->useCache(’config’)
#15 /home/[myAccountName]/public_html/app/code/core/Mage/Core/Model/Config.php(294): Mage_Core_Model_Config->_canUseCacheForInit()
#16 /home/[myAccountName]/public_html/app/code/core/Mage/Core/Model/App.php(413): Mage_Core_Model_Config->loadModulesCache()
#17 /home/[myAccountName]/public_html/app/code/core/Mage/Core/Model/App.php(343): Mage_Core_Model_App->_initModules()
#18 /home/[myAccountName]/public_html/app/Mage.php(683): Mage_Core_Model_App->run(Array)
#19 /home/[myAccountName]/public_html/index.php(87): Mage::run(’’, ‘store’)
#20 {main}

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1157
Joined:  2008-04-24
 

You have the wrong database user configured in app/etc/local.xml.

 
Magento Community Magento Community
Magento Community
Magento Community
 
suitesop
Jr. Member
 
Total Posts:  4
Joined:  2013-11-02
 

Yes it was a permissions issue. I had my hosting run the Shell command to change all directories and sub directories back to 755 instead of 777 (which they all seemed to have changed to after re uploading to server).

I got the database name error even though Password was ‘YES’ because I didn’t have the db user created and connected to the db after I restored it.  Also I had to have my .htaccess file replaced on my root.

Now the site is back to normal. For those who have a magento theme. I would caution to research the theme maker to see if the version theme may conflict with the new Magento engine before upgrading.

Cheers.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top