Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

import with magmi
 
enemaxenemax
Jr. Member
 
Total Posts:  1
Joined:  2013-04-21
 

I’ve been working with the magmi csv formatting for weeks now without being able to get the trick making it working.

Desperately need help grin

Magento 1.7.0.2, magmi 0.7.18, Image attributes processor v1.0.25

Settings:
Datasources CSV Datasource v1.3
CSV import mode local
CSVs base directory \\\\magmi\\\\Import\\\\
CSV separator |
CSV enclosure \\\”
Magmi Magento Reindexer v1.0.2 activated
------------------------------------------------------------
Image attributes processor v1.0.25 activated with following settings
image search path /media/import
Image import mode Override existing images
Assign only existing images set to NO
Pre-download check for remote images set to Enable
Debug mode set to Enable
------------------------------------------------------------
On the fly indexer v0.1.5 activated

Here the test csv file I\\\’m using

“store“|“websites“|“attribute_set“|“type“|“category_ids“|“sku“|“has_options“|“name“|“manufacturer“|“meta_title“|“meta_description“|||“url_key“||“gift_message_available“|“url_path“|“custom_design“|“options_container“|“price“|“cost“|“weight“|“minimal_price“|“description“|“meta_keyword“|“in_depth“|“dimension“|“model“|“activation_information“|“short_description“|“custom_layout_update“|“color“|“status“|“tax_class_id“|“visibility“|“qty“|“min_qty“|“use_config_min_qty“|“is_qty_decimal“|“backorders“|“use_config_backorders“|“min_sale_qty“|“use_config_min_sale_qty“|“max_sale_qty“|“use_config_max_sale_qty“|“is_in_stock“|“low_stock_date“|“notify_stock_qty“|“use_config_notify_stock_qty“|“manage_stock“|“use_config_manage_stock“|“stock_status_changed_auto“|“use_config_qty_increments“|“qty_increments“|“use_config_enable_qty_inc“|“enable_qty_increments“|“is_decimal_divided“|“stock_status_changed_automatically“|“use_config_enable_qty_increments“|“product_name“|“store_id“|“product_type_id“|“product_status_changed“|“product_changed_websites“|“processor“|“memory“|“hardrive“|“screensize“|“computer_manufacturers“|“shoe_type“|“gender“|“shoe_size“|“shirt_size“|“country_orgin“|“finish“|“room“|“megapixels“|“ram_size“|“cpu_speed“|“max_resolution“|“response_time“|“contrast_ratio“|“harddrive_speed“|“price_type“|“sku_type“|“weight_type“|“price_view“|“shipment_type“|“special_price“|“special_from_date“|“image_label“|“small_image_label“|“thumbnail_label“|“page_layout“|“country_of_manufacture“|“msrp_enabled“|“msrp_display_actual_price_type“|“msrp“|“enable_googlecheckout“|“is_recurring“|“news_from_date“|“news_to_date“|“special_to_date“|“custom_design_from“|“custom_design_to“|“media_gallery“
“admin“|“base“|“jewellery“|“simple“|“53,35,67,39“|“GilN04.001“|“0“|“Gilda Code:  GilN04.001“|“Venezianodesign“|||“/All/GilN04.001.front.JPG“|“/All/GilN04.001.front.JPG“|“Necklaces_Gilda“|“/All/GilN04.001.front.JPG“|“No“|“Necklaces_Gilda.html“||“Block after Info Column“|“416“||“115g = 0.25lb“||“Wooden beads. Vintage Brass flowers buttons. “|||“46 cm “|||“Necklaces 46 cm“|||“Enabled“|“Taxable Goods“|“Catalog, Search“|“1“|“0“|“1“|“0“|“0“|“1“|“10,000“|“1“|“0“|“1“|“1“|||“1“|“0“|“1“|“0“|“1“|“0“|“1“|“0“|“0“|“0“|“1“|“GilN04.001“|“0“|“simple“|||||||||||||||||||||||||||||“GilN04.001 label“|“GilN04.001 label“|“GilN04.001 label“|“No layout updates“|“Italy“|“Use config“|“Use config“||“No“|“No“||||||“/All/GilN04.001.front.JPG::front;/All/GilN04.001.side.JPG::side;/All/GilN04.001.side45.JPG::side45;/All/GilN04.001.back.JPG::back;/All/GilN04.001.backP.JPG::particoular;::;::;::;::;::“

Here the magmi error
Running Magmi Product Import Engine v1.7.1 by dweeves
Import Profile:default
Import Mode:create
CSV Datasource v1.3 - Importing CSV : C:\\\\xampp\\\\htdocs\\\\magento\\\\magmi\\\\Import/13.10.31-11.13_MagentoCatalogExport_rev 14.13-with quote separator.csv using separator [ | ] enclosing [ \\\” ]
Performing Datasouce Lookup…
Found 2 records, took 0.014691829681396 sec
CSV Datasource v1.3 - No BOM detected, assuming File is UTF8 without BOM…
CSV Datasource v1.3 - 106 CSV headers columns found
Image attributes processor v1.0.25 - no image attributes found in datasource, disabling image processor

I tried to remove the separator without success, PLEASE HELP

Thak you in advance to anyone

 
Magento Community Magento Community
Magento Community
Magento Community
 
serpyre
Enthusiast
 
Avatar
Total Posts:  771
Joined:  2013-05-20
 

Have you been creating the file from Excel, always causes a problem. Try using Notepadd++ and saving the file as UTF8 without BOM.

 
Magento Community Magento Community
Magento Community
Magento Community
 
xvip87
Jr. Member
 
Total Posts:  5
Joined:  2013-11-03
 

Use Notepad++ and change Encoding to UTF8 without BOM will work smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
coscientiam
Jr. Member
 
Total Posts:  26
Joined:  2013-09-24
 

Yeah agree about Notepad++ and BOM encoding issue. This is going to resolve.

Also for those who consider paid solutions for performing import/export, check out this one. It’s based on MAGMI so supports it’s columns mapping (btw see the comprehensive MAGMI columns mapping guide here), and with it such problems like encoding issues are impossible because all your data is stored directly online in Google Spreadsheet and fetched right from there.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top