Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Imagens
 
Source
Jr. Member
 
Total Posts:  4
Joined:  2008-04-08
 

Saudações.

Já procurei (se calhar onde não devia), mas não encontro solução para o seguinte:
- Na criação de um artigo, na escolha dos ficheiros de imagem, este aparecem correctamente (quando passo o ponteiro do rato por cima).
- Quando gravo e tento editar o artigo criado, não aparecem!!!

Não são associadas ao registo embora apareçam no directório \media

Sem poder referênciar imagens aos artigos, nada faz sentido!

Alguém me pode ajudar?

Sistema: IIS local e IE ou Firebird

Obrigado desde já.
Carlos Neves

 
Magento Community Magento Community
Magento Community
Magento Community
 
licentia
Sr. Member
 
Avatar
Total Posts:  78
Joined:  2007-08-31
Portugal
 

Boas,

O upload de imagens não funciona actualmente em sistemas Windows.

Presumo que este bug seja corrigido na próxima actualização.

No entanto se quiser tentar resolver este bug manualmente, dê uma vista de olhos neste tópico

http://www.magentocommerce.com/boards/viewthread/4246/

Saudações

 
Magento Community Magento Community
Magento Community
Magento Community
 
Source
Jr. Member
 
Total Posts:  4
Joined:  2008-04-08
 

Funcionou !
Já agora sabe por que é que com o Modern Theme instalado na pesquisa dos artigos aparece

Ordenar por: Melhor valorgetAvailableOrders())):?>| NomegetAvailableOrders())):?>| PreçogetAvailableOrders())):?>|

na opção de ordenação?

Obrigado.

 
Magento Community Magento Community
Magento Community
Magento Community
 
licentia
Sr. Member
 
Avatar
Total Posts:  78
Joined:  2007-08-31
Portugal
 

Boas,

Parece-me que tem nas definições do seu php.ini a não permissão do uso de short tags.

Faça o seguinte.

No seu ficheiro index.php, depois de algo parecido com isto

if (version_compare(phpversion(), '5.2.0''<')===true{
    
echo  '<div style="font:12px/1.35em arial, helvetica, sans-serif;"><div style="margin:0 0 25px 0; border-bottom:1px solid #ccc;"><h3 style="margin:0; font-size:1.7em; font-weight:normal; text-transform:none; text-align:left; color:#2f2f2f;">Whoops, it looks like you have an invalid PHP version.</h3></div><p>Magento supports PHP 5.2.0 or newer. <a href="http://www.magentocommerce.com/install" target="">Find out</a> how to install</a> Magento using PHP-CGI as a work-around.</p></div>';
    exit;
}

Coloque o seguinte código:

ini_set('short_open_tag',1);

Depois diga se já funciona

Com os melhores cumprimentos,

 
Magento Community Magento Community
Magento Community
Magento Community
 
Source
Jr. Member
 
Total Posts:  4
Joined:  2008-04-08
 

Saudações.

A parte das imagens já funciona correctamente. Obrigado pelo link grin

Nos artigos ainda não. Já tinha colocado

short_open_tag = On no php.ini

e mesmo agora com ini_set(’short_open_tag’,1); em index.php continua a não aparecer correctamente - ver imagem.

Também não entendo porque não aparece a referência ao número de items!!!

Obrigado pela ajuda.
Carlos Neves

Image Attachments
imgArtigos.gif
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top