Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Shipping Carrier(s) already enabled, but it says unavailable. Why? 
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

I really do not understand how the Shipping works.

I had FedEx, UPS, USPS enabled all together and one at a time but I am getting this “This shipping method is currently unavailable. If you would like to ship using this shipping method, please contact us.” error in the Get a Quote and the One page checkout Shipping Method.  I have the USPS Gateway URL entered, had requested the USPS webtools people turned on the account, had entered the User ID and I am still getting the error. :(

Please, can anybody help! Very desperate!

Image Attachments
usps2.jpgusps.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
PCGamesPlus
Sr. Member
 
Avatar
Total Posts:  166
Joined:  2008-01-03
Sacramento, CA
 

In looking at the Gateway URL you are using, it is incomplete. Use “http://production.shippingapis.com/ShippingAPI.dll” without quotes of course.

Cheers Mike

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

Mike, thank you. Unfortuantely that is not the culprit :(

After I corrected this ‘http://production.shippingapis.com/ShippingAPI.dll”, and replacing back all the original files (cart.phtml and shipping.html), removed the cookies along with jQuery files that once caused the state/provinces’s dropdown disappeared), I thought I saw the table rates showed up once. Now I am not certain if I saw it in my imagination out of desperation, because once more refresh I am seeing the same thing again - I repeated three times the steps I did just to make sure I was not hallucinating . It appears I was.

Can anyone please explain to me how the table rates being called? Does it ‘talk’ to the USPS shipping API server? The table rate csv was imported - and I thought I saw the exact table rates (in my hallucination), is it pulled from the database?

please!

 
Magento Community Magento Community
Magento Community
Magento Community
 
leetaylordoes
Sr. Member
 
Total Posts:  227
Joined:  2008-02-05
San Diego, CA
 

Hey chinesedream,

Have you tried the following?

http://production.shippingapis.com/ShippingAPI.dll

Be sure you have a registered Web Tools account, as using your regular USPS login won’t work (https://secure.shippingapis.com/registration/).

Thanks,
Lee

 
Magento Community Magento Community
Magento Community
Magento Community
 
leetaylordoes
Sr. Member
 
Total Posts:  227
Joined:  2008-02-05
San Diego, CA
 

Another reference: http://www.usps.com/webtools/htm/Rate-Calculators-v1-2.htm#_Toc166663647

- Lee

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 
timothyleetaylor - 23 April 2008 11:27 AM

Another reference: http://www.usps.com/webtools/htm/Rate-Calculators-v1-2.htm#_Toc166663647

- Lee

Hi Lee, yes, I have everything setup correctly and has just been confirmed by the USPS ICCC.

Will the table rate affects it? Can you please share your tablerate.csv file?

I followed the Table Rate Setup tutorial from the Wiki or KB.

Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
leetaylordoes
Sr. Member
 
Total Posts:  227
Joined:  2008-02-05
San Diego, CA
 

It seems you have gotten things worked out, correct @chinesedream?

Glad to hear it!

- Lee

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top