Magento Forum

Setup magento so that only the checkout page and Admin area use SSL (https://)
 
Savra
Jr. Member
 
Total Posts:  6
Joined:  2008-04-16
 

Hi,
I am just wondering how i would go about setting up Magento so that only the Admin area and the Checkout area use SSL (https://).

I do not want SSL to be site wide as it causes quite a performance hit but i need it to be secure when entering sensitive information (credit card number, etc)

Cheers,
Matthew

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lior
Magento Team
 
Avatar
Total Posts:  293
Joined:  2007-09-24
 

Go to Admin > System > Configuration > Sales > Web > Secure
You can there configure the site to use SSL for checkout and admin

 
Magento Community Magento Community
Magento Community
Magento Community
 
jppichon
Jr. Member
 
Total Posts:  25
Joined:  2007-09-28
Paris - France
 
Lior - 22 April 2008 10:06 AM

Go to Admin > System > Configuration > Sales > Web > Secure
You can there configure the site to use SSL for checkout and admin

Hello, I’m sorry but I didn’t find the possibility to enable SSL for the checkout because there is no Web section under in Admin -> System -> Configuration -> Sales.

I only found the option to setup SSL for Front end and/or for admin under Admin -> System ->Configuration -> General -> web

Do I missed something ?

Regards

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lior
Magento Team
 
Avatar
Total Posts:  293
Joined:  2007-09-24
 

You found the correct location, sorry for my mistake in the path.

When you select “Yes” for “Use Secure URLs in Frontend” then all sections of the Front End that required security (My Account and Checkout) will be under SSL, the rest of the site will not be under SSL

When you select “Yes” for “Use Secure URLs in Admin” then the entire Admin will be under SSL

 
Magento Community Magento Community
Magento Community
Magento Community
 
brianjking
Jr. Member
 
Avatar
Total Posts:  14
Joined:  2008-02-21
Bowling Green, OH
 

This doesn’t seem to be working for me in 1.0. I have it turned on and a valid SSL certificate although it doesn’t ever change the URL to https://.

Please help! I need to go live in 1 week. Thank you!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lior
Magento Team
 
Avatar
Total Posts:  293
Joined:  2007-09-24
 

@brianjking
PM me your admin login and I will check it for you

 
Magento Community Magento Community
Magento Community
Magento Community
 
brianjking
Jr. Member
 
Avatar
Total Posts:  14
Joined:  2008-02-21
Bowling Green, OH
 

@lior - I PMed you the info. Although I already have it all marked YES where it should be. Please advise. Thank you.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top