Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Nach SSL Installation bei Front - and Backend 404 Fehler Anzeigen
 
mykel
Jr. Member
 
Avatar
Total Posts:  6
Joined:  2007-12-04
Pune
 

Hallo Community,

Dank der Kooperation meines Webspace Providers (Netway Solution) konnte ich die Vorausetzungen für eine Magento Installation schaffen.
Alle nötigen php Extensions sind geladen, mod_rewrite ist von Hause aktiviert, SSL ist ebenfalls gegeben.
store.dulari-collection.com/phpinfo.php
(Operating system Linux, Apache version 2.2.8 (Unix), PHP version 5.2.5, MySQL version 4.1.22-standard)
(p.s. default php is vermutlich die 4er version)

Nach erfolgreichen upload und entpacken aller Daten habe ich den Ordner in store umbenannt, welcher durch die subdomain store.dulari-collection.com erreichbar ist.

Danach habe ich die Chmod’s wie in der Installationanweisung von der magento website beschrieben gesetzt. www.magentocommerce.com/knowledge-base/entry/magento-installation-guide

‘Ensure that the file magento/var/.htaccess, the directories magento/app/etc, magento/var, and all
the directories under magento/media are writable by the web server.’

Hier war ich mir allerdings ein wenig unsicher ob ich denn auch die übergeordneten Ordener wie magento (bei mir store) und app ebenfalls auf 777 setzten muss.
Ich tat es nicht, da in der Beschreibung nicht explizit darauf hingewiesen wurde, hoffe das meine Entscheidung natürlich richtig war.

Danach habe ich die Installation durch Aufruf meiner Subdomain gestartet. Beim Punkt konfiguration habe ich dann SSL für frontend sowohl aus auch für backend gesetzt, als auch mod_rewrite aktiviert.
Als base Url wählte das Installationprogrmm automatisch die richtige Auswahl.
https://store.dulari-collection.com

Bei der Frage nach der SQl Database, die ich schon einige Tage zuvor angelegt habe, habe ich als Ziel localhost:2082 wie es im Beispiel darunter beschrieben ist angegeben. Auch hier war ich mir unsicher ob dies so ganz richtig ist. Den Datenbank-Namen und Datenbank-User und das zugehörige Passwort eingegeben, und die Installtion wurde erfolgreich fortgesetzt und beendet.

Beim anschließenden Öffnen des Backend bekam ich dann prompt eine 404 Fehler Anzeige geliefert.
Zum Frontend konnte ich hingegen bis zur Startseite gelangen (allerdings unter http://store.dulari-collection.com), beim Versuch andere Subseiten zu öffnen wurde mir dann ebenfalls eine 404 Fehler Anzeige geliefert.

Not Found
The requested URL /electronics/cellphones was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

--------------------------------------------------------------------------------

Apache/2.2.8 (Unix) mod_ssl/2.2.8 OpenSSL/0.9.7a DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 mod_jk/1.2.25 Server at store.dulari-collection.com Port 80

Komischerweise bekomme ich unter https://store.dulari-collection.com eine Joomla 1.5 template Seite Skylite Home Page angezeigt welche sicherlich nicht auf meinem webpackage installiert ist (… zudem wird in meiem Package unter Fantastico nur die Joomla 1.0 version als Installer angeboten).

Andere Änderungen (.htaccess) habe ich bisher nicht vorgenommen, da ich bisjetzt natürlich keine Ahnung habe, wo der Fehler denn ganz genau liegt. (Chmod, SSL, Datenbank Addresse o. doch mod_rewrite)
Vielleicht kann mir ja jemand weiterhelfen oder kann mir wenigentens bestätigen das ich die Eingaben soweit korrekt vorgenommen habe, sodaß ich die möglichen Fehlerquelle reduzieren kann.

Thanx
Michael

 
Magento Community Magento Community
Magento Community
Magento Community
 
jan212
Guru
 
Avatar
Total Posts:  407
Joined:  2008-01-03
 

was auch immer da abgeht, irgendwas läuft gewaltig schief bzw. ist übel verkonfiguriert…

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top