Magento Forum

   
Dreamhost has banned allow_url_fopen
 
DaveTheAve
Jr. Member
 
Total Posts:  25
Joined:  2007-08-31
Kentucky
 

So yea like most people I can’t install Magento do to Dreamhost’s ban on allow_url_fopen.

More information here: http://wiki.dreamhost.com/Allow_url_fopen

IMO: There should be a option to use cURL.

 
Magento Community Magento Community
Magento Community
Magento Community
 
austinstorm
Member
 
Avatar
Total Posts:  31
Joined:  2007-08-31
Moscow, ID
 

Dreamhost is certainly a… polarizing web host. I’d put myself in the “more headaches than it’s worth” school. I use a nice locally owned web host, and if I need any changes made to the server config I just call the owner’s cell phone number and he gets someone right on it. I used dreamhost once before, and it was a really mixed experience. For e-commerce, however, I need better than ups and downs. I suggest looking for something better and not being lured in by the bargain-basement prices.

 
Magento Community Magento Community
Magento Community
Magento Community
 
DaveTheAve
Jr. Member
 
Total Posts:  25
Joined:  2007-08-31
Kentucky
 

Bypassed this check by typing: “ return $this;” on line 89 of “app/code/core/Mage/Install/Model/Installer/Config.php”

If you are having the same issue, enjoy the hack.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Siddharth Menon
Jr. Member
 
Avatar
Total Posts:  20
Joined:  2007-08-31
Mumbai
 
DaveTheAve - 31 August 2007 01:57 PM

So yea like most people I can’t install Magento do to Dreamhost’s ban on allow_url_fopen.

More information here: http://wiki.dreamhost.com/Allow_url_fopen

IMO: There should be a option to use cURL.

Well there are ways to overcome that. But may developer agru that its not save to turn it on. I don’t know much but I did find a way out by using custom php.ini files.

 
Magento Community Magento Community
Magento Community
Magento Community
 
DaveTheAve
Jr. Member
 
Total Posts:  25
Joined:  2007-08-31
Kentucky
 

With dreamhost you can not use custom pp.ini files. The only way to really fix this issue without reprogramming Magento would be to compile your own php5 and run it from that.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Siddharth Menon
Jr. Member
 
Avatar
Total Posts:  20
Joined:  2007-08-31
Mumbai
 
DaveTheAve - 01 September 2007 02:07 AM

With dreamhost you can not use custom pp.ini files. The only way to really fix this issue without reprogramming Magento would be to compile your own php5 and run it from that.

You can use custom php.ini I am using it to run OsCommerce. You can modify the original php.ini and upload back.

Here follow this link http://wiki.dreamhost.com/Custom_PHP.ini

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top