Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Magento multi shop en multi domain
 
shadydeath
Jr. Member
 
Total Posts:  2
Joined:  2013-10-13
 

Good day everyone, i have a question regarding said title.

my goal is to set up multiple domains for example: www.test001.com , www.test002.com on 1 single magento installation with a seperate shop attached to eacht domain, each shop will be connected to the same database.
i followed multiple installation guides en how to’s on how to set it up and get it running with yet no luck in achieving it.

the main issue i am having is that the browser no matter what i try connects to the internet for www.test001.com, www.test002.com
i added both to the hosts file to make them run on 127.0.0.1, i added them in the following way:
127.0.0.1 www.test001.com
127.0.0.1 www.test002.com

i also added them to apache with the following:
<VirtualHost *:80>
ServerAdmin webmaster@test001.com
DocumentRoot /var/www/http
ServerName test001.com
</VirtualHost>

<VirtualHost *:80>
ServerAdmin webmaster@test002.com
DocumentRoot /var/www/http
ServerName test002.com
</VirtualHost>

i also edited the .htaccess file and added the following as was said to do so:
SetEnvIf Host www\.test001\.com MAGE_RUN_CODE=test001_com
SetEnvIf Host www\.test001\.com MAGE_RUN_TYPE=website
SetEnvIf Host ^test001\.com MAGE_RUN_CODE=test001_com
SetEnvIf Host ^test001\.com MAGE_RUN_TYPE=website

SetEnvIf Host www\.test002\.com MAGE_RUN_CODE=test002_com
SetEnvIf Host www\.test002\.com MAGE_RUN_TYPE=website
SetEnvIf Host ^test002\.com MAGE_RUN_CODE=test002_com
SetEnvIf Host ^test002\.com MAGE_RUN_TYPE=website

after all this the link i made for the local testing keeps sending me to the internet instead of the local page, but when i leave away the www. they work but they send me to the main localhost link from the default config of magento even though i made extra links for the other shops.

used guides:
http://www.magentocommerce.com/knowledge-base/entry/tutorial-multi-site-multi-domain-setup
http://www.magentocommerce.com/knowledge-base/entry/ce18-and-ee113-installing

ja klopt de post is nog in engels gezien ik hem eerder had gepost in tech support algemeen maar geen succes daar + word overspoelt door een berg andere posts

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top