Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Language switching issues after upgrade to 1.8 from 1.6.2
 
anish_ns
Jr. Member
 
Total Posts:  2
Joined:  2013-10-05
 

I am facing some issues on recently upgrading to magento 1.8 from 1.6.2.0
we have two language version of our website in English & French

These are 2 separate domains for e.g.
shopenglish.com
shopfrench.com

In apache we have set_env module enabled so, depending on what site is called apache sets the environment

for www.shopenglish.com in virtual host
SetEnv MAGE_RUN_CODE \\\"en\\\"
SetEnv MAGE_RUN_TYPE \\\"store\\\"

and similarly for www.shopfrench.com
SetEnv MAGE_RUN_CODE \\\"fr\\\"
SetEnv MAGE_RUN_TYPE \\\"store\\\"

Now, when I try to switch categories or products between languages I am getting a 404 error. For some categories & products where the names are the same, the switch happens fine. For e.g.

if a category page is called new in english and nouveau in french, then switching languages is throwing a 404 error. But, if the category name is the same in both languages i.e. \\\"accessories\\\" the switch happens fine both ways.

When I am on the English site in the New category. The French language link has the following URL

http://www.shopfrench.com/new?___store=fr&___from_store=en

And if I am on the French site in the Nouveau category the English language link points to

http://www.shopenglish.com/nouveau?___store=en&___from_store=fr

Somehow, its not translating the category URL KEY on post (new for english / nouveau for french) in this case and it throws a 404 error.
The same setup works perfectly well in Magento in1.6.2.0

Can some one please help?

Thanks in Advance.

Anish

 
Magento Community Magento Community
Magento Community
Magento Community
 
anish_ns
Jr. Member
 
Total Posts:  2
Joined:  2013-10-05
 

Apparently this same issue was resolved in Magento 1.7

http://samuiweb.net/magento-store-code-url-bug/

But, now I can confirm that the above fix is not working in Magento 1.8

Folks if you have multiple language sites **** DO NOT UPGRADE TO 1.8 **** without testing in a dev environment.
Redirect works fine if you have catalogs/products with the same name in both languages. However, if they are differently named then 404 errors galore. It seems the entries in core_url_rewrite table are being ignored

 
Magento Community Magento Community
Magento Community
Magento Community
 
bsqtmp
Jr. Member
 
Total Posts:  3
Joined:  2013-05-10
 

Somebody has a Solution fpr 1.8?

This isn’t working --> http://www.magentocommerce.com/boards%20/viewthread/681388/#t466605 :-(

 
Magento Community Magento Community
Magento Community
Magento Community
 
copyscape
Jr. Member
 
Total Posts:  17
Joined:  2009-11-11
 

Does anyone have a working solution for magento 1.8.1? Language switch is totally broken...renders magento completely useless this way…

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top