Magento Forum

   
Magento install stuck on licensing page.. 
 
ptaparia
Jr. Member
 
Total Posts:  3
Joined:  2008-04-19
 

####################
Update:
####################

I tried the downloader to download and install magento - still facing the earlier issues. The form that has the error is posting to:

<form action="http://shopsbs.com/magento/index.php/install/wizard/beginPost/" method="post">

Also, I hard coded the url and moved ahead in the steps… but when I reach the database configuration page (../wizard/config), the same problem - I edit the appropriate fields and click ‘Continue’.... the page POSTS back and loads the default values back onto the page. Somehow the setting changes are not being written to file (/etc/config.xml?)

Could this be a file permission error? If so, why don’t I get any error messages on my screen?

Thank you,

####################
ORIGINAL MESSAGE
####################
Hi,

I just downloaded version 1.0 of Magento. My installation is at http://www.shopsbs.com/magento

I also had to upload php5-cgi, since my host does not have PHP 5.2.0 or newer on the box.

My issue is when I start the wizard, it does not move forward when clicking on Continue. Ofcourse, I checked the “I agree to the terms...” checkbox, before clicking on the “Continue” button, but the form POST redirects to the wizards page.

Thank you in advance for your help.

.htaccess paste

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

    Action php5-cgi /cgi-bin/php5-cgi
    AddHandler php5
-cgi .php
    php_flag cgi
.fix_pathinfo 1

############################################
## this line is specific for 1and1 hosting

    #AddType x-mapp-php5 .php
    #AddHandler x-mapp-php5 .php

############################################
## default index file

    
DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

    
php_value memory_limit 64M
    php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

    
php_flag magic_quotes_gpc off

############################################
## enable resulting html compression

    #php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

    
php_flag suhosin.session.cryptua off

</IfModule>

<
IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

    
SecFilterEngine Off
    SecFilterScanPOST Off
</IfModule>

<
IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

    # Insert filter
    #SetOutputFilter DEFLATE

    # Netscape 4.x has some problems...
    #BrowserMatch ^Mozilla/4 gzip-only-text/html

    # Netscape 4.06-4.08 have some more problems
    #BrowserMatch ^Mozilla/4\.0[678] no-gzip

    # MSIE masquerades as Netscape, but it is fine
    #BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
    # Don't compress images
    #SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

    # Make sure proxies don't deliver the wrong content
    #Header append Vary User-Agent env=!dont-vary

</IfModule>

<
IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

    
SSLOptions StdEnvVars

</IfModule>

<
IfModule mod_rewrite.c>

############################################
## enable rewrites

    
Options +FollowSymLinks
    RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

    #RewriteBase /magento/

############################################
## workaround for HTTP authorization
## in CGI environment

    
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

    
RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

    
RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond 
%{REQUEST_FILENAME} !-d
    RewriteCond 
%{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

    
RewriteRule .* index.php [L]

</IfModule>


############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

    
AddDefaultCharset Off
    
#AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

    
ExpiresDefault "access plus 1 year"

</IfModule>

############################################
## By default allow all access

    
Order allow,deny
    Allow from all

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

    #FileETag none

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top