Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

One page checkout broken in custom design
 
sccr410
Sr. Member
 
Total Posts:  76
Joined:  2008-04-02
 

For my custom design, the one page checkout doesn’t seem to work anymore. The boxes on the right don’t want to populate the data and I can’t get past the shipping step.

http://www.ashwebdev.com/blackarrow/checkout/onepage/

I’ve tried to verify that all the JavaScript in the default design is used in my design - seems to all be there. I can’t find anything that is really different except for the header/footer design. I’ve left all the checkout template files exact the same as the default.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ross
Guru
 
Avatar
Total Posts:  336
Joined:  2007-08-31
Scarborough, North Yorkshire, UK
 

I ran into this problem a while back, and it took me a while to find the problem.

The javascript on the one-page checkout uses the class name of the right-column for doing DOM updates, so if your custom theme changes that (in the main page layout) then it will stop it working.

Refer to the .phtml files for the default theme (main page layouts) and copy the class name from there (I did post about this elsewhere though if you need more detail).

Hope that helps

 
Magento Community Magento Community
Magento Community
Magento Community
 
sccr410
Sr. Member
 
Total Posts:  76
Joined:  2008-04-02
 

Yep, that was it. Just a note, the class name is “col-right”, not “right-column” (in case someone hits this thread without seeing the other)

 
Magento Community Magento Community
Magento Community
Magento Community
 
toadx
Jr. Member
 
Total Posts:  21
Joined:  2008-06-19
 

Oh god!  I just spent hours and hours trying to fix this problem myself.  Thanks for the insight!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top