Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Menüpunkt erscheint nicht
 
superheld
Sr. Member
 
Total Posts:  106
Joined:  2010-05-13
 

Hallo!

Ich habe nach diversen Howtos ein Menü im Adminbereich erstellt. Funktioniert gut soweit. Nur wenn ich das umbennenne um meinen eigenen Namespace zu belegen, funktioniert es nicht mehr und ich kann den Fehler einfach nicht finden. Mag mal jemand schauen?

Vorweg: Das Modul läuft lt. Konfiguration->Admin->Erweitert (oder so ähnlich). In so fern lasse ich diesen Teil mal weg.

name/IeP/adminhtml.xml

<?xml version="1.0"?>
<config>
    <
menu>
        <
iep translate="title" module="iep">
            <
title>IeP</title>
            <
sort_order>15</sort_order>
            <
children>
                <
example translate="title" module="iep">
                    <
title>Example</title>
                    <
sort_order>1</sort_order>
                    <
action>adminhtml/example/index</action>
                </
example>
            </
children>
        </
iep>
    </
menu>
</
config>

.../config.xml

<config>
    <
modules>
        <
name_IeP>
            <
version>0.1.0</version>
        </
name_IeP>
    </
modules>
    <
adminhtml>
        <
layout>
            <
updates>
                <
iep>
                    <
file>iep.xml</file>
                </
iep>
            </
updates>
        </
layout>
        <
acl>
            <
resources>
                <
admin>
                    <
children>
                        <
iep>
                            <
title>Awesome Menu Item</title>
                            <
children>
                                <
example translate="title" module="iep">
                                    <
title>Example Menu Item</title>
                                </
example>
                            </
children>
                        </
iep>
                    </
children>
                </
admin>
            </
resources>
        </
acl>
    </
adminhtml>
    <global>
        <
helpers>
            <
iep>
                <class>
name_IeP_Helper</class>
            </
iep>
        </
helpers>
        <
events>
            <
controller_front_init_routers>
                <
observers>
                    <
name_iep_model_observer>
                        <
type>singleton</type>
                        <class>
name_IeP_Model_Observer</class>
                        <
method>checkForConfigRequest</method>
                    </
name_iep_model_observer>
                </
observers>
            </
controller_front_init_routers>
        </
events>
    </global>
</
config>

der Helper ist leer nd der Observer ist noch Teil eines anderen Howtos.

Von hier hab ichs: http://codegento.com/2011/02/adding-a-new-admin-menu-item/

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top