Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Limit on Products? 
 
whoscart
Sr. Member
 
Total Posts:  120
Joined:  2008-02-23
 

Is there any limit on the maximum number of products in a file for an import. I have about 3000 products with a total file size of 13mb and the error always says:

“Could not load file: “/home/rawpubli/public_html/var/import/BG_General_File_Imported.xml”

 
Magento Community Magento Community
Magento Community
Magento Community
 
whoscart
Sr. Member
 
Total Posts:  120
Joined:  2008-02-23
 

Any help please?

 
Magento Community Magento Community
Magento Community
Magento Community
 
whoscart
Sr. Member
 
Total Posts:  120
Joined:  2008-02-23
 

figured this out.

 
Magento Community Magento Community
Magento Community
Magento Community
 
gabrielk
Sr. Member
 
Avatar
Total Posts:  83
Joined:  2007-11-30
 

Just in case anyone else comes across this, the problem is most likely:

- Incorrect permissions on your csv
- Incorrect permissions on your ./var subfolders

Try setting them to 777 (or 644, but that often doesn’t work when a script needs to read and write to a file).

 
Magento Community Magento Community
Magento Community
Magento Community
 
jerwood
Member
 
Avatar
Total Posts:  42
Joined:  2009-01-09
 

For what it is worth, I also ran into trouble importing thousands of products. I created csv files with about 20k - 50k rows, then I went to upload and it would time out on me. I installed a php.ini file in the Magento directory and fiddled with some settings… which ones were they…

Here it is:
;;;;;;;;;;;;;;;;;;;
; Resource Limits ;
;;;;;;;;;;;;;;;;;;;

max_execution_time = 36000 ; Maximum execution time of each script, in seconds
max_input_time = 60 ; Maximum amount of time each script may spend parsing request data
memory_limit = 128M ; Maximum amount of memory a script may consume (32MB)

I set my execution time, input time, and memory limits way high so that I could import huge files. Once I get things running properly, I’ll probably choke those back so I don’t make any queries performed by the user too painstakingly long.

That is how I solved my first import problem.

But, I have another one. I am going to post a new thread right now.

CHEERS!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top