Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

How do I solve various SQL-errors
 
Sipke
Jr. Member
 
Total Posts:  10
Joined:  2008-03-26
 

When selecting Search Terms on the frontpage the following error occurs:
There has been an error processing your request.
SQLSTATE[HY000]: General error: 2006 MySQL server has gone away

When editing a attribute(Admin) and saving it the following error occurs:
There has been an error processing your request.
SQLSTATE[21000]: Cardinality violation: 1241 Operand should contain 1 column(s)
It does save the settings....

Does anybody have a idea how to fix this?
When searching this forum and the internet in says it perhaps has something to do with PDO?

We are using:
- PHP 5.x
- MySQL 5.0.x
- Linux

 
Magento Community Magento Community
Magento Community
Magento Community
 
cshontz
Sr. Member
 
Avatar
Total Posts:  91
Joined:  2007-11-07
 

Regarding the attribute SQL error, please see the following thread. It includes a patch.

http://www.magentocommerce.com/boards/viewthread/6067/

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sipke
Jr. Member
 
Total Posts:  10
Joined:  2008-03-26
 

Thanks for the link to this thread, I will try the mentioned solution.

Still looking for a solution for this:
When selecting Search Terms on the frontpage the following error occurs:
There has been an error processing your request.
SQLSTATE[HY000]: General error: 2006 MySQL server has gone away

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sipke
Jr. Member
 
Total Posts:  10
Joined:  2008-03-26
 
cshontz - 16 April 2008 04:55 AM

Regarding the attribute SQL error, please see the following thread. It includes a patch.

http://www.magentocommerce.com/boards/viewthread/6067/

I have tried but it didn’t work. I have replaced the three files, the same problem occurs!:(

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top