Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Latest update files - can’t access checkout page
 
sempsys
Jr. Member
 
Total Posts:  11
Joined:  2009-10-29
 

Hi Bug Slayer -

I’m extremely excited about the changes that you’ve implemented in tonight’s updated that was released!  Thank you!

However, after uploading the latest files I am unable to reach the checkout page on my site as I’m receiving the following error (I’ve replaced my actual domain with a generic one for public viewing - I’ve PM’d you the actual code).

Fatal error: main() [function.require]: Failed opening required ‘app/code/core/Mage/Paypal/Model/Standard.php’ (include_path=’/home/myusername/public_html/magento/app/code/local:/home/myusername/public_html/magento/app/code/community:/home/myusername/public_html/magento/app/code/core:/home/myusername/public_html/magento/lib:.:/usr/lib/php:/usr/local/lib/php’) in /home/myusername/public_html/magento/app/code/local/Mage/Pap/Model/Paypal.php on line 49

Please advise smile Thanks in advance for your support!

Thanks,
Brad

 
Magento Community Magento Community
Magento Community
Magento Community
 
MageGuys
Guru
 
Avatar
Total Posts:  380
Joined:  2008-06-07
 

The “right” path to use on line 4 of Paypal.php is somewhat ambiguous, so I might have gotten it wrong (though it works on the servers I tested it on.) There are at least 3-4 possibly correct paths that I can think of.

Here are some possible variations on that line, in order of best to worst. Could you try these and tell me which, if any, work for you?

require_once BP . DS . ‘app/code/core/Mage/Paypal/Model/Standard.php’;
require_once ‘../app/code/core/Mage/Paypal/Model/Standard.php’;
require_once ‘Mage/Paypal/Model/Standard.php’;

Once I get your feedback I’ll push out another update with the best fix.

 
Magento Community Magento Community
Magento Community
Magento Community
 
MageGuys
Guru
 
Avatar
Total Posts:  380
Joined:  2008-06-07
 

BTW, this was fixed last night. Forgot to post back here afterwards though.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top