Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

SSL Error: Invalid or self-signed sertificate… when trying to upload photos
 
Flipmedia
Member
 
Avatar
Total Posts:  43
Joined:  2009-09-24
 

Hi

Thank you “MagentoAustralia” your advice enabled my to resolve the issue of recieving the error “SSL Error: Invalid or self-signed certificate”.

This error was returned when attempting to upload and image to a fresh install of Magento ver. 1.4.2.0. This is a development platform and had a Self Signed Certificate which I created using OpenSSL for Apache.

I am posting my fix as I run a Mac OS X development platform / work station. As per MagentoAustralia advice I had to add my self signed certifcate to the Mac OS X application Keychain. I simply dragged the certificate into the Keychain named “login”, once loaded into Keychain I simply set the Trust level to “trusted”. Images now upload as expected.

Hope this helps someone.

L

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lucmarcelino
Jr. Member
 
Total Posts:  2
Joined:  2010-10-28
 

SOLUTION: SSL Error: Invalid or self-signed certificate

this is the solution, a other mode of upload, no flash, is 100%!!!
http://www.magentocommerce.com/extension/specs/1756/no-flash-uploader#specs

shweta83 - 07 December 2009 01:19 AM

Hi,

I am getting the following error

SSL Error: Invalid or self-signed certificate while uploading image from backend

but if the same things i do from my colleagues pc there is no such error like above

I got frustrated

please help me out

 
Magento Community Magento Community
Magento Community
Magento Community
 
ITXInternacional
Jr. Member
 
Total Posts:  2
Joined:  2010-12-07
 

question
i had already do the change in the web general with the unsecure and secure but even now it doesnt work… and i dont understand the part with the html code and what part is requirement put it or what?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Yevgeniy A. Viktorov
Jr. Member
 
Total Posts:  29
Joined:  2008-04-28
Ukraine
 

Another thanks to MagentoAustralia, I also was missed ga_bundle smile

For my nginx setup I\’ve missed the following step:

cat site.com.crt gd_bundle.crt site.com.bundle.crt

And now config looks like this:

ssl_certificate ssl/site.com.bundle.crt;
  
ssl_certificate_key ssl/site.com.key;

Update: Oh, And uploading works just fine now smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
bogdanstorm
Jr. Member
 
Total Posts:  1
Joined:  2011-07-27
 

Today is 21 August 2011 and this ISSUE is still giving people headaches.

The problem is from Flash plugin/addon of your browser.

Last night I updated Flash for Firefox 6 and now I can’t upload pictures because of that.

I tried with IE8 and works perfectly.

Like a friend said few posts back, it’s a browser-plugin problem, NOT a server one.

Good luck.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Soraph
Jr. Member
 
Total Posts:  11
Joined:  2011-06-02
 

Hello everyone,
I just encountered this problem today with all my 1.6.0.0 installations and I solved it by increasing the MaxRequestLen from the apache configurations for the website(s).

Currently using
MaxRequestLen 15728640

And I can upload without any issues.

 
Magento Community Magento Community
Magento Community
Magento Community
 
globing
Jr. Member
 
Avatar
Total Posts:  15
Joined:  2010-03-01
 

for me this issue is browser specific..

 
Magento Community Magento Community
Magento Community
Magento Community
 
superheld
Sr. Member
 
Total Posts:  106
Joined:  2010-05-13
 

I got this error, if PHP is run as FastCGI-Application. If i change it to apache-module, my upload works fine…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Annavakulchik
Jr. Member
 
Total Posts:  9
Joined:  2010-11-11
 

You can try to solve it by adding post_max_size = 64M in your php.ini
It works fine for me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Pradeep Sanjaya
Jr. Member
 
Avatar
Total Posts:  5
Joined:  2009-11-19
Colombo, Sri Lanka
 

You will get the same error if you try to upload a very large file. Try to upload a small file and check whether you get the same error or not.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ErikLandvall
Jr. Member
 
Total Posts:  1
Joined:  2011-11-06
 

Soon to be Christmas -2011.. still the same problem. I never used ssl on this projekt but there it is:

SSL Error: Invalid or self-signed certificate

I could upload files just fine yesterday, but today I cant. I even tried the exact same images in the exact same page.
I think I tried everything in this post except updating my flashplayer, will do so soon.
But seriously Magento team. U should had resolved this. Its an easy fix! Make an option to upload without flash. I don’t care how stuff look. I care if it works.

Right now I feel that you are really incompetent in what you are doing…
I mean even I can make an application that can upload images. You cant!

Image Attachments
SSL-Error.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
CODNITIVE
Sr. Member
 
Avatar
Total Posts:  92
Joined:  2009-07-28
 

Same “SSL Error: Invalid or self-signed certificate” error message, when I tried to upload images from my desktop windows PC on my production server. The problem for me was my desktop PC firewall! “Plugin Container for Firefox” was block by my desktop firewall.

 
Magento Community Magento Community
Magento Community
Magento Community
 
chiefair
Mentor
 
Avatar
Total Posts:  1848
Joined:  2009-06-04
 

@onesimpleman

For the question about whether you can run Magento on a server with a self-signed certificate, the failures caused by self-signed certificates often are because they are created without being signed by a CA Certificate, or if signed, the systems where you will be viewing the website don’t have the user CA Certificate in the trusted certificate store.

Creating Certificate Authorities and self-signed SSL certificates and start at (1B) Generate your own CA (Certificate Authority).
OpenSSL, it’s part of Linux… Use it. OpenSSL-Win32 also available for that other OS.

If you create a Certification Authority and then create a server certificate/key pair, sign the server key with the CA Certificate and then import the CA certificate into Internet Explorer’s Trusted Root Certification Authorities Certificate Store (which makes it available to Chrome and to the Flash Flex file uploader) and Firefox’s Certificate Manager Authorities Store, you’ll have a lot better luck running your test web server with SSL.

When you notify the operating system and the browser that your self-signed certificate is trusted by you because you are your own Certification Authority and have imported the CA Certificate into the proper locations, then things work just like if you’d paid $250 for the live certificate on a live e-commerce site and Magento works just fine.

(No need to see that stupid “the world’s coming to an end it’s a self-signed or invalid certificate” page or have the flash image uploader crap out with the same sort of message once the CA Certificate is in place!)

 
Magento Community Magento Community
Magento Community
Magento Community
 
CODNITIVE
Sr. Member
 
Avatar
Total Posts:  92
Joined:  2009-07-28
 

I notice this error show for me still, just for images and files bigger than 120KB! Images and files lower than this size can upload without any problem. The error shows after that file or image uploaded 100%.
in my php:
upload_max_filesize = 64M
post_max_size = 96M
memory_limit = 256M

Also I followed “chiefair” guide and installed a CA on Magento admin successfully. It works great for my admin but still I got the error!

Any help is appreciated
------------------------------------------------------------------------------------------

EDIT:
THE PROBLEM SOLVED for me.
Thanks to “Soraph” to put me in right way! (post #36 in this thread)

My Apache runs in mod_fcgid and issue was it’s “FcgidMaxRequestLen” default value which is 131072bytes (128KB). By changing it to a higher value (15728640 - 15MB) issue solved for me.
You can edit fcgid.conf and add

FcgidMaxRequestLen 15728640

to

<IfModule mod_fcgid.c>

This links can be helpfull:
Apache Module mod_fcgid
MaxRequestLen Issue

 
Magento Community Magento Community
Magento Community
Magento Community
 
chiefair
Mentor
 
Avatar
Total Posts:  1848
Joined:  2009-06-04
 

Thanks Codnitive, I run fastcgi on my dev and needed the MaxRequestLen setting.

For some reason the link ot Plesk in your posting has a mailto: in the link, here’s a repost of the link to the web page:
MaxRequestLen Issue

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top