Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 4
SSL Error: Invalid or self-signed sertificate… when trying to upload photos
 
Kathir Vel
Jr. Member
 
Total Posts:  11
Joined:  2009-01-06
 

I managed to fix the same problem. I was not using Secure URL for the backend (admin). I do not think it should have been an issue. The customer was uploading images until l last week. I use Rapid SSL. Maybe something is wrong with their server. I dont know. It works now… that’s good.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jeramey
Jr. Member
 
Total Posts:  5
Joined:  2009-08-05
 

I’m having the same issue as people are describing, except I’ve noticed something that others have yet to comment on.  Mine appears to be computer specific.  On some computers I’m fine uploading images (same browser, same version of flash), on others it doesn’t work.

Any thoughts?

 
Magento Community Magento Community
Magento Community
Magento Community
 
shweta83
Jr. Member
 
Total Posts:  4
Joined:  2009-12-01
 

Hi,

I am getting the following error

SSL Error: Invalid or self-signed certificate while uploading image from backend

but if the same things i do from my colleagues pc there is no such error like above

I got frustrated

please help me out

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lee1
Jr. Member
 
Total Posts:  21
Joined:  2009-02-10
 

Hi guys,

This is the first time I have ran into this issue, and it’s odd.  Two weeks ago I could upload images without a problem, and now I keep getting the dreaded “SSL Error: Invalid or self-signed certificate” error.

I have searched the forums over and over and tried every single solution that people have posted.  Nothing is working at all.

I’ve tried other browsers, IE, FF and Chrome.
Flash Player 9.
Code others have suggested.
4 Fresh reinstalls and double cheked file permissions.

Absolutely everything.

Is there any way I can manually upload the images until there is a real fix for this issue?

It’s getting kind of urgent now as my boss and I was “hoping” to have this up and running today.

Thanks in advance.
Lee

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lee1
Jr. Member
 
Total Posts:  21
Joined:  2009-02-10
 

Right ok.  I have resolved this and it works for “me”, but I can’t say for others.

At my work place we have a poor ISP and we’re heavily firewalled, so before altering any code or anything like that, it would be a good idea to make sure you’re on an unrestricted internet connection i.e. home connection or something.

I’ve tried and tested it with IE, FF and Chrome.  All work perfectly.

Lee

 
Magento Community Magento Community
Magento Community
Magento Community
 
fawad123
Jr. Member
 
Total Posts:  2
Joined:  2009-12-11
 

No, your patch is not working.

 
Magento Community Magento Community
Magento Community
Magento Community
 
JTSchmidt
Jr. Member
 
Total Posts:  11
Joined:  2008-04-05
Irvine, CA
 
jeramey - 12 August 2009 07:54 PM

I’m having the same issue as people are describing, except I’ve noticed something that others have yet to comment on.  Mine appears to be computer specific.  On some computers I’m fine uploading images (same browser, same version of flash), on others it doesn’t work.

Any thoughts?

I’m seeing the same thing as jeramey:  I have a hosted Magento installation, no ssl on admin;

Image upload works from my Vista machine (all browsers), and Windows 7; however, getting “Invalid or self-signed certificate” error when attempting to upload a image pic from my XP Home machine (regardless of browser, no firewall).

 
Magento Community Magento Community
Magento Community
Magento Community
 
_Cod3r
Jr. Member
 
Total Posts:  6
Joined:  2009-10-13
 

Check if date and time on your computer is correct.

I was getting the same error, and it was all because of the time on my pc

In addition to this, go to Back End>System>Configuration-Locale options and select the correct time zone.

Hope it helps,

_Coder.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Wibbles
Jr. Member
 
Total Posts:  7
Joined:  2009-12-07
 

This is happening in 1.4
I have installed a fresh copy of magento, and have been importing products from a dev install.
Images were not imported so I have to re-upload them.

This is what I get every time I try to upload:
SSL Error: Invalid or self-signed certificate

This is just silly, I don’t even use SSL. The insecure_base_url is just the same as the base_url - just a normal http://

Only clue that I have is that I switched the front-end to use https:// so I could test if SSL was actually enabled, then I disabled it again.
This never happened to me on 1.3.2.4.

I have made a bug report if anyone else wants to chip in: http://www.magentocommerce.com/bug-tracking/issue?issue=8417

 
Magento Community Magento Community
Magento Community
Magento Community
 
paltam
Jr. Member
 
Total Posts:  13
Joined:  2009-06-24
 

Firefox 3 gave me the SSL error, but IE6 worked just fine.
Shifting back to Firefox it worked again
the only thing that I have changed meanwhile is the Locale in the bottom: from Hungatian to US and back.
you might want to try that too.

 
Magento Community Magento Community
Magento Community
Magento Community
 
clockman
Jr. Member
 
Total Posts:  25
Joined:  2010-01-18
 

i had the same problem.
I fixed that with changing the locale down to something fro my country-region.
I think this is something that has to do with the time and the locale of magento and your computer.

 
Magento Community Magento Community
Magento Community
Magento Community
 
reza nazarian
Jr. Member
 
Total Posts:  4
Joined:  2010-07-05
 

Try these solution
upgrade your browser and flash player to the latest versions
it solved my problem

 
Magento Community Magento Community
Magento Community
Magento Community
 
andy_sim
Jr. Member
 
Total Posts:  25
Joined:  2009-05-22
 

Had the same problem, images being uploaded from my home machine.
Firewall was stopping the incomming request. Turned it off temporarily and it all works well.

Hope it helps

Andy

 
Magento Community Magento Community
Magento Community
Magento Community
 
MageAustralia
Member
 
Total Posts:  37
Joined:  2008-08-23
Sydney, Australia
 

Hi All,

First off, people in this thread are describing multiple different problems and so different solutions.

For this error:

SSL ErrorInvalid or self-signed certificate

The problem is related to the way Flash player handles Certificates compared to browsers. It’s not just affecting Magento because Magento uses a component called “SWFUpload” for the images upload. Basically, the underlying problem is that whatever certificate you are using, the Flash player is not recognising the “Certificate Authority” as being trusted.

If you are using a Self-signed certificate, add your certificate to your operating system’s list of trusted certificate authorities. In windows, you should be able to follow these instructions to Manage Certificates.

If you are using a ‘real’ certificate, there’s numerous issues. It could be that you haven’t installed the “Intermediate CA” certificate when you installed your SSL certificate - your browser probably already had the “Intermediate CA” installed and that’s why your browser isn’t being affect and my guess is that Flash looks at IE’s certificates list because it’s an ActiveX plugin. So, check if you can get hold of the “CA Bundle” from your SSL provider and install that in your Web Server - failing that working, an upgrade of Flash might also fix it because new CA certificates are being released all the time and so the new player will come with new Trusted CA’s. If that still fails, just add the CA to your Trusted certificates on your operating system.

The other problems that occur with SWFUpload are: site is secured using .htaccess - you can whitelist your own IP address if it’s a static IP by adding the “allow from” line in your .htaccess file, add your IP address. This will allow you to access the site without having to Authenticate with the Basic Authentication.

AuthName "Dev Site"  
AuthType Basic  
<Limit GET POST>  
order deny,allow  
deny from all  
allow from 10.10.10.10 
#Put your IP  here.
</Limit>

The third problem that people are getting is a Javascript popup error. This is usually related to an Apache module called “mod_security”. The best way to handle this is using one of these two methods:

You can try to configure mod_security Off in .htaccess file

SecFilterEngine Off
SecAuditEngine Off
If your host does not allow htaccess configuration, you need to request support to disable mod_security by using the following rule
SecRule SERVER_NAME "yourdomain.com" phase:1,nolog,allow,ctl:ruleEngine=off

I hope that helps everyone with the SWFUpload issues they are experiencing.

 
Magento Community Magento Community
Magento Community
Magento Community
 
dnicholas0
Jr. Member
 
Total Posts:  1
Joined:  2010-12-02
 

I was having the same problem and I fixed it with a very simple problem.  It turns out that my items in inventory were set to “out of stock.” Total n00b mistake, but it might help some of you out there.

Dennis

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 4