Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 4
SSL Error: Invalid or self-signed sertificate… when trying to upload photos
 
sdowdell
Jr. Member
 
Total Posts:  4
Joined:  2008-04-14
 

I created a configurable product, but when I try to download images this error comes up. SSL Error: Invalid or self-signed sertificate.

I followed one of the configurable product screen cast and noticed that when she uploads photos her page looks different than mine. She has spaces to upload individual photos for each size one at a time (eg. thumbnail, large, small)… my page does not have this.

p.s. All of the photos have been sized to meet specifications

Sarah

 
Magento Community Magento Community
Magento Community
Magento Community
 
Tweakmag
Guru
 
Avatar
Total Posts:  307
Joined:  2007-08-31
London, UK
 

The video is for an older version of magento, that is why it looks different for you. Is your SSL certificate valid? Did you actually install a certificate?

 
Magento Community Magento Community
Magento Community
Magento Community
 
sdowdell
Jr. Member
 
Total Posts:  4
Joined:  2008-04-14
 

Yes I just purchased a new certificate today and my husband (web designer) installed it, but it is still giving the error???

 
Magento Community Magento Community
Magento Community
Magento Community
 
Tweakmag
Guru
 
Avatar
Total Posts:  307
Joined:  2007-08-31
London, UK
 

Are you sure that you are accessing the exact url that you got the certificate for. For example, if you bought the certificate for http://www.domain.com - your certificate would be invalid for http://domain.com or http://shop.domain.com (unless you bought a wildcard certificate which are rather expensive).

Cheers
Adam

 
Magento Community Magento Community
Magento Community
Magento Community
 
noSpam
Jr. Member
 
Total Posts:  4
Joined:  2008-04-14
 

Ajazza, one question. I am trying magento locally with a dyndns. I created a certificate with “apache2-ssl-certificate - force” to “prueba1.homelinux.org”, and also gives me this error when trying to upload images for products. You think I should have a CA (Certificate Authority) rolleyes

 
Magento Community Magento Community
Magento Community
Magento Community
 
onesimpleman
Jr. Member
 
Total Posts:  24
Joined:  2008-04-14
 

Does this mean you cannot install magento on a test server with a self signed certificate?

 
Magento Community Magento Community
Magento Community
Magento Community
 
jdavies
Jr. Member
 
Total Posts:  4
Joined:  2008-04-22
 

onesimpleman, et al., if you are just testing, you can work around cert problems by setting System > Configuration > Web > Use Secure URLs in Admin to “No”—then image upload works. You may already know this, but I had a similar question myself and thought I’d chip in.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mffowler
Member
 
Total Posts:  31
Joined:  2008-05-16
 

Actually, I have working SSL and get the error when manually uploading an image as I use htaccess to password protect directories during development. This should be worked out as using htaccess during dev. is common for shared web development. I disabled htaccess password protect

 
Magento Community Magento Community
Magento Community
Magento Community
 
mffowler
Member
 
Total Posts:  31
Joined:  2008-05-16
 

Actually, I have a working SSL cert. and get the same error when manually uploading an image as I use htaccess to password protect directories during development. This should be worked out as using htaccess during dev. is common for shared web development. I disabled htaccess password protection and it worked fine.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mrw
Jr. Member
 
Total Posts:  3
Joined:  2008-04-08
Banja Vrdnik, Serbia
 
jdavies - 24 April 2008 01:50 PM

onesimpleman, et al., if you are just testing, you can work around cert problems by setting System > Configuration > Web > Use Secure URLs in Admin to “No”—then image upload works. You may already know this, but I had a similar question myself and thought I’d chip in.

I have same problem. Can’t upload images on localhost. But this didn’t solve my problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Prattski
Member
 
Total Posts:  54
Joined:  2008-01-22
 

I found a quick work-around, for those of you who haven’t gotten certificates yet:

- Login to the admin
- System >> Configuration
- Click on “Web” on the left under “General”
- Under “Secure”, change the bottom two drop-downs to say “No”
- Under “Unsecure”, change the Base URL to http instead of https
- Now in your browser, change the URL to http instead of https

Then upload your images.  Not sure of the ramifications of this - but I do know that I was getting the error, and now I’m not.

 
Magento Community Magento Community
Magento Community
Magento Community
 
rembrandt
Jr. Member
 
Total Posts:  14
Joined:  2008-11-01
 
blank1 - 15 June 2008 04:46 PM

Actually, I have working SSL and get the error when manually uploading an image as I use htaccess to password protect directories during development. This should be worked out as using htaccess during dev. is common for shared web development. I disabled htaccess password protect

This worked for me as well, I’m also using htaccess for protection during development and that’s what was causing my problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
james-aj5
Jr. Member
 
Total Posts:  4
Joined:  2009-02-19
 

I am just making a small shop which only uses paypal gateway for payment. I am finding that I can’t upload images at all. I have set all the cofig options to not use secure urls, but when I try and upload my product images nothing happens and when I ‘Save and continue’ they’re all gone so back to square 1 of having no product images. What should I do? Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
JungleTech
Jr. Member
 
Total Posts:  1
Joined:  2009-03-06
 

We resolved this Issue by:

1. mod_security
<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>
NOTE: You might have to call your hosting provider up and have them disable it/add an exception for you....

2. {{base_urls}}
Replace all the “{{base_url}}” with http://MagentoInstall.com/magento
Replace all the “{{secure_base_url}}” with https://MagentoInstall.com/magento/

3.Our /tmp directory was to small/full redirect your uploads to a /tmp replacement...add to your php.ini
upload_tmp_dir=/Path/To/Your/New/tmp/Dir

=============================================================================================================
---Jeff
---Web Developer
---JungleTech.com

 
Magento Community Magento Community
Magento Community
Magento Community
 
laflair13
Jr. Member
 
Total Posts:  18
Joined:  2009-06-18
 

None of these worked for me. When I click upload I am getting a box pop up that says

<!DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.0 Strict//EN” “http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html lang="en">
<head>
<title>Log into Magento Admin Page</title>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8” ></meta>
<link type="text/css" rel="stylesheet" href="http://razortechsurplus.com/store/skin/adminhtml/default/default/reset.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://razortechsurplus.com/store/skin/adminhtml/default/default/boxes.css" media="all" />
<link rel="icon" href="http://razortechsurplus.com/store/skin/adminhtml/default/default/favicon.ico" type="image/x-icon" />
<link rel="shortcut icon” href="http://razortechsurplus.com/store/skin/adminhtml/default/default/favicon.ico" type="image/x-icon" />

<script type="text/javascript\" src="http://razortechsurplus.com/store/js/index.php/x.js?f=prototype/prototype.js,prototype/validation.js,mage/adminhtml/form.js"></script>

<!--[if IE]> <link rel="stylesheet" href="http://razortechsurplus.com/store/skin/adminhtml/default/default/iestyles.css" type="text/css" media="all" /> <![endif]-->
<!--[if lt IE 7]> <link rel="stylesheet" href="http://razortechsurplus.com/store/skin/adminhtml/default/default/below_ie7.css" type="text/css" media="all" /> <![endif]-->
<!--[if IE 7]> <link rel="stylesheet" href="http://razortechsurplus.com/store/skin/adminhtml/default/default/ie7.css" type="text/css" media="all" /> <![endif]-->
</head>
<body id="page-login" onload="document.forms.loginForm.username.focus();">
<div class="login-container">
<div class="login-box">
<form method="post" action="” id="loginForm">
<div class="login-form">
<input name="form_key" type="hidden" value="BfE6tihSTGk89kTV" />
<h2>Log in to Admin Panel</h2>
<div id="messages">
</div>
<div class="input-box input-left"><label for="username">User Name:</label><br/>
<input type="text" id="username" name="login[username]" value="” class="required-entry input-text” /></div>
<div class="input-box input-right"><label for="login">Password:</label><br />
<input type="password" id="login" name="login[password]" class="required-entry input-text” value="” /></div>
<div class="clear"></div>
<div class="form-buttons">
<a class="left" href="http://razortechsurplus.com/store/index.php/admin/index/forgotpassword/">Forgot your password?</a>
<input type="submit" class="form-button" value="Login" title="Login" /></div>
</div>
<p class="legal">Magento is a trademark of Irubin Consulting Inc. DBA Varien. Copyright © 2009 Irubin Consulting Inc.</p>
</form>
<div class="bottom"></div>
<script type="text/javascript\">
var loginForm = new varienForm(’loginForm’);
</script>
</div>
</div>
</body>
</html>

 
Magento Community Magento Community
Magento Community
Magento Community
 
brianmac44
Jr. Member
 
Total Posts:  2
Joined:  2009-03-31
 

I seemed to fix this for one of our clients by commenting out the following 3 lines

lib/flex/varien/varien/upload/Uploader.as

536                                                if (allIOError{
537                                                 _markAsSSLError
();
538                                                }

change to

536                                           //     if (allIOError) {
537                                           //      _markAsSSLError();
538                                           //    }

More of a bandaid then fix but no complaints yet.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 4