Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 3
* Skip import row, store “store” field not exists and * Skip import row, is not valid value “” for field “type”
 
ayaan
Jr. Member
 
Total Posts:  3
Joined:  2008-06-10
 

I was having similar problem when I tried to import products on my site. I then (after a lot of frustration) used Open Office instead of excel and it worked for me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
RobOrr
Sr. Member
 
Avatar
Total Posts:  218
Joined:  2008-06-04
 
ayaan - 02 September 2008 12:37 AM

I was having similar problem when I tried to import products on my site. I then (after a lot of frustration) used Open Office instead of excel and it worked for me.

I used open office on one of my subsequent attempts too, but the same errors resulted. It was originally an excel file, but I saved it under another name using open office and nothing.  Not sure what to do here.

 
Magento Community Magento Community
Magento Community
Magento Community
 
martijnr
Member
 
Total Posts:  31
Joined:  2008-08-31
 

Iám having the same issues here. Did anyone got it working? Iam using openoffice and export it to a csv file. When running I got the following error: # Skip import row, is not valid value “29521” for field “type”. I things it looks into a different field but, I have checked the csv file and the field mapping and there it is good. Hope someone found a solution.

 
Magento Community Magento Community
Magento Community
Magento Community
 
validBen
Jr. Member
 
Total Posts:  13
Joined:  2008-10-22
 

I’ve had the same problem in the past and it seemed to come from the number of column mapped and the actual number of column in the csv file. Plus I think the columns order needs to be the same in the mapping and csv file.

 
Magento Community Magento Community
Magento Community
Magento Community
 
lilicrashes
Jr. Member
 
Total Posts:  30
Joined:  2008-10-23
 
nkshop - 01 May 2008 06:41 AM

I had the same issue.
I had to use the store code in the file, rather then the store name.
Just go to Manage Stores and check your code. Drop this in the file and you should be all set.

Ok where in the file do I put this?

I get the same thing, only it keeps saying there is no “website” and it skips the line.

 
Magento Community Magento Community
Magento Community
Magento Community
 
lilicrashes
Jr. Member
 
Total Posts:  30
Joined:  2008-10-23
 

does anyone have a sample csv file for me to read? Because I am getting really aggravated that I can’t import anything… So far my magento experience sucks…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Liddle Young
Member
 
Avatar
Total Posts:  37
Joined:  2008-09-16
 

Has anybody had any success with this, I’ve been trying all day and no joy. I can export and import the 3 test products I put on the site without a problem, but as soon as you add a 4th you get the error Skip import row, is not valid value “” for field “type” ?
Tried with Open Office and Excel and even in Notepad and always the same error for the extra product that is added, all the 3 existing test products re-import with out an error?

Dean

 
Magento Community Magento Community
Magento Community
Magento Community
 
lilicrashes
Jr. Member
 
Total Posts:  30
Joined:  2008-10-23
 

To get a sample file ( I am trying to import customers but am getting missing field errors as well) I went ahead and did a couple of things to get my import of people as follows.

1. manually made a fake login (in your case you make an item)

2. go to the dataflow --- “system"-->import/export--->profiles

3. in profiles there should be some premade with the program. One of them is listed export all products

4. run the profile and it will export it out into a csv file (specify that)

5. ftp into var/export and download the csv file from there. YOU NOW HAVE A CORRECTLY FORMATED CSV file

Note! download openoffice (it is free) and open your csv from there. I found my import didn’t work when I used excel.

For those people who are importing customers I found that I could get email, firstname, lastname and password_hash, but nothing else even though I entered the addresses.

So if anyone knows why please tell me..

Hope this helps get us all to the next step!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
alex.bsc
Guru
 
Total Posts:  340
Joined:  2008-06-06
 

http://www.magentocommerce.com/boards/viewthread/20869/

 
Magento Community Magento Community
Magento Community
Magento Community
 
Azim
Sr. Member
 
Total Posts:  97
Joined:  2008-09-17
NY, USA
 

I am using Open Office to modify my csv file and it did a lot of work but i am stuck with this ittle problem here.
all the values in text are good but the all the numerical columns are not as they should be. they are not wrapped around like this “number”
“value1”,"value2”,"value3”,number1,"value4”,number2,"value5"

Pease if you get my point help me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Bogislaw
Member
 
Total Posts:  63
Joined:  2009-07-29
 

Had the same issue

- Skip import row, required field “sku” not defined -

As far as I experienced, the fact that OpenOffice works better for importing than Excel is due only to Excel reformatting values automatically. It’s the good old Microsoft habit to secretly do something we didn’t ask for.

If you use Excel to edit CSV files watch out
- to tell Excel to read the value separator right (comma, or semicolon...) and the value limiter (")
- that Excel doesn’t auto-format dates (4.2 becomes Apr 02 or whatever)
- for decimal and thousand separators (dot, comma - some areas of the world use different)
- cell format for numbers/text

Since I watch this stuff, imports work fine.

hth,
B.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Imogen26
Jr. Member
 
Total Posts:  1
Joined:  2009-08-28
 

I was also having a lot of trouble importing data via csv…
I eventually saved it as an xml after editing the data in Excel and everything worked fine.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ciprian SASU
Jr. Member
 
Total Posts:  3
Joined:  2009-12-21
Romania
 

The problem can be solved in simple maner.

The error comes because to import something you must have all the required fields,
the field what you see have red dots when you enter by hand.

what i recomand: export with a predefined profile one article, see the structure and put all the data in the same way
use an excell editor to fill where you do not have data like in the exported article.

 
Magento Community Magento Community
Magento Community
Magento Community
 
247365
Jr. Member
 
Total Posts:  28
Joined:  2010-01-05
 

Ok - it took me a while to work my issue out. I used CSV from Excel - I think the issue was to do with the UTF-8 stuff. I think Open Office handles it differently.
Basically, I had the same issue getting the # Skip import row, is not valid field “price” or something
You need to make sure there is actually a heading called price. I did, but somehow there where some random spaces on either side of the word that Excel put in. I deleted the spaces and it seems to work.

Thanks,

Mitchell

 
Magento Community Magento Community
Magento Community
Magento Community
 
fransnl
Jr. Member
 
Total Posts:  3
Joined:  2010-10-06
 

Had same problem.

Solution: most of the time I used copy, sometime you have a space.

and there is a difference between “description” and “description” check this first in the skipping colom
use open office
it is possible by options, languages to set , tot . als decimal sign
save as cvs utf-8 or as xlm file

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 3