Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Review Prodcuts Module Warning Shows Up
 
bkimura
Jr. Member
 
Total Posts:  6
Joined:  2008-04-07
 

I Get this warning when i submit a comment view the review products button. Anyone know what may cause this and/or how to fix it?

We are using PHP 5.2.5 and Magento Version 1
We did have to add the path scripts to our HTTPD.CONF file to get the site working properly. Im thinking it may be related to the fix in php 5.2.5?

If anyone can shed some light i would greatly appreciate it!

Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/home/httpd/vhosts/revacomm.net/httpdocs/magento/app/code/local/Mage/Catalog/Block/Product/View/Super/Config.php) is not within the allowed path(s): (/home/httpd/vhosts/revacomm.net/subdomains/magento/httpdocs:/tmp) in /home/httpd/vhosts/revacomm.net/subdomains/magento/httpdocs/magento/app/code/core/Mage/Core/functions.php on line 150
[0] in file_exists("/home/httpd/vhosts/revacomm.net/httpdocs/magento/app/code/local/Mage/Catalog/Block/Product/View/Supe") in /home/httpd/vhosts/revacomm.net/subdomains/magento/httpdocs/magento/app/code/core/Mage/Core/functions.php on line 150
[1] in mageFindClassFile("Mage_Catalog_Block_Product_View_Super_Config") in /home/httpd/vhosts/revacomm.net/subdomains/magento/httpdocs/magento/app/code/core/Mage/Core/Model/Layout.php on line 439
[2] in Mage_Core_Model_Layout->_getBlockInstance("Mage_Catalog_Block_Product_View_Super_Config") in /home/httpd/vhosts/revacomm.net/subdomains/magento/httpdocs/magento/app/code/core/Mage/Core/Model/Layout.php on line 419
[3] in Mage_Core_Model_Layout->addBlock("Mage_Catalog_Block_Product_View_Super_Config", “product.info.config") in /home/httpd/vhosts/revacomm.net/subdomains/magento/httpdocs/magento/app/code/core/Mage/Core/Model/Layout.php on line 220
[4] in Mage_Core_Model_Layout->_generateBlock(Mage_Core_Model_Layout_Element, Mage_Core_Model_Layout_Element) in /home/httpd/vhosts/revacomm.net/subdomains/magento/httpdocs/magento/app/code/core/Mage/Core/Model/Layout.php on line 186
[5] in Mage_Core_Model_Layout->generateBlocks(Mage_Core_Model_Layout_Element) in /home/httpd/vhosts/revacomm.net/subdomains/magento/httpdocs/magento/app/code/core/Mage/Core/Model/Layout.php on line 187
[6] in Mage_Core_Model_Layout->generateBlocks(Mage_Core_Model_Layout_Element) in /home/httpd/vhosts/revacomm.net/subdomains/magento/httpdocs/magento/app/code/core/Mage/Core/Model/Layout.php on line 191
[7] in Mage_Core_Model_Layout->generateBlocks() in /home/httpd/vhosts/revacomm.net/subdomains/magento/httpdocs/magento/app/code/core/Mage/Core/Controller/Varien/Action.php on line 277
[8] in Mage_Core_Controller_Varien_Action->generateLayoutBlocks() in /home/httpd/vhosts/revacomm.net/subdomains/magento/httpdocs/magento/app/code/core/Mage/Core/Controller/Varien/Action.php on line 214
[9] in Mage_Core_Controller_Varien_Action->loadLayout() in /home/httpd/vhosts/revacomm.net/subdomains/magento/httpdocs/magento/app/code/core/Mage/Review/controllers/ProductController.php on line 110
[10] in Mage_Review_ProductController->listAction() in /home/httpd/vhosts/revacomm.net/subdomains/magento/httpdocs/magento/app/code/core/Mage/Core/Controller/Varien/Action.php on line 341
[11] in Mage_Core_Controller_Varien_Action->dispatch("list") in /home/httpd/vhosts/revacomm.net/subdomains/magento/httpdocs/magento/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php on line 150
[12] in Mage_Core_Controller_Varien_Router_Standard->match(Mage_Core_Controller_Request_Http) in /home/httpd/vhosts/revacomm.net/subdomains/magento/httpdocs/magento/app/code/core/Mage/Core/Controller/Varien/Front.php on line 147
[13] in Mage_Core_Controller_Varien_Front->dispatch() in /home/httpd/vhosts/revacomm.net/subdomains/magento/httpdocs/magento/app/Mage.php on line 424
[14] in Mage::run("default") in /home/httpd/vhosts/revacomm.net/subdomains/magento/httpdocs/magento/index.php on line 40

 
Magento Community Magento Community
Magento Community
Magento Community
 
NuBlue
Sr. Member
 
Avatar
Total Posts:  94
Joined:  2008-03-31
Lancaster, United Kingdom
 

Having the same problem. Turning off open_base dir fixes it. This isn’t a solution for people using shared hosting though.. I’m no php expert but it looks to be trying to access a file which it doesn’t need outside of the webspace root, as everything works fine once openbase dir is enabled but the file its trying to access doesn’t physically exist. Turning open_base dir off also fixes the Export option problem some people have been having.

Maybe a Dev can advise where we comment the code which is causing magento to look outside of the web space root for /usr/share/php/Mage/Catalog/Block/Product/View/Super/Group.php ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
bkimura
Jr. Member
 
Total Posts:  6
Joined:  2008-04-07
 

I know i had to allow magento to write the paths in the httpd.conf file as posted earlier. People using php 5.2.5 have this problem.  Can anyone offer any help?

 
Magento Community Magento Community
Magento Community
Magento Community
 
bkimura
Jr. Member
 
Total Posts:  6
Joined:  2008-04-07
 

@nublue:
Thanks for pointing me in the right direction on the open base dir. If you shared server is running plesk you can actually create a vhosts.conf file to disable open_base dir on a domain or sub domain level.

First off, add a file, ‘vhost.conf’ for http sites and for https sites add ‘vhost_ssl.conf’ in the conf directory.

Add the new direction options there.

<Directory /home/httpd/vhosts/domain/subdomains/magento/httpdocs>
php_admin_value open_basedir off
</Directory>

Once this has been added run
/usr/local/psa/admin/bin/websrvmng -a -v

This will cause httpd to use this vhost.conf file.

Then restarted httpd to commit the new changes. /etc/init.d/httpd restart

This issue also solves the problem for people using php 5.2.5 and are having installation issues.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top