Magento Forum

Page 2 of 2
Fatal error: session_start()
 
diazwatson
Member
 
Avatar
Total Posts:  35
Joined:  2010-04-23
Spain
 

tm1579 - 20 November 2013 08:01 PM

Magento community version 1.8

I replaced local.xml
<session_save><![CDATA[db]]></session_save>
to this
<session_save><![CDATA[files]]></session_save>

Look like it works for me, so far I did not see this error.

It also worked for me on Magento community version 1.8.1[color=blue]

[/color]

 
Magento Community Magento Community
Magento Community
Magento Community
 
oboyle
Jr. Member
 
Avatar
Total Posts:  13
Joined:  2011-02-14
 

Worked for me after clearing caches

Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
sammbiz
Jr. Member
 
Total Posts:  16
Joined:  2013-12-15
 

Hi,

I fixed the problem
If you have the same problem, you need to expend php.ini by \\\’safe_mode = off\\\’, then it works.

Hope this find you to resolve your problem,

For more details,you can contact me on

Regards,
Sammbiz

Team ILM

 
Magento Community Magento Community
Magento Community
Magento Community
 
thviet
Jr. Member
 
Total Posts:  1
Joined:  2014-01-13
 
diazwatson - 04 January 2014 07:41 PM

tm1579 - 20 November 2013 08:01 PM
Magento community version 1.8

I replaced local.xml
<session_save><![CDATA[db]]></session_save>
to this
<session_save><![CDATA[files]]></session_save>

Look like it works for me, so far I did not see this error.

It also worked for me on Magento community version 1.8.1[color=blue][/color]

i changed but dont’ work.
Please help me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
BeautyEssence
Jr. Member
 
Total Posts:  3
Joined:  2013-12-12
 

Hello Everyone!

I’m very new to working with Magento. I’m currently working with the CE edition 1.8.1.0
I’m trying to make my website mirror or atleast be similar to another magento website.

I copied and imported some files but somewhere I went wrong.

My page is now showing error,
Fatal error: Call to a member function toHtml() on a non-object in /home/missjul2/public_html/app/code/core/Mage/Core/Model/Layout.php on line 555

Can someone please help me?

 
Magento Community Magento Community
Magento Community
Magento Community
 
andremundial
Jr. Member
 
Avatar
Total Posts:  1
Joined:  2013-06-12
 

You need to change save path folder in php.ini and assigned it to public_html/tmp.
Then will worked..(but may bring other log magento error)

Other way, is to reinstall Magento...just delete the local.xml from app/etc folder and any file e folder from var/ folder.
access your home again and will star over the installation, NOW in the last option “Section Store Option” choose “FILE System”.
Now you can work with your magento.

 
Magento Community Magento Community
Magento Community
Magento Community
 
supriyoalam
Jr. Member
 
Total Posts:  1
Joined:  2013-11-25
 

Following code working for me! Cheers!

ini_set(’session.save_handler’,’files’); // Added this line and it works!
session_start(); // Line #125

 
Magento Community Magento Community
Magento Community
Magento Community
 
akseen
Jr. Member
 
Total Posts:  2
Joined:  2012-10-06
 
supriyoalam - 05 February 2014 07:46 AM

Following code working for me! Cheers!

ini_set(’session.save_handler’,’files’); // Added this line and it works!
session_start(); // Line #125

Instead, do this

file: app\etc\local.xml
Change:
<session_save><![CDATA[db]]></session_save>

to

<session_save><![CDATA[files]]></session_save>

Save and upload.

Then, Delete the below two directories:

var/cache
var/session

Spent hours on this and found solutions in forums with the above scattered around other threads!

 
Magento Community Magento Community
Magento Community
Magento Community
 
akseen
Jr. Member
 
Total Posts:  2
Joined:  2012-10-06
 
thviet - 14 January 2014 02:29 AM

diazwatson - 04 January 2014 07:41 PM
tm1579 - 20 November 2013 08:01 PM
Magento community version 1.8

I replaced local.xml
<session_save><![CDATA[db]]></session_save>
to this
<session_save><![CDATA[files]]></session_save>

Look like it works for me, so far I did not see this error.

It also worked for me on Magento community version 1.8.1[color=blue]

[/color]

i changed but dont’ work.
Please help me.

Delete var/cache and var/session folders

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 2