Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Fatal error: session_start()
 
secondcanvas
Jr. Member
 
Total Posts:  5
Joined:  2009-04-09
 

I installed and re-installed Magento 3x through magento connect and kept getting error 500.  Hosting rep couldnt help me.

Since I didnt know how to upgrade to 1.8.0 from 1.7.0.2 through Magento Connect I got a full download zip file, extracted it and uploaded all folders/files to the server to overwrite.  As there was no activity from the initial installation, I didnt need to save anything.

Per knowledge base, I deleted the var/cache folder but could not find var/session folder.  I dont have one.
When I tried to access my site, I got message saying - site down to maintenance… and ended up deleting a magento.flag file.
When I deleted that file, I got a new message as below.

Fatal errorsession_start() [<a href='function.session-start'>function.session-start</a>]Failed to initialize storage moduleuser (path: /tmpin /home/efirst/public_html/shop/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php on line 125

Please help.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

Is the /tmp partition on your server writable by the web server? Next, what is being used as the session storage? Open app/etc/local.xml and locate the following line:

<session_save><![CDATA[.....]]></session_save>

It could be set to any of the following: db, memcache, files. Make sure it is set to “files”.

Also check if there is a custom <session_save_path> entry present.

 
Magento Community Magento Community
Magento Community
Magento Community
 
secondcanvas
Jr. Member
 
Total Posts:  5
Joined:  2009-04-09
 

thanks so much for a fast response.

locale.xml file has the session set to files.

regarding the /tmp partition, is that the tmp folder in the root folder?  (sorry i’m not too tech saavy; just the designer) i don’t have a tmp folder within the magento folder which is named shop.

also the var/cache folder reappeared.  is this something i need to keep deleting?

 
Magento Community Magento Community
Magento Community
Magento Community
 
secondcanvas
Jr. Member
 
Total Posts:  5
Joined:  2009-04-09
 

forgot…

there is no <session_save_path> entry in the local.xml file
thx

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

It is normal that the var/cache folder is recreated. It stores the cached files used to speed up Magento.

The /tmp partition is configured globally on the server. Based on the error, it seems that Magento is trying to write session data to the /tmp folder. You may want to contact your hosting provider about this, as it may be a configuration issue on their end.

 
Magento Community Magento Community
Magento Community
Magento Community
 
firepoint007
Jr. Member
 
Total Posts:  2
Joined:  2012-10-07
 

I’ve actually the same problem.

My shop is hosted at 1&1;as dedicated managed server.

Did you get the problem solved?

 
Magento Community Magento Community
Magento Community
Magento Community
 
MageOxy
Jr. Member
 
Avatar
Total Posts:  26
Joined:  2010-02-28
 

I know this is not the right way but I changed the core file and added a line, and it works at least!

ini_set('session.save_handler','files'); // Added this line and it works!
session_start(); // Line #125
 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

Instead of modifying the core file directly, you can set the session storage settings in your app/etc/local.xml configuration file. Look for the session_save node and change it accordingly:

<session_save><![CDATA[files]]></session_save>
 
Magento Community Magento Community
Magento Community
Magento Community
 
MageOxy
Jr. Member
 
Avatar
Total Posts:  26
Joined:  2010-02-28
 
Sindre|ProperHost - 03 November 2013 06:40 AM

Instead of modifying the core file directly, you can set the session storage settings in your app/etc/local.xml configuration file. Look for the session_save node and change it accordingly:

<session_save><![CDATA[files]]></session_save>

I am sorry to say, your solution did not work for us.

 
Magento Community Magento Community
Magento Community
Magento Community
 
GoMageTeam
Guru
 
Avatar
Total Posts:  356
Joined:  2013-01-13
Warsaw, Poland
 

Hello,

This answer should help you:

1.  Check local.xml There should be <session_save><![CDATA[files]]></session_save>

2.  Check whether the folder var/cache and the folder permissions should be correct.

 
Magento Community Magento Community
Magento Community
Magento Community
 
toyrc
Jr. Member
 
Total Posts:  1
Joined:  2011-12-09
 

I’m getting the same problem:
session_start() [<a href=’function.session-start’>function.session-start</a>]: Failed to initialize storage module: user (path: /tmp)

Change the session storage to “files” works, but this is not the solution. We really need database storage for sessions.
If you guys know any other idea to fix with DB storage, please let me know!

 
Magento Community Magento Community
Magento Community
Magento Community
 
testemagento01
Jr. Member
 
Total Posts:  1
Joined:  2013-11-18
 

i know a better solution! use OSCOMMERCE!

ok ok , if u really need use this s…

go to https://github.com/colinmollenhour/magento-lite/blob/master/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php

replace your code varien.php and all works!

 
Magento Community Magento Community
Magento Community
Magento Community
 
tm1579
Jr. Member
 
Total Posts:  5
Joined:  2013-10-04
 

Magento community version 1.8

I replaced local.xml
<session_save><![CDATA[db]]></session_save>
to this
<session_save><![CDATA[files]]></session_save>

Look like it works for me, so far I did not see this error.

 
Magento Community Magento Community
Magento Community
Magento Community
 
gcampanholi
Jr. Member
 
Total Posts:  1
Joined:  2011-10-18
 

I deleted the file ‘local.xml’ and reinstall was requested! worked

 
Magento Community Magento Community
Magento Community
Magento Community
 
MasterGent
Jr. Member
 
Total Posts:  1
Joined:  2013-11-24
 
MageOxy - 03 November 2013 03:40 AM

I know this is not the right way but I changed the core file and added a line, and it works at least!

ini_set('session.save_handler','files'); // Added this line and it works!
session_start(); // Line #125

After a few days of struggle. I used your method and it works.

What are the downsides of this fix?

Would love to know the correct fix.

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
OksanaHoffmann
Jr. Member
 
Total Posts:  1
Joined:  2013-05-30
 

Hi guys!

Can somebody help me pleeeease!
I have the same problem, but I also cannot even open the local.xml
It says that it is not correct

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2