Magento Forum

   
Page 1 of 2
How do I fix - “PHP Extension “curl” must be loaded”? 
 
Toby
Jr. Member
 
Total Posts:  4
Joined:  2008-03-25
Salisbury, UK
 

Hi, I am installing Magento 1.0 on a local server using XAMPP. I have put the downloaded files into the correct place, and can get to the localisation setting when I’m setting up Magento. However, when I click continue after that, it says “"PHP Extension “curl” must be loaded” - please set all required settings before clicking continue.”
How can I solve this? I am running windows vista.

Thanks everyone

Toby

 
Magento Community Magento Community
Magento Community
Magento Community
 
radders
Sr. Member
 
Total Posts:  162
Joined:  2008-03-23
 

Enable it by removing the semi-colon before it in php.info. There are several copies of the file in different directories so make sure you adjust the correct file (apache/bin directory I think). Do the same for mcrypt.
Also in apache/conf directory httpd.conf you can enable url rewrite module in a similar way if you like.

You’ll need to restart apache.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Toby
Jr. Member
 
Total Posts:  4
Joined:  2008-03-25
Salisbury, UK
 

I’ve done that, but the same error still comes up. any ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
radders
Sr. Member
 
Total Posts:  162
Joined:  2008-03-23
 

Only to check that you have done it correctly.

 
Magento Community Magento Community
Magento Community
Magento Community
 
roberto2362
Jr. Member
 
Total Posts:  1
Joined:  2008-04-11
 

me too with the same probem :-(.  none has ideas? rolleyes

 
Magento Community Magento Community
Magento Community
Magento Community
 
ukdazza
Guru
 
Total Posts:  308
Joined:  2008-04-16
 

same problem. was trying to edit the files (as suggested) but no luck

 
Magento Community Magento Community
Magento Community
Magento Community
 
ukdazza
Guru
 
Total Posts:  308
Joined:  2008-04-16
 

WORKED!!

I found the ‘curl’ line in the php file in the apache/bin and removed the ‘ ; ‘ and then found the ‘rewrite’module line in the apache/conf/httd.conf file and removed the ‘ # ‘.

Almost got this setup now lol only taken a few days!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
LusoLux
Jr. Member
 
Total Posts:  2
Joined:  2008-05-02
 

It’s still not working for me though! :o(

I’m running Vista and installed Magento on Xampp. I still get the error message “PHP Extension “curl” must be loaded”.

I’ve removed the ; and # - but still get the error.

Please help!

Regards,
Lusolux

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sam Jacob
Jr. Member
 
Total Posts:  2
Joined:  2008-04-29
 

I am getting the same error like
PHP Extension “curl” must be loaded
I have enabled and followed and copied the dll to the system32 folder in XP and i have come down to this single error in loading curl.

Please anyone help me in this. Is there a need to keep up with the .htaccess for the this curl?? to work??

Do help me at the earliest. I am waiting to test with magento rather than virtue mart?

 
Magento Community Magento Community
Magento Community
Magento Community
 
enoc22
Jr. Member
 
Total Posts:  14
Joined:  2009-01-03
 

If it’s any help
I had the same problem, i am using Xampp, i enabled the curl extensions in the folowing --
php-pear.ini, php.ini, and php5.ini in the php directory,
and the php.ini in the apache/bin directory

Oliver

 
Magento Community Magento Community
Magento Community
Magento Community
 
sebmei
Jr. Member
 
Total Posts:  2
Joined:  2009-08-18
 
enoc22 - 02 April 2009 03:55 PM

If it’s any help
I had the same problem, i am using Xampp, i enabled the curl extensions in the folowing --
php-pear.ini, php.ini, and php5.ini in the php directory,
and the php.ini in the apache/bin directory


Oliver

That worked out for me!!! thnx a lot.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Aronson
Jr. Member
 
Total Posts:  1
Joined:  2009-10-15
 

You forgot restart Apache smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
sistro
Jr. Member
 
Total Posts:  1
Joined:  2010-03-28
 

Hi, I had the same problem on LAMP

This is the solution:

sudo apt-get install curl libcurl3 libcurl3-dev php5-curl

Now you have PHP cURL installed, the next thing you need to do is to restart apache2, run the following command in your terminal:

sudo /etc/init.d/apache2 restart

 
Magento Community Magento Community
Magento Community
Magento Community
 
buckmajor
Jr. Member
 
Total Posts:  24
Joined:  2008-11-22
 

I did all this, and now I have this error:

Exception printing is disabled by default for security reasons.

Error log record number: 391846631

Any solution for this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
raja55
Jr. Member
 
Total Posts:  1
Joined:  2009-07-02
 

I had the same problem in XAMPP then i removed `;` before the line extension=php_curl.dll from php.ini in php directory and restarted the xampp now it works fine

 
Magento Community Magento Community
Magento Community
Magento Community
 
tarbantinbookstore
Jr. Member
 
Total Posts:  12
Joined:  2010-07-31
 

1. Search all php.ini file in xampp directory
2. Removed `;` before the line extension=php_curl.dll from php.ini
3. Restarted the xampp now it works fine

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top
Page 1 of 2