Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

1.3.2.3 to 1.3.2.4 Image Upload Not working [SOLVED]
 
Kaya Arseven
Jr. Member
 
Total Posts:  12
Joined:  2009-06-29
 

I have upgraded through Magento Connect. After the update, image upload stopped working. Basically when you click to BROWSE , file browser comes up, you choose an image and click OK. Nothing happens after. No errors, no msgs nothing. Normally you are supposed to see the list of the images waiting for upload but they don’t show up.

I have already changed permissions on MEDIA folder and subfolders from 755 to 777

I have my php.ini file and it already has some of the lines from other related posts regarding the image upload issue.

extension=pdo.so
extension
=pdo_mysql.so
extension
=pdo_sqlite.so 

magic_quotes_gpc 
off
short_open_tag 
on


SecFilterEngine Off
SecFilterScanPOST Off

file_uploads 
On

upload_max_filesize 
2M

By the way I have tried the admin panel in windows ( IE & firefox ) and Mac ( safari ) , I thought it might be the flash player problem but I started having the problem after Magento Connect Update.

Have a nice day folks
Thanks for help in advance.
Kaya

 
Magento Community Magento Community
Magento Community
Magento Community
 
Kammalou
Sr. Member
 
Avatar
Total Posts:  285
Joined:  2009-01-20
Denmark
 

Do you have .htaccess setup to secure your site with htpasswd file authentication ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
blu42media
Member
 
Avatar
Total Posts:  32
Joined:  2008-09-03
Los Angeles, CA
 

My client is having the same issue.  He’s using IE8.  I did similar testing on my version of IE8 (using Parallels) and I’m not having an issue.

I’m going to have him try using developer tools to see if there’s any output on the console and will post it here if we find something.

We welcome anyone’s suggestions for getting this solved!!

Thanks,
John

 
Magento Community Magento Community
Magento Community
Magento Community
 
jbpilatre
Jr. Member
 
Total Posts:  4
Joined:  2009-10-12
Pierrevillers
 

Hello,

Test this module : No Flash Image Uploader in Magento Connect

http://www.magentocommerce.com/extension/1756/no-flash-uploader

This should fix the problem ...

Sorry for my English, I’m french

Regards

Joachim

 
Magento Community Magento Community
Magento Community
Magento Community
 
Kaya Arseven
Jr. Member
 
Total Posts:  12
Joined:  2009-06-29
 
Euklid - 23 October 2009 07:04 AM

Do you have .htaccess setup to secure your site with htpasswd file authentication ?

I have been using the magento’s standard .htaccess file . I haven’t modified it , there is no password protection I believe.

I don’t think it is a browser issue because I have tried admin with all browsers and with different computers. I feel like it is a script issue in the admin.

Any ideas smile ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Kaya Arseven
Jr. Member
 
Total Posts:  12
Joined:  2009-06-29
 

i just spent a full day of work debugging this. make sure your base url, javascript base url and skin base url are all the same or it will simply not work. i don’t know all of the details, but I’m guessing it’s similar to doing an ajax request to a foreign url. even the difference between http://www.example.com/ and http://example.com/ might cause it to break

Jesse
http://www.shopjimmy.com

I had the same Problem. I clicked the button, selected an image in the dir list, push open but nothing happens.

The reason was that i had changed the System->Web->Basis Skin URL | Media URL | javascript URL to refer to a subdomain. This was done because of ServeFromCookielessDomain.

It dose work nicely, but the effect was that in the Magento admin i couldn’t upload any Product images. I didn’t see any javascript error, maybe the flash has some Some Origin Problems, since it itself gets loaded from the subdomain aka static.domain.com/media. I solved the problem by switching the Admin to secure URL. Since i don’t have an valid ssl cert for the subdomain i cannot use the subdomain as secure URL.

So i patched the uploader.phtml to use a relative URL for the Flex.Uploader and after that it worked. But maybe someone should look into the flash app, to fix the problem properly.

Greetings
FDA

Hi guys,

I have found these in the forum. I will try them and see what happens. I have been using a CDN service to host my SKIN folder. I will try to change it back to defaults. Let see if it works .

 
Magento Community Magento Community
Magento Community
Magento Community
 
Kaya Arseven
Jr. Member
 
Total Posts:  12
Joined:  2009-06-29
 

PROBLEM SOLVED.

I have been using that amazon CDN network for hosting my SKIN folder. Let say my SKIN folder was on another server, so my (unsecure) BASE SKIN URL was “http://mac-parts-skin.s3.amazonaws.com/” and (secure) BASE SKIN URL was “{{secure_base_url}}skin/’ . So i thought Magento can get the SKIN data from other server for the frontend. I was expecting that it can get the skin data from my local server since I have “{{secure_base_url}}skin/’ under SECURE urls.

I have chosen YES for ‘Use Secure URLs in Admin’ so it is supposed to use the default url for the admin control images but it was still using the Base Skin URL from unsecure links.

Now I changed it back to defaults and stopped using CDN for my SKIN folder.

AND PROBLEM SOLVED.

Check the images for old config and new config.

My guess is flash stuff is in the skin folder and it makes a problem when you don’t have them in the same server. Other bug is the secure and unsecure urls. Even if I choose YES for ‘Use Secure URLs in Admin’, magento still use unsecure urls for admin.

I hope someone can explain it to me if my logic is wrong. Sorry for my English.

Image Attachments
magento-old.jpgmagento-new.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
elfling
Enthusiast
 
Avatar
Total Posts:  901
Joined:  2008-10-21
 

for the unsecure url.

https:// should be the base url, not http

 
Magento Community Magento Community
Magento Community
Magento Community
 
idsagency
Jr. Member
 
Total Posts:  4
Joined:  2009-11-23
 

had an issue with a fresh install not showing image uploaded.
im on host gator reseller. using ver1.32

installed the extensions from jbpilatre and it works awesome !!1

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sivabalan Magento
Jr. Member
 
Total Posts:  9
Joined:  2010-11-03
 

Guys!!

Just enable Use SID on Frontend from Session Validation Settings under Admin->Configuration->Web

Thats it.

Cheers!!!!!!!!!!!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
zaknaphein600rr
Jr. Member
 
Total Posts:  1
Joined:  2012-10-01
 

I realize this is an old thread, but thought someone someday could use the info.

I had this same problem.  The source was that I was switching from serving content locally to serving it from a CDN (Cloudfront to be exact).  The problem has to do with cross domain security issues.  In my case, I was loading the uploader SWF from the CDN and then trying to use it to make changes on my server, resulting in a security issue.  I talked to a Flash programmer friend of mine who pretty much confirmed this is the case.

To get around this, I simply edited app/design/adminhtml/default/default/template/media/uploader.html

I changed this line:

<?php echo $this->getJsObjectName() ?> = new Flex.Uploader('<?php echo $this->getHtmlId() ?>''<?php echo $this->getUploaderUrl('media/uploader.swf') ?>'<?php echo $this->getConfigJson() ?>);

To this:

<?php echo $this->getJsObjectName() ?> = new Flex.Uploader('<?php echo $this->getHtmlId() ?>''<?php echo 'http://www.mydomain.com/skin/adminhtml/default/default/media/uploader.swf' ?>', <?php echo $this->getConfigJson() ?>);

And it solved my problem.

Incidently, I was having this problem with Magento 1.6 and it seems like Magento 1.7 takes care of it for you.  But hey, if you’re running 1.6 with no plans to upgrade to 1.7 in the future, this is the way I’d go!

 
Magento Community Magento Community
Magento Community
Magento Community
 
hergonof
Jr. Member
 
Total Posts:  10
Joined:  2013-04-10
 

The issue loading images in many cases is due to the copy of the site from the root to a subdirectory.
Below is the solution, simple and effectiveness.
Thanks for the post.

I realize this is an old thread, but thought someone someday could use the info.

I had this same problem.  The source was that I was switching from serving content locally to serving it from a CDN (Cloudfront to be exact).  The problem has to do with cross domain security issues.  In my case, I was loading the uploader SWF from the CDN and then trying to use it to make changes on my server, resulting in a security issue.  I talked to a Flash programmer friend of mine who pretty much confirmed this is the case.

To get around this, I simply edited app/design/adminhtml/default/default/template/media/uploader.html

I changed this line:
<?php echo $this->getJsObjectName() ?> = new Flex.Uploader(’<?php echo $this->getHtmlId() ?>’, ‘<?php echo $this->getUploaderUrl('media/uploader.swf') ?>’, <?php echo $this->getConfigJson() ?>);
To this:
<?php echo $this->getJsObjectName() ?> = new Flex.Uploader(’<?php echo $this->getHtmlId() ?>’, ‘<?php echo 'http://www.mydomain.com/skin/adminhtml/default/default/media/uploader.swf' ?>’, <?php echo $this->getConfigJson() ?>);
And it solved my problem.

Incidently, I was having this problem with Magento 1.6 and it seems like Magento 1.7 takes care of it for you.  But hey, if you’re running 1.6 with no plans to upgrade to 1.7 in the future, this is the way I’d go!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top