Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Ogone implementatie
 
Asjer Querido
Jr. Member
 
Total Posts:  6
Joined:  2009-10-03
 

Wie kan ik inhuren om een probleem op te lossen met een Ogone implementatie?

We zijn al een heel eind, de transactie verloopt prima, maar het onderdeel blijft nog in de winkelwagen zitten, dus Magento krijgt geen transactiefeedback van Ogone.

Dit probleem moet dit weekend worden opgelost, iemand tijd en zin (en kundig)? Stuur me even een mailtje naar

 
Magento Community Magento Community
Magento Community
Magento Community
 
Appmerce
Guru
 
Avatar
Total Posts:  376
Joined:  2008-05-13
Amsterdam, The Netherlands
 

Welke module gebruik je? Die oude van egwada?

Ik heb gisteren een verbeterde Ogone module gemaakt: http://www.magentocommerce.com/extension/2100

Werkt prima. Die oude module van egwada heeft inderdaad problemen met de terugkeer-url, success acties etc.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Asjer Querido
Jr. Member
 
Total Posts:  6
Joined:  2009-10-03
 

Bedankt voor de snelle reactie!

Toevallig had ik de module gespot en direct geïnstalleerd op een testserver met een schone installatie, werkte perfect! Vervolgens heb ik het bij de productie versie geprobeerd, maar kreeg direct al een error. Ik stuitte nog tegen een klein probleem, maar dat was gauw opgelost. Nu rest er nog één probleem, hopelijk kan je me vertellen waar het fout gaat.

Alles verloopt vlekkeloos, worden netjes naar de Ogone pagina verwezen, betaling komt ook aan bij Ogone, maar bij de terugkoppeling gaat het fout, en stuiten we op een 404 pagina, de pagina bestaat niet.

De configuratie pagina bij Ogone staat goed en instellingen van de module ook, enig idee hoe we dit kunnen oplossen?

Alvast bedankt!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Appmerce
Guru
 
Avatar
Total Posts:  376
Joined:  2008-05-13
Amsterdam, The Netherlands
 

Die 404 zie ik ook gebeuren als ik mijn store url meestuur. Als dit het geval is, moet je de links per store aanpassen in Magento, dus configuratie > betaalwijzen en zet dan links bovenaan de dropdown op de juist store.

Bijv. als “dutch” je store code is dan worden de urls iets als “{{store_url}}dutch/ogone/result/success” dus dan met dutch ertussen.

Misschien lag het daar aan. Heb de module overigens vandaag geupdate. zodat bovenstaande mogelijk is.

 
Magento Community Magento Community
Magento Community
Magento Community
 
fragilem17
Member
 
Total Posts:  56
Joined:  2009-02-15
 

Beste Morningtime,

bedankt voor je module, ik gebruikte de aangepaste iDeal module om te werken met ABN-Amro iDeal internetkassa.
alles werkt goed, maar 3 op de 100 bestellingen gaan mis, de factuur is aangemaakt maar het totaal bedrag staat op 0, terwijl bij de klant alles wel goed is gegaan en het geld op de rekening staat. Wij kunnen echter deze order niet meer inboeken… kan deze bug echt neit vinden ( jij een idee? ) dus ik dacht, ik geeft jouw module een keer een kans grin

hij draait maar heb een re-direct probleem.

zodra er een cancel request gaat vanuit ABN-amro

dan is mijn url zo:
http://www....mijnwebsite...nl/internetkassa/result/cancel

en het resultaat is:
Fatal error: Call to a member function cancel() on a non-object in /..../magento/app/code/core/Mage/Sales/Model/Order.php on line 605

geen idee waar ik het debuggen moet starten.

bedankt voor een eventueel pointer in de juiste richting.

 
Magento Community Magento Community
Magento Community
Magento Community
 
fragilem17
Member
 
Total Posts:  56
Joined:  2009-02-15
 

als ik manueel naar de success surf dan krijg ik dit…
de pearLib ‘magento connect’ installatie failde de eerste keer.. mogelijk dat er ergens iets van config niet goed staat?

Unable detect system directory: report

 
Magento Community Magento Community
Magento Community
Magento Community
 
amijnders
Jr. Member
 
Total Posts:  1
Joined:  2009-09-21
 
fragilem17 - 22 December 2009 10:10 AM

als ik manueel naar de success surf dan krijg ik dit…
de pearLib ‘magento connect’ installatie failde de eerste keer.. mogelijk dat er ergens iets van config niet goed staat?

Unable detect system directory: report

Is deze error inmiddels al opgelost? Wij hebben nu namelijk bij een installatie de zelfde fatal error melding.

-- Fatal error: Call to a member function cancel() on a non-object in /home/allebenodigdheden.nl/public_html/magento/app/code/core/Mage/Sales/Model/Order.php on line 605

 
Magento Community Magento Community
Magento Community
Magento Community
 
ODL
Jr. Member
 
Total Posts:  14
Joined:  2009-05-11
 

Ben ook erg benieuwd of er inmiddels een oplossing is voor deze error.

Momenteel wordt de bezoeker doorgestuurd naar de betaalpagina van betreffende bank, waar ook een succesvolle betaling kan worden gedaan. Echter wanneer de bezoeker wordt teruggestuurd (naar ‘http://www.domein.nl/internetkassa/result/success’) wordt de volgende foutmelding gegeven (uit error log): “Geen HTML antwoord! Er ontbreken POST/GET variabelen in de terugkeer-URL.”.

In de functie (_checkResponse, regel 86, ResultController.php) die deze exception teruggooit wordt de variabele ‘$this->_internetkassaResponse’ opgevraagd, maar die bestaat niet.

Als ik het goed heb, moet deze variabele in de functie ‘successAction’ (regel 296, ResultController.php) worden gezet, alleen worden er geen POST/GET variabelen meegestuurd ( $this->getRequest()->getParams() == NULL ).

Dat is ongeveer wat ik heb kunnen vinden, waarom er geen variabelen worden meegestuurd is voor mij een vraag.
Ik hoop dat Morningtime hier nieuw licht op kan schijnen?

 
Magento Community Magento Community
Magento Community
Magento Community
 
robnnl
Jr. Member
 
Total Posts:  16
Joined:  2009-04-06
 
ODL - 29 March 2010 09:00 AM

Ben ook erg benieuwd of er inmiddels een oplossing is voor deze error.

Momenteel wordt de bezoeker doorgestuurd naar de betaalpagina van betreffende bank, waar ook een succesvolle betaling kan worden gedaan. Echter wanneer de bezoeker wordt teruggestuurd (naar ‘http://www.domein.nl/internetkassa/result/success’) wordt de volgende foutmelding gegeven (uit error log): “Geen HTML antwoord! Er ontbreken POST/GET variabelen in de terugkeer-URL.”.

In de functie (_checkResponse, regel 86, ResultController.php) die deze exception teruggooit wordt de variabele ‘$this->_internetkassaResponse’ opgevraagd, maar die bestaat niet.

Als ik het goed heb, moet deze variabele in de functie ‘successAction’ (regel 296, ResultController.php) worden gezet, alleen worden er geen POST/GET variabelen meegestuurd ( $this->getRequest()->getParams() == NULL ).

Dat is ongeveer wat ik heb kunnen vinden, waarom er geen variabelen worden meegestuurd is voor mij een vraag.
Ik hoop dat Morningtime hier nieuw licht op kan schijnen?

ik heb ook geen hmlt antwoord error, exact hetzelfde.
heb alleen de ogone module ipv internetkassa module gebruikt (wel van morningtime) maar dus ook een fout.

 
Magento Community Magento Community
Magento Community
Magento Community
 
dawitte
Jr. Member
 
Total Posts:  8
Joined:  2009-03-24
 

Aangezien ik zelf de afgelopen week bezig ben geweest met de installatie van Ogone had ik dezelfde problemem zoals hierboven omschreven.

Hierop heb ik de officiele extensie van Ogone geinstalleerd en vervolgens van de onderstaande post de instellingen overgenomen. ( behalve natuurlijk de SHA1 ).

http://www.magentocommerce.com/boards/viewthread/69224/

Het werkte meteen perfect en zonder problemen.

gr. Hans

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top