Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problème avec mon addRouter
 
polis4r
Jr. Member
 
Total Posts:  4
Joined:  2012-11-19
 

Hello à tous smile

J’ai besoin d’un petit coup de mains avec mon addRouter. Je tente de réécrire mes URL de wishlist au format /mawishlist-id.html.
J’ai crée mon Router, editer mon fichier de config.xml comme indiqué dans les nombreux posts que l’on peut voir à ce sujet mais rien n’y fait ..

Je vous donne les fichiers en questions vos yeux d’expert pourront surement m’aider smile

Config.xml (en dessous mon models dans le global)

<events>
    <
controller_front_init_routers>
        <
observers>
            <
wishlist>
                <class>
BBT_Wishlist_Controller_Router</class>
                <
method>initControllerRouters</method>
            </
wishlist>
        </
observers>
    </
controller_front_init_routers>
</
events>

Router.php

class BBT_Wishlist_Controller_Router extends Mage_Core_Controller_Varien_Router_Abstract {

    
public function initControllerRouters$observer )
    
{
        $front 
$observer->getEvent()->getFront();
        
$front->addRouter('wishlist'$this);
    
}

    
public function match(Zend_Controller_Request_Http $request)
    
{
        var_dump
('match'); die();
    
}
}

Merci d’avance smile
p.

 
Magento Community Magento Community
Magento Community
Magento Community
 
polis4r
Jr. Member
 
Total Posts:  4
Joined:  2012-11-19
 

Avec un autre name dans mon addRouter cela fonctionne parfaitement comme par exemple avec “cms”

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top