Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problems with magento HTTP and HTTPS links
 
nnszabolcs
Jr. Member
 
Total Posts:  5
Joined:  2010-03-19
 

We are using magento and also buyd an ssl certificate.
We have a lot of internal link for landing pages and also have url rewrites opened for capitalization problems for example if i access.
www.mysite.com/Sample is going to www.mysite.com/sample
the problem is when i trying to acces the website like: https://www.mysite.com/sample is automaticaly going to www.mysite.com
There is no redirects! how can i fix this problem? Also there is browsers where is working and browsers where not.
live example:

all of this links should go to this address: www.gamucci.com/mirror
http://www.gamucci.com/mirror - ok
https://www.gamucci.com/mirror - redirecting to www.gamucci.com
https://gamucci.com/mirror - ok
In firefox is working all of this links, and in google chrome is still redirecting.

can anyone help us please?!

 
Magento Community Magento Community
Magento Community
Magento Community
 
rberezewski
Jr. Member
 
Total Posts:  1
Joined:  2013-10-30
 

You can always go to my Blog http://www.cigstars.net/ then it will redirect you to the site..

 
Magento Community Magento Community
Magento Community
Magento Community
 
Monty_iLM
Guru
 
Total Posts:  450
Joined:  2013-11-05
 

Hi,

Check this tread http://stackoverflow.com/questions/7947030/nginx-no-www-to-www-and-www-to-no-www

Hope this will help you!!

Thanks

Monty
iLoveMage

 
Magento Community Magento Community
Magento Community
Magento Community
 
SimpleHelixcom
Enthusiast
 
Avatar
Total Posts:  906
Joined:  2007-08-31
Huntsville, AL
 

Hello nnszabolcs,

The redirect is happening because of Magento’s auto-redirect base URL settings. You can disable this which should resolve the redirect issue. To disable it, log in to your Magento Admin Dashboard and navigate to System > Configuration. Under the General heading on the left side, select “Web” and then click on “Url Options” towards the upper middle section of the screen. There is an option here called “Auto-redirect to Base URL.” Change this option to “No” and save the config. You should now be able to navigate to HTTPS pages on your site without being redirected to HTTP pages. I hope this helps!

 
Magento Community Magento Community
Magento Community
Magento Community
 
nChannel
Guru
 
Avatar
Total Posts:  329
Joined:  2012-02-28
 

We’ve seen this issue with clients and even our own site from time to time. In the past we’ve put canonical tags on the https version pointing to the http page.

Darren
http://www.nchannel.com

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top