Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

SSL Always on
 
nam37
Jr. Member
 
Total Posts:  8
Joined:  2007-09-26
 

I’ve got a new install up and running on a Windows Web Server 2008 with PHP running under FastCGI and MySQL, but for some reason, the URLs are always https://.

When I installed Magento, I choose the “don’t use ssl” setting (forgot the exact words).

My Admin Panel settings are:

Unsecure
UnsecureBase URL {{base_url}}
Base Link URL {{unsecure_base_url}}
Base Skin URL {{unsecure_base_url}}skin/
Base Media URL {{unsecure_base_url}}media/
Base JavaScript URL {{unsecure_base_url}}js/

Secure
SecureBase URL {{base_url}}
Base Link URL {{secure_base_url}}
Base Skin URL {{secure_base_url}}skin/
Base Media URL {{secure_base_url}}media/
Base JavaScript URL {{secure_base_url}}js/
Use Secure URLs in Frontend No
Use Secure URLs in Admin No

I’ve done two installs now, and I’ve had the same issue both times.

Could this be a non-apache (IIS) issue?  If so, does anyone have a work-around before I start hacking code?

(Note, I’ve already played with the cache settings. In fact, I’ve currently disabled the cache system.)

I’ve also tried set following settings and it is still not working:

Unsecure
UnsecureBase URL http://67.109.XXX.XXX/
Base Link URL http://67.109.XXX.XXX/
Base Skin URL http://67.109.XXX.XXX/skin/
Base Media URL http://67.109.XXX.XXX/media/
Base JavaScript URL http://67.109.XXX.XXX/js/

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lior
Magento Team
 
Avatar
Total Posts:  293
Joined:  2007-09-24
 

For now try just to put:
http://67.109.XXX.XXX/
Instead of the base URL in the secure and none secure sections of the configurations

 
Magento Community Magento Community
Magento Community
Magento Community
 
nam37
Jr. Member
 
Total Posts:  8
Joined:  2007-09-26
 
Lior - 07 April 2008 08:09 AM

For now try just to put:
http://67.109.XXX.XXX/
Instead of the base URL in the secure and none secure sections of the configurations

Thanks.  That seems to have fixed it.  Will the system still be able to go into SSL for a secure checkout, or will that be broken now?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lior
Magento Team
 
Avatar
Total Posts:  293
Joined:  2007-09-24
 

at the moment all links will be going to the non secure location.
if you want to use SSL in the secure base URL you will have to use https instead of http

Try to do the change and see that you are not getting to the https on the none secure pages.

 
Magento Community Magento Community
Magento Community
Magento Community
 
nam37
Jr. Member
 
Total Posts:  8
Joined:  2007-09-26
 
Lior - 07 April 2008 08:49 AM

at the moment all links will be going to the non secure location.
if you want to use SSL in the secure base URL you will have to use https instead of http

Try to do the change and see that you are not getting to the https on the none secure pages.

It’s very strange. If I set it to:

Unsecure
UnsecureBase URL http://67.109.XXX.XXX/

Secure
SecureBase URL https://67.109.XXX.XXX/

The URLs (links between pages) work fine, but the included files (images, JS,...) all have https:// paths

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lior
Magento Team
 
Avatar
Total Posts:  293
Joined:  2007-09-24
 

Does your configuration looks like this at the moment:
Unsecure
UnsecureBase URL http://67.109.XXX.XXX/
Base Link URL {{unsecure_base_url}}
Base Skin URL {{unsecure_base_url}}skin/
Base Media URL {{unsecure_base_url}}media/
Base JavaScript URL {{unsecure_base_url}}js/

Secure
SecureBase URL https://67.109.XXX.XXX/
Base Link URL {{secure_base_url}}
Base Skin URL {{secure_base_url}}skin/
Base Media URL {{secure_base_url}}media/
Base JavaScript URL {{secure_base_url}}js/
Use Secure URLs in Frontend Yes
Use Secure URLs in Admin No

 
Magento Community Magento Community
Magento Community
Magento Community
 
nam37
Jr. Member
 
Total Posts:  8
Joined:  2007-09-26
 
Lior - 07 April 2008 10:38 AM

Does your configuration looks like this at the moment:
Unsecure
UnsecureBase URL http://67.109.XXX.XXX/
Base Link URL {{unsecure_base_url}}
Base Skin URL {{unsecure_base_url}}skin/
Base Media URL {{unsecure_base_url}}media/
Base JavaScript URL {{unsecure_base_url}}js/

Secure
SecureBase URL https://67.109.XXX.XXX/
Base Link URL {{secure_base_url}}
Base Skin URL {{secure_base_url}}skin/
Base Media URL {{secure_base_url}}media/
Base JavaScript URL {{secure_base_url}}js/
Use Secure URLs in Frontend Yes
Use Secure URLs in Admin No

Almost, everything is the same except:

Use Secure URLs in Frontend No

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lior
Magento Team
 
Avatar
Total Posts:  293
Joined:  2007-09-24
 

PM me your admin login and I will try to check it for you

 
Magento Community Magento Community
Magento Community
Magento Community
 
l_mahoney
Jr. Member
 
Total Posts:  8
Joined:  2008-04-04
 

Please check out my post to thread http://www.magentocommerce.com/boards/viewthread/5576/. Maybe that will help.

 
Magento Community Magento Community
Magento Community
Magento Community
 
nam37
Jr. Member
 
Total Posts:  8
Joined:  2007-09-26
 
l_mahoney - 14 April 2008 06:43 AM

Please check out my post to thread http://www.magentocommerce.com/boards/viewthread/5576/. Maybe that will help.

Thanks.  That looks like the solution.  I’ll try it out when I get a chance.

Did you have to install a mod_rewrite add-on for IIS, or is your install working OK without one?

 
Magento Community Magento Community
Magento Community
Magento Community
 
l_mahoney
Jr. Member
 
Total Posts:  8
Joined:  2008-04-04
 

I am using ISAPI_Rewrite.

 
Magento Community Magento Community
Magento Community
Magento Community
 
etho201
Sr. Member
 
Total Posts:  85
Joined:  2008-04-03
Summerville, SC
 

Try going to: System --> Cache Management

Then uncheck Configuration.

Clear out your browsers history and reload your page and see if that fixed the problem… It seems to have worked for me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
fred5000
Jr. Member
 
Total Posts:  14
Joined:  2008-05-28
 

I was having a problem with firefox saying unauthenticated content.  I took the advice and unchecked blocks and config in cache management and I don’t get ssl warnings anymore.  Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
fred5000
Jr. Member
 
Total Posts:  14
Joined:  2008-05-28
 

I was having a problem with firefox saying unauthenticated content.  I took the advice and unchecked blocks and config in cache management and I don’t get ssl warnings anymore.  Thanks.  You can check at http://bcsolarstore.com or https://bcsolarstore.com

 
Magento Community Magento Community
Magento Community
Magento Community
 
ktsixit
Member
 
Total Posts:  68
Joined:  2008-08-20
 

after reading this thread i have a question, if i don’t choose SSL during the installation, what happens with the payment and order pages? And if I do choose secure url’s, will all the pages be https? Cause this slows down browsing and it is not necessary for simple pages.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top