Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Additional Info
 
Charles
Member
 
Avatar
Total Posts:  73
Joined:  2008-03-27
Belgium
 

Hi,
I’d like to show the additional info next to the image of a product.
What I did is modify the product/type/simple.phtml file and add the following code in product/type/simple.phtml

<?php $_additional $this->getAdditionalData(); ?>

<div>
  <
div>
    
<?php echo $this->__('Additional Information'?>
  
</div>
  <
div>

    <
table cellspacing="0" class="data-table" id="product-attribute-specs-table">
      
<?php foreach ($_additional as $_data): ?>
      
<tr>
        <
td class="label">
          
<?php echo $_data['label'] ?>
        
</td>
        <
td class="data">
          
<?php echo $_data['value'] ?>
        
</td>
      </
tr>
      
<?php endforeach; ?>
    
</table>
    <
script type="text/javascript">decorateTable('product-attribute-specs-table')</script>

  
</div>
</
div>

The code is exactly the same as what I found in product/wiew.phtml.

However, upon running, it seems that $_additional doesn’t get set.

If I perform an echo $this in product/view/simple.phtml I get product.info.simple
If I perform an echo $this in product/view.phtml, I get product.info
So I guess that there is a slight difference and that getAdditionalData() doesn’t work on a product.info.simple instance.

How can I make getAdditionalData() work on product.info.simple ???

Thanks,

Charles

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top