Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Site Broken Links
 
coreworm
Jr. Member
 
Total Posts:  11
Joined:  2007-12-31
 

Got Magento 1.0 installed.

The admin module is working fine so far.
As for the main site, the first page is ok; I can see the Magento Demo Store but the rest of the links are “Not Found”.

Example:

Not Found
The requested URL /magento/customer/account/ was not found on this server.

Not Found
The requested URL /magento/wishlist/ was not found on this server.

Not Found
The requested URL /magento/contacts/ was not found on this server.

Before diving into deep debugging, anyone know the likely cause of this?

Thanks in advance.

 
Magento Community Magento Community
Magento Community
Magento Community
 
srinigenie
Guru
 
Avatar
Total Posts:  539
Joined:  2008-02-04
 

What happens when you refresh the page once you get the page not found error?

 
Magento Community Magento Community
Magento Community
Magento Community
 
mcr072378
Jr. Member
 
Total Posts:  5
Joined:  2008-04-03
 

this happen to me when I first installed it.  Check your apache vhost configuration.  Mine was fixed by making sure DocumentRoot was going to PATH/magento and then a restart of apache cleared it up.

mcr

 
Magento Community Magento Community
Magento Community
Magento Community
 
coreworm
Jr. Member
 
Total Posts:  11
Joined:  2007-12-31
 

I did your suggestion. Now the error messages become “The webpage cannot be found”.

It seems like there’s CGI or server side scripts such as /catalogsearch,
/poll, etc, do we need to map these urls explicitly or how does the
Magento process these server side scripts?

 
Magento Community Magento Community
Magento Community
Magento Community
 
calyx
Jr. Member
 
Total Posts:  3
Joined:  2008-04-09
 

I had this same problem.  My issue was with mod rewrite.  I had to disable it in the Magento Admin.  Check out this thread on how to enable/disable mod rewrite:  http://www.magentocommerce.com/boards/viewthread/4829/

 
Magento Community Magento Community
Magento Community
Magento Community
 
coreworm
Jr. Member
 
Total Posts:  11
Joined:  2007-12-31
 

I tried the methods but still getting the same results…
Do I need to do a reinstall?

I am using CentOS. Anyone has got issues with this variant?

 
Magento Community Magento Community
Magento Community
Magento Community
 
srinigenie
Guru
 
Avatar
Total Posts:  539
Joined:  2008-02-04
 

See if this helps
http://www.magentocommerce.com/boards/viewthread/5717/

 
Magento Community Magento Community
Magento Community
Magento Community
 
coreworm
Jr. Member
 
Total Posts:  11
Joined:  2007-12-31
 

Hi All,

I have re-read the forum and found that to disable the rewrite in the Magento Admin Module.
Miss that one out. Wonder why Magento set it to enable by default?

Now the store works and can proceed to real work now.

Thanks all that reply!

 
Magento Community Magento Community
Magento Community
Magento Community
 
jblancov
Jr. Member
 
Total Posts:  1
Joined:  2014-03-30
 

Hi all, I think the issue is related with mod_rewrite (It is good for SEO), this steps help me:

Apache module must be enabled:

a2enmod rewrite

In the Virtualhost the directive AllowOverride needs to be set to something like that:

AllowOverride All

For instance:

<Directory /var/www/user1/>
        
Options Indexes FollowSymLinks MultiViews
        AllowOverride All
        Order allow
,deny
        allow from all
    
</Directory>

Then apache can process the .htaccess file located in /var/www/user1/ (in the example) and subfolders, now we assume that in the directory /var/www/user1/magento are the magento files, then we need to edit the file /var/www/user1/magento/.htaccess and in the section:

<IfModule mod_rewrite.c>

############################################
## enable rewrites

    
Options +FollowSymLinks
    RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

    #RewriteBase /magento/

Remove the ‘#’

RewriteBase /magento/

Finally restart apache service and try.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top