Magento Forum

   
Magento crashed (explained with details)
 
baseckas
Jr. Member
 
Total Posts:  2
Joined:  2013-01-02
 

Hello,

I would like to appologize if this might look as a duplicate, but I won\’t (because I already searched as much as I can find)…

Recently my magento website crashed, and maybe you could help me find the source, because I am completely desperate…

Here are some details:
It started few days ago, I kept getting \"Internal server error\” randomly, and with time it got intense. I found this in apache error log:

[Wed Sep 11 09:19:19 2013] [error] [client 188.69.226.233] (104)Connection reset by peerFastCGIcomm with server \"/usr/local/fastcgi/cgi-bin/php-cgi\" abortedread failed
[Wed Sep 11 09
:19:19 2013] [error] [client 188.69.226.233] FastCGIincomplete headers (0 bytesreceived from server \"/usr/local/fastcgi/cgi-bin/php-cgi\"

In host cpanel I found that I have exceeded limit of php processes. Well, ok lame host, but that wasn\’t enough for me, so I decided to adjust..
Changed permission of every folder to 755 and files to 644
Changed permission of index.php from 644 to 755 and vica versa
Edited .htaccess, even replaced with .sample
php_memory_limit set to 256M
Changed php version from 5.3 to 5.4 (and eventually back to 5.3)
Cleared cache dozens of times.

After making each of these changes I clearly remember checking website - same random \"Internal server error\”, but today - magento loads only half of index page, admin page doesn\’t load at all - blank page.

I tried to enable error reporting - no effect.

Here is how website looks now... - content is completely missing (sidebar menu, custom cms, product categories, produtcs...)
I would understand if php scripts stopped working, therefore website fails to load, but there is a Joomla on the same host that works fine. So this Magento “half page load” makes completely no sense....

Any thoughts?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top