Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Shared SSL results in Invalid PHP Version
 
blankman373
Jr. Member
 
Avatar
Total Posts:  4
Joined:  2008-04-05
 

Hey guys,

I stumbled upon Magento Commerce while looking for an alternative shopping cart for one of my clients, as they were unhappy with their current one (Miva Merchant). I must say, it is one hell of a job, and am very excited about putting it into production.

A little about my client’s setup, it is on shared Server, using php 4, mySQL and a shared SSL. i was able to get it installed using the php-cgi workaround and got everything setup, products, pricing, etc. Just have the design left.

My problem is that whenever I enable Secure URLs on the frontend, any links that require the SSL gives me the following page:

Whoops, it looks like you have an invalid PHP version.
Magento supports PHP 5.2.0 or newer. Find out how to install Magento using PHP-CGI as a work-around.

I tried the 1&1;fix posted many times on the forums by modifying my Magento .htaccess to the following:

#AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

But that did not work. I know the SSL is OK, because it is working on the current cart. I would really like to have SSL enabled, as it adds a sense of confidence for customers when they see the little lock, even though all my payments are going through PayPal.

Any help would be appreciated… Thanks in advance.

-Munawar

 
Magento Community Magento Community
Magento Community
Magento Community
 
txkhomes
Jr. Member
 
Total Posts:  5
Joined:  2008-04-05
United States
 

Have you considered updating to php5 as it is faster and more secure

 
Magento Community Magento Community
Magento Community
Magento Community
 
blankman373
Jr. Member
 
Avatar
Total Posts:  4
Joined:  2008-04-05
 
txkhomes - 05 April 2008 10:52 PM

Have you considered updating to php5 as it is faster and more secure

Would love to, but unfortunately, I dont have that option. This site is hosted by a small company her in SoCal, and my client doesn’t want to change.

Any Ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
jjcapri
Jr. Member
 
Avatar
Total Posts:  15
Joined:  2008-03-17
 

I wonder if this is related to the problem I’m having. I was able to install the last 3 beta versions no problem, but now cannot install 1.0. I’m making the same changes I was before, but now I get the error:

Whoops, it looks like you have an invalid PHP version.

Magento supports PHP 5.2.0 or newer. Find out how to install Magento using PHP-CGI as a work-around.
‘; exit; } $mageFilename = ‘app/Mage.php’; if (!file_exists($mageFilename)) { if (is_dir(’downloader’)) { header("Location: downloader"); } else { echo “app/Mage.php not found”; } exit; } require_once $mageFilename; umask(0); Mage::run(’default’);

....
makes no sense to me!
So far all I’ve done is unzipped the files and placed on the server. I’m trying to run the install.

Did the php file change perhaps? wonder if I have to reupload that to the cgi bin directory.

JJ

 
Magento Community Magento Community
Magento Community
Magento Community
 
jjcapri
Jr. Member
 
Avatar
Total Posts:  15
Joined:  2008-03-17
 

any ideas on this? I still cannot install v1.0. Don’t understand. I installed the last 3 beta versions okay.

JJ

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top